News: Welcome to the TinyPortal Support site.

Login  |  Register
HTML5 Icon HTML5 Icon
TP on Social Media
Welcome, Guest. Please login or register.
Did you miss your activation email?

October 14, 2019, 10:46:29 AM

Login with username, password and session length

Recent

Members
  • Total Members: 3756
  • Latest: Ocean
Stats
  • Total Posts: 189082
  • Total Topics: 20763
  • Online Today: 70
  • Online Ever: 629
  • (November 08, 2018, 01:36:54 PM)
Users Online
Users: 2
Guests: 53
Total: 55

Author Topic: Table 'smf.smf_tp_settings' doesn't exist  (Read 14496 times)

0 Members and 1 Guest are viewing this topic.

Offline thomaswebb

  • Jr. Member
  • **
  • Posts: 6
Table 'smf.smf_tp_settings' doesn't exist
« on: June 03, 2011, 10:04:50 PM »
Link to my site: http://www.eve-blackarmada.com
SMF version: SMF 2.0 RC5 / SMF 1.1.13
TP version: TP 1.1 RC1
Default Forum Language: English
Theme name and version: Default
Browser Name and Version: Google Chrome /IE9
Mods installed: None
Related Error messages: Table 'smf.smf_tp_settings' doesn't exist

I am at an impass here. I cannot figure out what is causing this error. I have MySQL 5 installed, the username used to install SMF has dba permissions, everything else gets modified just fine, however now matter what I do, I always get this error after installing TP. It says that everything installed successfully, however this always comes up.

If it helps, its running off IIS in windows server 2008 RC2, I have php 5, MySQL 5.5, and I have tried it with both SMF 2.0 RC5, and SMF 1.1.13.

Any suggestions?

P.S - When I look at the SQL db, there is no table for smf_tp_settings.. Is there an error in the installation script causing it not to create the DB properly?

Offline IchBin™

  • Developer
  • *
  • Posts: 16228
    • My Website
Re: Table 'smf.smf_tp_settings' doesn't exist
« Reply #1 on: June 04, 2011, 12:36:31 AM »
It seems to be a problem with certain server setups. I posted a sql file that one can run on the SMF site in the TinyPortal support topic which you can import into the database to fix it. I've rewritten the code since then and it shouldn't have the same problem on the next version. If you can't find the file at SMF post back and I'll attach it here when I get a chance.

Online lurkalot

  • Administrator
  • *
  • Posts: 6288
    • Camera Craniums
Re: Table 'smf.smf_tp_settings' doesn't exist
« Reply #2 on: June 04, 2011, 10:32:00 AM »
Just a side note:

This also applies to anyone trying to install TP on a local setup using the latest version of Xampp / Wamp.  ;) 

Offline thomaswebb

  • Jr. Member
  • **
  • Posts: 6
Re: Table 'smf.smf_tp_settings' doesn't exist
« Reply #3 on: June 04, 2011, 06:26:07 PM »
Awesome, I ran the script in phpmyadmin today, and it created the tables and everything is working great!

Thanks!

Offline candyman

  • Jr. Member
  • **
  • Posts: 8
Re: Table 'smf.smf_tp_settings' doesn't exist
« Reply #4 on: August 21, 2011, 08:14:32 PM »
i have the same problem.. i imported database from old SMF 2.0 to a fresh 2.0 install.. i need this script

Offline IchBin™

  • Developer
  • *
  • Posts: 16228
    • My Website
Re: Table 'smf.smf_tp_settings' doesn't exist
« Reply #5 on: August 22, 2011, 08:06:41 AM »
Try the php file I posted in the support board as a sticky for those that upgrade. It should at least create the table if it doesn't exist.

Offline DukeOfAwesome

  • Jr. Member
  • **
  • Posts: 9
Re: Table 'smf.smf_tp_settings' doesn't exist
« Reply #6 on: July 02, 2013, 06:37:34 AM »
Hi,

I am getting the "Table 'smf.smf_tp_settings' doesn't exist" error. I tried your updated version of the tp_update.php file and still no luck. I am using SMF 2.04 with TP v1.0.

I had to install theTP manually after the install package failed.
 
Is there just a SQL script somewhere I can run to create the database tables manually to get around this problem?

Thanks

Duke

Offline IchBin™

  • Developer
  • *
  • Posts: 16228
    • My Website
Re: Table 'smf.smf_tp_settings' doesn't exist
« Reply #7 on: July 02, 2013, 01:37:11 PM »
Please start a new topic in the future. Resurrecting topics that are 2+ years old is not something we want here. If you need to, link to any topic that is related to your topic. If you can't get the tables to install on a fresh install, I'm not sure what to tell you. This will give you the structure of the table, but I'm betting you'll have more problems after getting the table installed. This assumes that you have smf_ as the prefix to your database tables.

Code: [Select]
CREATE TABLE IF NOT EXISTS `smf_tp_settings` (
  `id` mediumint(9) NOT NULL AUTO_INCREMENT,
  `name` text NOT NULL,
  `value` text NOT NULL,
  PRIMARY KEY (`id`)
)

Offline DukeOfAwesome

  • Jr. Member
  • **
  • Posts: 9
Re: Table 'smf.smf_tp_settings' doesn't exist
« Reply #8 on: July 02, 2013, 06:08:08 PM »
Hi,

Thanks for that. That worked, but now I get the error:

Table 'smf.smf_tp_articles' doesn't exist

Can you please provide me with a script that creates the entire database required by Tiny Portal?

Many thanks

Duke

Offline IchBin™

  • Developer
  • *
  • Posts: 16228
    • My Website
Re: Table 'smf.smf_tp_settings' doesn't exist
« Reply #9 on: July 02, 2013, 10:26:30 PM »
This is not going to help you. If you are missing the tables, what about all the data that gets set by default when TP installs? There are a ton of settings that TP sets as well as some default data that will be missing if you only create the tables that are needed. You need to figure out why your host is not allowing TP to install properly.