News: TinyPortal Release Schedule. Please read this update for More Info.

Login  |  Register
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media
Welcome, Guest. Please login or register.
Did you miss your activation email?

April 06, 2020, 02:46:18 PM

Login with username, password and session length

Recent

Members
Stats
  • Total Posts: 189583
  • Total Topics: 20808
  • Online Today: 71
  • Online Ever: 917
  • (January 21, 2020, 09:02:26 AM)
Users Online
Users: 2
Guests: 42
Total: 44

Author Topic: Homepage (portal) Not showing on mobile devices ?  (Read 4673 times)

0 Members and 1 Guest are viewing this topic.

Offline TinyDick

  • Jr. Member
  • **
  • Posts: 6
Homepage (portal) Not showing on mobile devices ?
« on: July 22, 2013, 10:31:01 AM »
Link to my site: http://www.hobbiesanddiy.com
SMF version: SMF ver. 2.0.4
TP version: TP ver. 1
Default Forum Language: English
Theme name and version: Firox multicolor
Browser Name and Version: Android + iOS
Mods installed: none
Related Error messages: none

I installed the tiny portal and all seemed ok, then i posted link to a mate on skype who is using an ipod touch - all he can see are the directory listings - the forums work fine but front page not showing.

I tested on my android phone - same issue, strange as working aok on laptop and desktop machines.

Anyone else come across this ?

Thanks guys

Online lurkalot

  • Administrator
  • *
  • Posts: 6474
    • Camera Craniums
Re: Homepage (portal) Not showing on mobile devices ?
« Reply #1 on: July 22, 2013, 10:42:25 AM »
Got a bit of a redirect problem there methinks.  The address you supplied

http://www.hobbiesanddiy.com   takes you to your server root.  See screengrab

The address for your site front page is .http://hobbiesanddiy.com/forum/index.php

And your forum is http://hobbiesanddiy.com/forum/index.php?action=forum

Just a side note:  You appear to have a very unfortunate user name. I'm hoping for your sake, your name is Richard, and you are quite small.  If not I would be tempted to change it.  O0

Offline TinyDick

  • Jr. Member
  • **
  • Posts: 6
Re: Homepage (portal) Not showing on mobile devices ?
« Reply #2 on: July 22, 2013, 11:49:36 AM »
Hi lurkalot :)

Heres what i did:

installed smf to /forum
installed tiny portal and expected it to be the home page

Would i be correct in assumming i should have installed the forum to the root and then installed portal which would then act as my homepage ?

or can i make the portal the root somehow ? this is what i expected to happen actually.

Thanks for your help

PS its not my real name just what the mrs calls me   :2funny:

Online lurkalot

  • Administrator
  • *
  • Posts: 6474
    • Camera Craniums
Re: Homepage (portal) Not showing on mobile devices ?
« Reply #3 on: July 22, 2013, 12:26:07 PM »

PS its not my real name just what the mrs calls me   :2funny:


Sorry, couldn't resist making a comment.  :D


Would i be correct in assumming i should have installed the forum to the root and then installed portal which would then act as my homepage ?

or can i make the portal the root somehow ? this is what i expected to happen actually.


You can have the site in a sub directory, as you have now.  But set up a redirect.

Do you have cPanel as part of your hosting package?  If so, set up a redirect,

http://www.hobbiesanddiy.com   to  http://hobbiesanddiy.com/forum/index.php

Offline TinyDick

  • Jr. Member
  • **
  • Posts: 6
Re: Homepage (portal) Not showing on mobile devices ?
« Reply #4 on: July 22, 2013, 12:42:56 PM »
Thanks lurkalot,

I reinstalled the forum to the root and reuploaded the portal.

All working sweet now!

You da man :)

Online lurkalot

  • Administrator
  • *
  • Posts: 6474
    • Camera Craniums
Re: Homepage (portal) Not showing on mobile devices ?
« Reply #5 on: July 22, 2013, 12:59:29 PM »
No problem, glad you sorted it. O0

PS: Hope the mrs doesn't call you that in public.  :D