News: When asking for support, it helps us and you, if you read the Posting Guidelines

Login  |  Register
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media
Welcome, Guest. Please login or register.
Did you miss your activation email?

April 02, 2020, 09:45:11 AM

Login with username, password and session length

Recent

Members
Stats
  • Total Posts: 189572
  • Total Topics: 20808
  • Online Today: 625
  • Online Ever: 917
  • (January 21, 2020, 09:02:26 AM)
Users Online
Users: 0
Guests: 41
Total: 41

Author Topic: Inserting images from quicklist does not work in new editor  (Read 3064 times)

0 Members and 1 Guest are viewing this topic.

Offline @rjen

  • Support Team
  • *
  • Posts: 2013
    • FJR-club Nederland
Inserting images from quicklist does not work in new editor
« on: February 17, 2018, 03:09:40 AM »
We noticed that insering images in a TP article from the quicklist does not work anymore in the new editor?
Using "My Images Quicklist"...

It used to be possible to upload an image into the quicklist, and insert it in the article by double-clicking the image. This is no longer working...

I believe a saw a comment before about a diffent approach to adding images in articles with the enw editor?

Using Chrome by the way...
Running TP1.6.4 on SMF2.0 at: www.fjr-club.nl

Testing TP on SMF2.0
Testing TP on SMF2.1 RC2
Want to check what php version I am testing on? See: PHP Info

Offline tino

  • Developer
  • *
  • Posts: 1737
Re: Inserting images from quicklist does not work in new editor
« Reply #1 on: February 17, 2018, 03:35:08 AM »
We noticed that insering images in a TP article from the quicklist does not work anymore in the new editor?
Using "My Images Quicklist"...

It used to be possible to upload an image into the quicklist, and insert it in the article by double-clicking the image. This is no longer working...

I believe a saw a comment before about a diffent approach to adding images in articles with the enw editor?

Using Chrome by the way...

You can drag the image up, but that still doesn't quite work correctly.

There is a new drag and drop option for the SCEditor in the next release.

Offline @rjen

  • Support Team
  • *
  • Posts: 2013
    • FJR-club Nederland
Re: Inserting images from quicklist does not work in new editor
« Reply #2 on: February 17, 2018, 03:44:27 AM »
When I drag and drop it drops the thumbnail, not the large image. Is that what You mean?
Running TP1.6.4 on SMF2.0 at: www.fjr-club.nl

Testing TP on SMF2.0
Testing TP on SMF2.1 RC2
Want to check what php version I am testing on? See: PHP Info

Offline lurkalot

  • Administrator
  • *
  • Posts: 6468
    • Camera Craniums
Re: Inserting images from quicklist does not work in new editor
« Reply #3 on: February 17, 2018, 03:49:35 AM »
We noticed that insering images in a TP article from the quicklist does not work anymore in the new editor?
Using "My Images Quicklist"...

It used to be possible to upload an image into the quicklist, and insert it in the article by double-clicking the image. This is no longer working...

I believe a saw a comment before about a diffent approach to adding images in articles with the enw editor?

Using Chrome by the way...

You can drag the image up, but that still doesn't quite work correctly.

There is a new drag and drop option for the SCEditor in the next release.

Yes, you can drag and drop them from the quicklist into the editor.  Or drag them directly from a images folder on your pc, to the editor.  Applies to 1.4R.

I believe in TP 1.5.0 we will be able to drag images directly from a folder on pc, and the images will also be added to the quicklist, so you add them from there as well. 

Offline tino

  • Developer
  • *
  • Posts: 1737
Re: Inserting images from quicklist does not work in new editor
« Reply #4 on: February 17, 2018, 03:50:41 AM »
When I drag and drop it drops the thumbnail, not the large image. Is that what You mean?

Yes, it doesn't quite work as I would expect.

Offline lurkalot

  • Administrator
  • *
  • Posts: 6468
    • Camera Craniums
Re: Inserting images from quicklist does not work in new editor
« Reply #5 on: February 17, 2018, 03:54:08 AM »
Works as intended regarding that part, the description clearly says,

"My Images Quicklist
The images below are small thumbnails of the original pictures. "

Anything uploaded to the quicklist via the browse button will ad a thumbnail image to the quick list.  The clicking to add to the editor doesn't work, drag and drop does.

Offline tino

  • Developer
  • *
  • Posts: 1737
Re: Inserting images from quicklist does not work in new editor
« Reply #6 on: February 17, 2018, 04:02:21 AM »
True, but it doesn't expand when you click on it like it used to ( I assume it did, I never tried it).

Although that's not part of the description, it is a change in behaviour.

Offline @rjen

  • Support Team
  • *
  • Posts: 2013
    • FJR-club Nederland
Re: Inserting images from quicklist does not work in new editor
« Reply #7 on: February 17, 2018, 04:19:42 AM »
Quote
( I assume it did, I never tried it).

It did, I just tested it in 1.3 to be sure.

With this change in behaviour the explanation text in the edit article page is a bit confusing (The images below are small thumbnails of the original pictures. By clicking them the picture is inserted into the editor. Be sure to click in the editor to make it active before selecting any of the images.)

With the new behaviour the 'My Images Quicklist' in this setup is not usable, since it displays thumbnails and not the full image. Perhaps an idea to change this Quicklist to no longer display the thumbnail but the actual image (resized by css?). With this the explanation text would need to be updated to explain the drag-and-drop behavior...
Running TP1.6.4 on SMF2.0 at: www.fjr-club.nl

Testing TP on SMF2.0
Testing TP on SMF2.1 RC2
Want to check what php version I am testing on? See: PHP Info

Offline lurkalot

  • Administrator
  • *
  • Posts: 6468
    • Camera Craniums
Re: Inserting images from quicklist does not work in new editor
« Reply #8 on: February 17, 2018, 04:31:20 AM »
Quote
( I assume it did, I never tried it).

It did, I just tested it in 1.3 to be sure.

With this change in behaviour the explanation text in the edit article page is a bit confusing (The images below are small thumbnails of the original pictures. By clicking them the picture is inserted into the editor. Be sure to click in the editor to make it active before selecting any of the images.)

With the new behaviour the 'My Images Quicklist' in this setup is not usable, since it displays thumbnails and not the full image. Perhaps an idea to change this Quicklist to no longer display the thumbnail but the actual image (resized by css?). With this the explanation text would need to be updated to explain the drag-and-drop behavior...

Agreed, we need to change the description, but first we need to get a system that works easily.  This quicklist idea has always been a bit hit and miss since day one.  It's been something on my wish list for ages.  A image manager = Some way to upload and find images to use in articles and blocks, or even forum posts, come to think of it. 

Offline tino

  • Developer
  • *
  • Posts: 1737
Re: Inserting images from quicklist does not work in new editor
« Reply #9 on: February 17, 2018, 04:43:59 AM »
Try the attached file with fixes to the various issues raised today.

Rename the .zip to .tar.gz as I can't upload it as a .tar.gz