TP-Docs
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media

Recent

Welcome to TinyPortal. Please login or sign up.

Members
Stats
  • Total Posts: 196,004
  • Total Topics: 21,330
  • Online today: 141
  • Online ever: 8,223 (February 19, 2025, 04:35:35 AM)
Users Online
  • Users: 0
  • Guests: 108
  • Total: 108

SQL goes away when deleting topic/post

Started by netsyphon, August 23, 2006, 10:45:33 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

netsyphon

here is the message i get on the page after i remove a topic:
Database Error: Lost connection to MySQL server during query
File: /sites/flashmob.shacknet.nu/Sources/Subs.php
Line: 419


mysql err file shows this:
Current dir: /var/mysql/
Running threads: 0  Stack size: 196608
Current locks:
lock: 0x82f0323c:
lock: 0x7e91023c:
lock: 0x7d4a723c:
lock: 0x8908d23c:
lock: 0x86e6223c:
lock: 0x8a2afa3c:

Key caches:
default
Buffer_size:       8388600
Block_size:           1024
Division_limit:        100
Age_limit:             300
blocks used:             0
not flushed:             0
w_requests:              0
writes:                  0
r_requests:              0
reads:                   0

handler status:
read_key:            0
read_next:           0
read_rnd             0
read_first:          3
write:               0
delete               0
update:              0

Table status:
Opened tables:         12
Open tables:            6
Open files:            13
Open streams:           0

Alarm status:
Active alarms:   0
Max used alarms: 0
Next alarm time: 0
mysqld got signal 11;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=8388600
read_buffer_size=131072
max_used_connections=20
max_connections=100
threads_connected=8
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_connections = 225791 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.


my OS is OpenBSD 3.9 with php5/mysql (all packages not ports).

it seems that this error destroys all connections to the database from all of my web apps.  simply restarting apache/mysql does NOTHING.  the server must be reboot to resolve this issue.  im suspecting that this is an issue with either my binary distribution or perhaps a 'bad' query.  if you have any ideas, i am glad to hear!

TIA,

G6Cad

That is something you have to contact your host and let them solve for you. It's not TP related at all.
Removing posts are also something for SMF to give you support on as boards and posts are in the SMF and not TP ;)

netsyphon

this is my box on a co-lo so i have pretty much full responsibility.

i did install a fresh copy and can delete stuff with ease, so it must be something with the size of the db or the query thats killing mysql.

appreciate the advice, ill post this in smf and see if any devs wanna peek at line 419 :)

netsyphon

issue was a bug in openbsd 3.9 package mysql-server-5.0.18.

i upgraded to 5.0.22 and the issue went away.

saved by ktrace :)

G6Cad

Thank you for post the cause of the error when you found out :)
This can be good help for others :)

IchBin

Quote from: netsyphon on August 24, 2006, 07:30:47 AM
issue was a bug in openbsd 3.9 package mysql-server-5.0.18.

i upgraded to 5.0.22 and the issue went away.

saved by ktrace :)
Thats great you found the answer. If you don't mind me asking, how do you like BSD? I've never tried a BSD distro....

netsyphon

in terms of security openbsd cant be beat.  i dont really mess around too much with other bsd distros (other than my OSX).

There is so much that this OS can do with only a ~300mb full installation footprint :)

the best firewalls ive seen are openbsd, not to mention that most 'security appliances' are really bsd kernels!

my only issue with the distro i use is that the maintainer refuses to use apache 2.0 for some reason :(

check it out, look at the faq, try a default install and see how well planned the system is by default! http://openbsd.org  O0

This website is proudly hosted on Crocweb Cloud Website Hosting.