News: TinyPortal Release Schedule. Please read this update for More Info.

Login  |  Register
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media
Welcome, Guest. Please login or register.
Did you miss your activation email?

April 08, 2020, 02:47:43 AM

Login with username, password and session length

Recent

Members
  • Total Members: 3777
  • Latest: Mike
Stats
  • Total Posts: 189583
  • Total Topics: 20808
  • Online Today: 56
  • Online Ever: 917
  • (January 21, 2020, 09:02:26 AM)
Users Online
Users: 0
Guests: 32
Total: 32

Author Topic: Articles don't like the " in the subject lines  (Read 1240 times)

0 Members and 1 Guest are viewing this topic.

Offline wildenborch

  • Support Team
  • *
  • Posts: 347
Articles don't like the " in the subject lines
« on: June 30, 2018, 04:42:26 AM »
Hi all,

I just noticed that the article subject lines don't accept "

For example, if my subject line would be: Lurkalot's new single "playing my guitar in the garden" released on 7" 10 & 12" (and which we all want to buy  ;D)

it will be - after saving - reduced to: Lurkalot's new single

Is there a reason for this or is this simply a bug? Since this forum topic accepts the " I assume it's a bug (at least I hope it is and that this can be corrected).


« Last Edit: June 30, 2018, 07:26:14 AM by wildenborch »

Offline tino

  • Developer
  • *
  • Posts: 1738
Re: Articles don't not like the " in the subject lines
« Reply #1 on: June 30, 2018, 05:55:55 AM »
That would be a bug...

I'm moving this to a hidden board as I think it means the data isn't escaped properly and therefor could lead to SQL injection.

I can't test atm as I don't have a development box, but will look at it as soon as I can.

Offline wildenborch

  • Support Team
  • *
  • Posts: 347
Re: Articles don't not like the " in the subject lines
« Reply #2 on: June 30, 2018, 06:18:32 AM »
Thank you Tino for the reply.

I just checked it with older TP versions and also there the problem exists.


Offline tino

  • Developer
  • *
  • Posts: 1738
Re: Articles don't like the " in the subject lines
« Reply #3 on: June 30, 2018, 01:01:57 PM »
Thank you Tino for the reply.

I just checked it with older TP versions and also there the problem exists.



It's not as bad I thought, just need to encode the data before displaying it to the browser, fix done in 1.5.1

https://github.com/tinoest/TinyPortal/commit/40a833936473b4e952ca9addcd1aaebd2839e874#diff-dc090e0c3ea42cad6c933b2407e887a9R1993

Offline wildenborch

  • Support Team
  • *
  • Posts: 347
Re: Articles don't like the " in the subject lines
« Reply #4 on: June 30, 2018, 01:40:01 PM »
Super!

Offline lurkalot

  • Administrator
  • *
  • Posts: 6474
    • Camera Craniums
Re: Articles don't like the " in the subject lines
« Reply #5 on: July 01, 2018, 03:41:40 AM »
Thank you Tino for the reply.

I just checked it with older TP versions and also there the problem exists.



It's not as bad I thought, just need to encode the data before displaying it to the browser, fix done in 1.5.1

https://github.com/tinoest/TinyPortal/commit/40a833936473b4e952ca9addcd1aaebd2839e874#diff-dc090e0c3ea42cad6c933b2407e887a9R1993

Thank you tino, glad this wasn't as bad as first thought. Surprised it hadn't cropped up before though, especially if it's been there for a while. Thanks also to wildenborch for bringing it to light.

Offline wildenborch

  • Support Team
  • *
  • Posts: 347
Re: Articles don't like the " in the subject lines
« Reply #6 on: July 01, 2018, 10:02:02 AM »
This is just to confirm that the " issue is indeed solved in TP 1.5.1

Offline tino

  • Developer
  • *
  • Posts: 1738
Re: Articles don't like the " in the subject lines
« Reply #7 on: July 01, 2018, 12:56:56 PM »
This is just to confirm that the " issue is indeed solved in TP 1.5.1

Thanks, moved to Fixed Bugs