News: When asking for support, it helps us and you, if you read the Posting Guidelines

Login  |  Register
HTML5 Icon HTML5 Icon
TP on Social Media
Welcome, Guest. Please login or register.
Did you miss your activation email?

October 18, 2019, 07:45:03 PM

Login with username, password and session length

Recent

Members
  • Total Members: 3756
  • Latest: Ocean
Stats
  • Total Posts: 189090
  • Total Topics: 20764
  • Online Today: 73
  • Online Ever: 629
  • (November 08, 2018, 01:36:54 PM)
Users Online
Users: 0
Guests: 43
Total: 43

Author Topic: TP installation stops SMF 2.0.2 from running  (Read 4222 times)

0 Members and 1 Guest are viewing this topic.

Offline keyrocks

  • Jr. Member
  • **
  • Posts: 13
TP installation stops SMF 2.0.2 from running
« on: January 22, 2012, 08:38:38 PM »
Hello:
I installed SMF 2.0.2 on my localhost machine running XAMPP Windows XP Pro.
The installation went smoothly and the package runs great.
I then downloaded and installed the Tiny Portal package using the file-set in the SMF2 folder. I completed the file mods as per instuctions.

I could not understand how to run the tp_upgrade.php file so I used information in the d-base table arrays to create an SQL file and imported the file successfully in phpMyAdmin to create the tables in the d-base... they are all prefixed with smf_ .

Now I cannot access the home page at all.
Using URL - http://localhost/ef20forums/index.php?action=profile;u=1;area=theme
returns this error message:
undefined function tpcheckadminareas() in ...\Sources\Subs.php on line 4036
- Removing the mod section has no effect.

Any assistance provided will be greatly appreciated.  :'(

Offline IchBin™

  • Developer
  • *
  • Posts: 16228
    • My Website
Re: TP installation stops SMF 2.0.2 from running
« Reply #1 on: January 22, 2012, 09:14:33 PM »
Why are you not installing using the package manager? There should be no need to do anything manually unless your server doesn't allow it.

Offline keyrocks

  • Jr. Member
  • **
  • Posts: 13
Re: TP installation stops SMF 2.0.2 from running
« Reply #2 on: January 23, 2012, 07:28:14 AM »
Thanks IchBin.
Are you saying that I should not have completed the steps manually as shown on this page:
http://custom.simplemachines.org/mods/index.php?action=parse;mod=97;attach=194209;smf_version=2.0.2
From that page, it appeared to me I was to do the file mods as shown, and add the new files to their respective directories as shown at the end of the page.

Should I now remove all of the mods and the tables I added to the d-base (using my scratch-built SQL file), and remove all of the files I copied into their respective directories... then install the packaging using the package manager from the Admin area?

If so, how would I prepare the package for installation (after un-zipping it) so that it would install from the package manager... I have it unzipped in another location on another hard-drive, not in my localhost/ef20forums (project root).

Offline IchBin™

  • Developer
  • *
  • Posts: 16228
    • My Website
Re: TP installation stops SMF 2.0.2 from running
« Reply #3 on: January 23, 2012, 09:36:38 AM »
If you only have installed TP, then I would revert all the changes by restoring the files for SMF back to original state. After that, to install TP with the package manager, you don't need to do anything but go to the download page for the package manager, select the zip file to install. SMF will do the rest for you. It will unzip the file on the server, make all the file edits, and install the database information.

Offline keyrocks

  • Jr. Member
  • **
  • Posts: 13
Re: TP installation stops SMF 2.0.2 from running
« Reply #4 on: January 23, 2012, 05:20:30 PM »
Absolutely correct! I meant to post this earlier this morning because I did exactly what you suggested... reversed the mods, deleted my tables from the d-base, deleted the files I had transferred manually (to respective folders). SMF returned to normal (of course). I didn't post earlier as I had to run out for a day-long meeting.  8)

I should have spent more time exploring SMF's Admin area BEFORE attempting to add TP because I hadn't yet checked out the "Package Manager"... If I had I wouldn't have posted here at all. Running the TP install was too quick and easy. This is my first install of SMF... lots to learn yet.

Once again, thanks for the assistance. Greatly appeciated.

Offline IchBin™

  • Developer
  • *
  • Posts: 16228
    • My Website
Re: TP installation stops SMF 2.0.2 from running
« Reply #5 on: January 23, 2012, 06:32:59 PM »
But now you know why SMF is so cool. :) Glad you figured it all out!

Offline G6Cad

  • Friends
  • *
  • Posts: 12643
    • FamiljeGodis
Re: TP installation stops SMF 2.0.2 from running
« Reply #6 on: January 31, 2012, 12:29:17 PM »
We all been there  :2funny:  I remeber when i forst got that blank page telling me that i must have done something wrong, but WHAT wrong hahahaha
Anyway, thank you for posting back and good luck