News: TinyPortal Release Schedule. Please read this update for More Info.

Login  |  Register
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media
Welcome, Guest. Please login or register.
Did you miss your activation email?

November 22, 2019, 06:04:00 AM

Login with username, password and session length

Recent

Members
Stats
  • Total Posts: 189262
  • Total Topics: 20773
  • Online Today: 60
  • Online Ever: 629
  • (November 08, 2018, 01:36:54 PM)
Users Online
Users: 0
Guests: 49
Total: 49

Author Topic: install problems  (Read 3178 times)

0 Members and 1 Guest are viewing this topic.

brygida

  • Guest
install problems
« on: March 13, 2006, 01:59:28 AM »
Hello,

I have installed SMF and try to upload TinyPortal,

I get this message:

An Error Has Occurred!
2: copy(/home/ctpsbe/public_html/portal/Themes/default/languages/TPmodules.english.php): failed to open stream: Permission denied
File: /home/ctpsbe/public_html/portal/Sources/Subs-Package.php
Line: 961 

Could someone tell me how to fix it?

thanks a lot in advance for any tiny help :)
brygida

Offline G6Cad

  • Friends
  • *
  • Posts: 12643
    • FamiljeGodis
Re: install problems
« Reply #1 on: March 13, 2006, 02:49:43 AM »
Via FTP go in and change the permission to the file that is called and not writable to atleast 755 or 777

brygida

  • Guest
Re: install problems
« Reply #2 on: March 13, 2006, 05:01:16 AM »
hi,

thanks a lot for reaktion !

I have done 777 on the
Sources/Subs-Package.php

and nothing changes ...

I have followed instructions from smf online manual docuwiki:
The following files need to be CHMOD'ed to 777:

attachments
avatars
Packages
Packages/installed.list
Packages/server.list
Smileys
Themes
Themes/default/languages/Install.english.php
agreement.txt
Settings.php
Settings_bak.php
install.php


Should "Sources" be chmoded also?

and here the report I get in my TP :
should all 11 files have "Success" ?

Package Manager - Install Actions
Install Actions for archive Tinyportal0_86.zip:
Installing this package will perform the following actions:
   Type   Action   Description
1.   Extract Tree   ./Themes   
2.   Extract Tree   ./Sources   
3.   Extract Tree   ./wysiwyg   
4.   Extract Tree   ./tp-downloads   
5.   Execute Code   tp_install.php   
6.   Execute Modification   ./index.php   Success
7.   Execute Modification   ./Sources/Load.php   Success
8.   Execute Modification   ./Themes/default/index.template.php   Success
9.   Execute Modification   ./Sources/Subs.php   Success
10.   Execute Modification   ./Sources/ManagePermissions.php   Success
11.   Execute Modification   ./Sources/Security.php   Success



Thank you for answering,
hope I will succed this install,
brygida

WebMasterZ

  • Guest
Re: install problems
« Reply #3 on: March 13, 2006, 05:21:06 AM »
Your report above is fine
What version of smf have you installed?
what version of TP are you trying to install & How?

brygida

  • Guest
Re: install problems
« Reply #4 on: March 13, 2006, 06:24:56 AM »
hi and thanks for your message!
it is nice to see answers coming  :)

I am trying to install the Tinyportal0_86 on SMF 1.0.6.
by the Package Manager

thanks for any insight

Offline IchBin™

  • Developer
  • *
  • Posts: 16228
    • My Website
Re: install problems
« Reply #5 on: March 13, 2006, 07:24:58 AM »
The following line that you posted in your first post is telling me that your host has the server setup with some security restricions that won't allow you to install the mod. Perhaps PHP is in safe mode on your server, I don't know. I would suggest you contact your host and ask them.

Code: [Select]
2: copy(/home/ctpsbe/public_html/portal/Themes/default/languages/TPmodules.english.php): failed to open stream: Permission denied

brygida

  • Guest
Re: install problems
« Reply #6 on: March 13, 2006, 07:41:43 AM »
hm, my host...

he is a resseller and knows less than me about  :-\

thanks anyway !
br

Offline IchBin™

  • Developer
  • *
  • Posts: 16228
    • My Website
Re: install problems
« Reply #7 on: March 13, 2006, 07:43:03 AM »
You can try the manual install. I think I have a link in my sig.

--edit--
I don't have a link. But all you need to do is download the manual install package. Run the install.php file by pointing your addressbar in your browser to it, then upload the files to your server.
« Last Edit: March 13, 2006, 07:45:07 AM by IchBinâ„¢ »

brygida

  • Guest
Re: install problems
« Reply #8 on: March 13, 2006, 07:47:07 AM »
yeap,
I will try the manual install of TP

thanks!