News: Welcome to the TinyPortal Support site.

Login  |  Register
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media
Welcome, Guest. Please login or register.
Did you miss your activation email?

January 19, 2020, 03:51:44 AM

Login with username, password and session length

Recent

Members
Stats
  • Total Posts: 189417
  • Total Topics: 20794
  • Online Today: 63
  • Online Ever: 781
  • (January 16, 2020, 02:42:13 PM)
Users Online
Users: 1
Guests: 57
Total: 58

Author Topic: TPsubs.template.php language file errors  (Read 11831 times)

0 Members and 1 Guest are viewing this topic.

supportingactors

  • Guest
TPsubs.template.php language file errors
« on: May 16, 2010, 01:59:05 AM »
TPsubs.template.php has three places in which it calls on $txt['..'] variables that don't exist:

at line 92 and 113, $txt['by'] should be $txt[525]
at 1674: $txt['on'] should be $txt[30]

This should fix the relevant problems some were seeing with "Undefined index..." errors in the Forum Error Log

Offline IchBin™

  • Developer
  • *
  • Posts: 16228
    • My Website
Re: TPsubs.template.php language file errors
« Reply #1 on: May 16, 2010, 08:55:17 AM »
Assuming you''re using SMF1.x.xx ? What version of TP ?

$txt['by'] comes from this line:  (line 35)
Themes/default/languages/TPShout.english.php:$txt['by'] = 'by';

$txt['on'] I think needs to be fixed.

supportingactors

  • Guest
Re: TPsubs.template.php language file errors
« Reply #2 on: May 16, 2010, 10:07:32 AM »
Yes, using SMF 1.1.11, upgraded TP from .983 to 1.0b5-1 (partially manually)

I do see it in the TPShout.english.php, but I do not have the shout box loaded -- nor does it seem like that's where the language variable should be defined. It's more likely supposed to be in TPortal.English.php after line 23 "// Articles... //" -- where there's a 'tp-by' in line 27 which could be used for the ['by'] in the TPsubs template-- although "by" already seems to be a standard SMF language item.
« Last Edit: May 16, 2010, 10:18:22 AM by supportingactors »

supportingactors

  • Guest
Re: TPsubs.template.php language file errors
« Reply #3 on: May 16, 2010, 10:56:50 AM »
Another one: in line 1752 $txt['in'] should probably be $txt['tp-incategory']

Is no one else getting these?

Enemy1

  • Guest
Re: TPsubs.template.php language file errors
« Reply #4 on: May 24, 2010, 03:30:24 PM »
Im getting them as well ...

using SMF 1.1.11, upgraded TP from .983 to 1.0b5-1

Quote
Unable to load the 'main_above' template.
« Last Edit: May 24, 2010, 11:55:37 PM by Enemy1 »

Offline stog

  • Jr. Member
  • **
  • Posts: 18
Re: TPsubs.template.php language file errors
« Reply #5 on: July 12, 2010, 11:36:42 AM »
brilliant - many thx - has so far fixed(fingers crossed) the myriad of undefined index errors i was getting

been looking for this fix for ages

cheers :)

Offline stog

  • Jr. Member
  • **
  • Posts: 18
Re: TPsubs.template.php language file errors
« Reply #6 on: July 13, 2010, 06:03:23 AM »
ok i am still getting errors - fewer but still 3 error pages a day

Offline IchBin™

  • Developer
  • *
  • Posts: 16228
    • My Website
Re: TPsubs.template.php language file errors
« Reply #7 on: July 13, 2010, 09:05:02 AM »
Perhaps you could start your own topic with the separate errors you are getting. Following our posting guide lines so we know what versions of everything you're using etc.

Posting Guidelines

Offline stog

  • Jr. Member
  • **
  • Posts: 18
Re: TPsubs.template.php language file errors
« Reply #8 on: July 13, 2010, 12:58:24 PM »

Offline stog

  • Jr. Member
  • **
  • Posts: 18
Re: TPsubs.template.php language file errors
« Reply #9 on: July 15, 2010, 01:57:48 AM »
tp 1 beta 5.1 on 1.1.11 (upgraded from 0.98 via beta4 etc - described elsewhere)
attached a screenshot of typical errors