News: September 21st, 2019, The Tinyportal team is pleased to announce the release of ~~ TinyPortal 1.6.4! GET IT NOW!!!

Login  |  Register
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media
Welcome, Guest. Please login or register.
Did you miss your activation email?

November 18, 2019, 07:50:11 PM

Login with username, password and session length

Recent

Members
Stats
  • Total Posts: 189259
  • Total Topics: 20772
  • Online Today: 332
  • Online Ever: 629
  • (November 08, 2018, 01:36:54 PM)
Users Online
Users: 0
Guests: 105
Total: 105

Author Topic: Problem with index.php  (Read 17854 times)

0 Members and 1 Guest are viewing this topic.

Offline IchBin™

  • Developer
  • *
  • Posts: 16228
    • My Website
Re: Problem with index.php
« Reply #20 on: March 15, 2006, 10:18:36 AM »
Veleno, make sure you have these lines in your httpd.conf

Code: [Select]
AddType application/x-httpd-php .php .phtml
AddType application/x-httpd-php .php3
AddType application/x-httpd-php-source .phps

If you don't have those, I'm pretty sure that is your problem.

crip

  • Guest
Re: Problem with index.php
« Reply #21 on: March 15, 2006, 10:21:37 AM »
But without those would SMF work without TP?

Offline IchBin™

  • Developer
  • *
  • Posts: 16228
    • My Website
Re: Problem with index.php
« Reply #22 on: March 15, 2006, 10:25:06 AM »
I'm not sure exactly how it works Crip. I think that sometimes uploading files to a server weither it be via SMF or FTP it can set the file type kind of screwy. If things are not set exactly right in the server it can have issues with certain files types. This is something you really would notice in the early days of Firefox. If the mime-types weren't set properly on servers for files, it would try to open them instead of display them. That's what makes me thing this is server related.

crip

  • Guest
Re: Problem with index.php
« Reply #23 on: March 15, 2006, 11:14:37 AM »
OK..i do understand now.. it's like tyring to snatch someones Js.script, instead of opening it.. wants you to download it..i gotcha now.

Veleno

  • Guest
Re: Problem with index.php
« Reply #24 on: March 16, 2006, 09:50:55 AM »
Hi guys ,

i founded the solution!!!

It wasn't a mime type problem, if so no one php file could be executed.

looking in the apache log files i founded a memory error! infact php has a 8mb memory limit for each script, so load.php , when smf is installed with portals, generates a out of memory error!!!

i put the limit to 16mb in php.ini , restarted web server and now all runs very well!!!

now i've only a little problem, i can't use any tp theme. Left and right bars appers only if i use the smf default theme.

any idea??

i thank you for helping me.

Bye,
Veleno

Offline IchBin™

  • Developer
  • *
  • Posts: 16228
    • My Website
Re: Problem with index.php
« Reply #25 on: March 16, 2006, 10:31:17 AM »
Glad you found it! That is great news, and a good learning lesson for many. :)

Your theme problem is because you only have the SMF version of the themes. There are the same themes made for SMF+TP. A link is in my sig for you to download.

Veleno

  • Guest
Re: Problem with index.php
« Reply #26 on: March 16, 2006, 02:03:14 PM »
i don't know how to thank you for helping me... truelly i'm very happy now that i know TP and this very nice comunity.

Thanks to the staff for helping me ...

i will be very happy to install TP in many other sites ...

My compliments to all