TP-Docs
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media

Recent

Welcome to TinyPortal. Please login or sign up.

June 05, 2023, 08:18:19 AM

Login with username, password and session length
Members
  • Total Members: 3,864
  • Latest: Joonoz
Stats
  • Total Posts: 194,365
  • Total Topics: 21,157
  • Online today: 106
  • Online ever: 3,540
  • (September 03, 2022, 01:38:54 AM)
Users Online
Users: 0
Guests: 75
Total: 75

Ãœbersicht -> Forum schaltet nicht um (Default-Template)

Started by nehcregit, April 05, 2006, 06:00:28 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

nehcregit

Nachdem die Installation recht mühelos klappte, fÃÆ'Ã,¤llt mir auf, dass beim Umschalten zwischen "ÃÆ'Ã...“bersicht" und "Forum" der Reiter nicht wechselt. Ein Schönheitsfehler, jetzt weiÃÆ'Ã...¸ ich auch, warum die index.template.php angemeckert wurde.

Seltsamerweise schaut sie aber gut aus, wenn ich mir sie anschaue. Kann mal jemand drüberschauen?

feline

Da ist wohl ein kleiner Fehler drin ...

ersetze:

if($settings['TPortal_front_type']!='boardindex')
// Show the [forum] button.
echo ($current_action=='forum' || $context['browser']['is_ie4']) ? '<td class="maintab_active_first">&nbsp;</td>' : '' , '
<td valign="top" class="maintab_' , $current_action=='forum' ? 'active_back' : 'back' , '">
<a href="', $scripturl, '?action=forum">FORUM</a>
</td>' , $current_action=='forum' ? '<td class="maintab_active_last">&nbsp;</td>' : '';


durch

if($settings['TPortal_front_type']!='boardindex')
// Show the [forum] button.
echo ($current_action=='forum' || $context['browser']['is_ie4']) ? '<td class="maintab_active_' . $first . '">&nbsp;</td>' : '' , '
<td valign="top" class="maintab_' , $current_action=='forum' ? 'active_back' : 'back' , '">
<a href="', $scripturl, '?action=forum">FORUM</a>
</td>' , $current_action=='forum' ? '<td class="maintab_active_' . $last . '">&nbsp;</td>' : '';


Damit sollte es klappen.

Fel

nehcregit

Nö... Er schaltet erst um, wenn ich in ein Board reingehe. Wenn ich im Index des Forums bin, bleibt der Reiter "ÃÆ'Ã...“bersicht" aktiv  ???

feline

Hmmm .. ich glaub da fehlt noch was ...


if (in_array($context['current_action'], array('search', 'admin', 'calendar', 'profile', 'mlist', 'register', 'login', 'help', 'pm','arcade')))


da müsste wohl noch 'forum' zugefügt werden.

Fel

nehcregit