News: Welcome to the TinyPortal Support site.

Login  |  Register
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media
Welcome, Guest. Please login or register.
Did you miss your activation email?

April 02, 2020, 09:09:03 AM

Login with username, password and session length

Recent

Members
Stats
  • Total Posts: 189572
  • Total Topics: 20808
  • Online Today: 381
  • Online Ever: 917
  • (January 21, 2020, 09:02:26 AM)
Users Online
Users: 0
Guests: 345
Total: 345

Author Topic: Blocks and Articles issues  (Read 13918 times)

0 Members and 1 Guest are viewing this topic.

Oldiesmann

  • Guest
Blocks and Articles issues
« on: February 15, 2005, 09:35:41 AM »
Playing around with Tinyportal now (http://smf.oldiesmann.us/tinyportal) and found a couple problems.

I created a block, then went in to edit it and specify who could see it. After that, the block was displayed twice.

Also, I created an article with intro text. The "Read more..." link doesn't work.

Bjørn

  • Guest
Re: Blocks and Articles issues
« Reply #1 on: February 15, 2005, 12:46:59 PM »
Yes, the permission don't work properly, I recently discovered... It will be fixed in the next release.

And you are right...the readmore just show the intro again instead of full page.

NightOwl

  • Guest
Re: Blocks and Articles issues
« Reply #2 on: February 16, 2005, 08:21:29 AM »
Seems this is a hot request of the permission issue.

I am looking forward for it as well.

Nice work and wish I could help with my limit knowledge.

NightOwl

  • Guest
Re: Blocks and Articles issues
« Reply #3 on: February 21, 2005, 09:33:08 AM »
Seems editing arcticles doesn't save after I'd clicked "send". Any solutions for this?

NightOwl

  • Guest
Re: Blocks and Articles issues
« Reply #4 on: February 21, 2005, 09:40:48 AM »
Another suggestion about blocks:

I think it will be nice if pre-made blocks can be made which works identical with Forums stats(Info Center). So the forum can concenstrate on displaying Forums only.

Bjørn

  • Guest
Re: Blocks and Articles issues
« Reply #5 on: February 21, 2005, 09:45:39 AM »
I am testing it out now..it seems to be something with IE. When you try to save articles, do you have any articles from before? 

Bjørn

  • Guest
Re: Blocks and Articles issues
« Reply #6 on: February 21, 2005, 09:46:43 AM »
Yes, i was thinking about about adding built-in blocks for the events and stats there...not sure it will in this beta though.

NightOwl

  • Guest
Re: Blocks and Articles issues
« Reply #7 on: February 21, 2005, 09:53:03 AM »
I am testing it out now..it seems to be something with IE. When you try to save articles, do you have any articles from before? 

Only the default articile there. Fisrt time, I think it failed cause I didn't give a topic name to the new article. Then try next time with a topic name and it doesn't saved any changes I've made on the default "type content here".

Humm.. I might try to do it with Opera instead see if that works out.

NightOwl

  • Guest
Re: Blocks and Articles issues
« Reply #8 on: February 21, 2005, 09:57:21 AM »
Yes, no-IE browser works. This made IE more odd again. hehe.

I think that only work without the AplosRTE editor not used by Opera
« Last Edit: February 21, 2005, 10:03:16 AM by NightOwl »

Bjørn

  • Guest
Re: Blocks and Articles issues
« Reply #9 on: February 21, 2005, 11:12:50 AM »
strange. It works fine with me in both IE and Mozilla. What kind of IE do you have ? IE 6 for PC?

NightOwl

  • Guest
Re: Blocks and Articles issues
« Reply #10 on: February 21, 2005, 12:27:26 PM »
IE6 on Win2k. The lastest release.

Bjørn

  • Guest
Re: Blocks and Articles issues
« Reply #11 on: February 21, 2005, 03:13:52 PM »
Thats what I use as well. Like win2k better than xp in fact...

I am not sure what could cause it, since mine works - can't replicate the problem - but if I should guess, it could be something with the javascripting involved in the WYSIWYG editor.

I chose AplosRTE because it fast and lightweight and support both IE and Mozilla, but there are at least 2-3 others that can do that as well.

Anyhow, I am setting up an option of not using the editor, just a plain box that accepts html code. Just to allow those who do have problems to write articles still. You could just use a browser that will not show the editor too..I know Opera will not, but that means  installing it, if you don't have it already...

NightOwl

  • Guest
Re: Blocks and Articles issues
« Reply #12 on: February 22, 2005, 10:12:22 AM »
Guess I've found something about the problem in Error log

Code: [Select]
8: Undefined index: bkedit
File: LINK-MASKED-OUT\Themes\default\TPortalBlocks.template.php (eval?)
Line: 422
« Last Edit: February 22, 2005, 10:16:24 AM by NightOwl »

Bjørn

  • Guest
Re: Blocks and Articles issues
« Reply #13 on: February 22, 2005, 10:59:02 AM »
That variable is no longer used, so it may be better in the next beta.

danolie

  • Guest
Re: Blocks and Articles issues
« Reply #14 on: February 23, 2005, 04:03:54 PM »
Yeah... appears to be something w/IE. I'm running IE 6 with win xp. It allows me to create articles and delte them, but no body text is saved.

I switched to Firefox and am able to do it just fine. For now will just use Firefox for adding articles.

Dan

wise

  • Guest
Re: Blocks and Articles issues
« Reply #15 on: February 25, 2005, 02:21:28 AM »
edit: it does work with Firefox - not IE though.
« Last Edit: February 25, 2005, 04:33:15 AM by wise »

NightOwl

  • Guest
Re: Blocks and Articles issues
« Reply #16 on: March 01, 2005, 11:18:13 AM »
Here is another serious problem.

I have 21 articles.

The TPadmin can only display 20 articles and the missing one is un-accessable.
So I can't edit or delete it without removing other article to made space for it to show up again.

Also, is there any way I can change the article size limits? I just mean a little personal modification is fine, guess that only my presonal need.
« Last Edit: March 02, 2005, 04:25:16 AM by NightOwl »

borgBOB

  • Guest
Re: Blocks and Articles issues
« Reply #17 on: March 05, 2005, 12:15:39 AM »
Thats what I use as well. Like win2k better than xp in fact...

I am not sure what could cause it, since mine works - can't replicate the problem - but if I should guess, it could be something with the javascripting involved in the WYSIWYG editor.

I chose AplosRTE because it fast and lightweight and support both IE and Mozilla, but there are at least 2-3 others that can do that as well.

Anyhow, I am setting up an option of not using the editor, just a plain box that accepts html code. Just to allow those who do have problems to write articles still. You could just use a browser that will not show the editor too..I know Opera will not, but that means  installing it, if you don't have it already...

What's wrong with the coding that is used in posts?  Like when I 'reply' to this post I have many of the same options your WYSIWYG editor offers.

Just a questions from someone removed from the project.

Bjørn

  • Guest
Re: Blocks and Articles issues
« Reply #18 on: March 05, 2005, 01:02:12 AM »
"Removed from the project"...? What do you mean?

No, its nothing wrong with using BBC codes..its just more difficult to write articles in it..typically when you need some tables and pictures aligned properly to the left/right. Thats why I put in the WYSIWYG. The next beta will have the option of using a plain box for html codes in addition to the editor.

NightOwl

  • Guest
Re: Blocks and Articles issues
« Reply #19 on: March 07, 2005, 03:14:47 AM »
8: Undefined variable: mg
File: Path edited\Themes\default\TPortalBlocks.template.php (eval?)
Line: 403

Just to inform another repeative error.

borgBOB

  • Guest
Re: Blocks and Articles issues
« Reply #20 on: March 07, 2005, 09:54:12 PM »
"Removed from the project"...? What do you mean?



I mean I am not personally involved with writing the code. I did not create this great thing as you have done.

About all I can do is offer suggestions...humbly.  I am "removed' from ownership of the work.

You know I love it, I am using it on 2 different boards.


Bjørn

  • Guest
Re: Blocks and Articles issues
« Reply #21 on: March 08, 2005, 03:01:37 AM »
ah..I see. :)

NightOwl

  • Guest
Re: Blocks and Articles issues
« Reply #22 on: March 12, 2005, 04:25:25 AM »
Besides of planning with giving non-admins to manage articles, I want ask about is there any plan on giving permission to a certian group to access articles, like editing them etc.

Bjørn

  • Guest
Re: Blocks and Articles issues
« Reply #23 on: March 12, 2005, 07:11:44 AM »
It won't make this upcoming beta, but def. in the next. I am aiming for submitting articles for membergroups, editing your own of course, and giving also some groups admin right in just articles.