Login  |  Register
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media

Recent

Welcome, Guest. Please login or register.
Did you miss your activation email?

January 19, 2021, 09:13:34 PM

Login with username, password and session length
Members
Stats
  • Total Posts: 191734
  • Total Topics: 20939
  • Online Today: 139
  • Online Ever: 1035
  • (November 26, 2020, 04:45:12 AM)
Users Online
Users: 0
Guests: 47
Total: 47

Author Topic: Weird text issue and text color change for dark themes/shout box  (Read 289 times)

0 Members and 1 Guest are viewing this topic.

Offline darkangel

  • Beta Tester
  • *
  • Posts: 361
Theme name and version: GamerZ
Browser Name and Version: FireFox 84.0.2
Mods installed: TP 2.0, httpBL 2.5.1, Join Reason 1.5 and Stop Spammer 2.3.9

The shout box is up and ready,  in this dark theme I try to get the actual shout text to be #ccc. I copied the tpshout.css into theme's css folder. Any idea where to change it for dark themes?
Fantasies Realm  | Fantasy Attic

SMF 2.0.15 | TP 1.2 | many mod addons | variety of themes

Offline darkangel

  • Beta Tester
  • *
  • Posts: 361
Re: Weird text issue and text color change for dark themes/shout box
« Reply #1 on: January 12, 2021, 09:24:30 PM »
Has this happened to anyone using smf and php7.3:
we are having issues while typing, keys are getting hit right, But either need to enter text in notepad or  get half text written or words stuck together.

I haven't read of anything like this happening with mods or portal so am lost.
Fantasies Realm  | Fantasy Attic

SMF 2.0.15 | TP 1.2 | many mod addons | variety of themes

Offline lurkalot

  • Administrator
  • *
  • Posts: 7110
    • Camera Craniums
Re: Weird text issue and text color change for dark themes/shout box
« Reply #2 on: January 13, 2021, 12:48:41 AM »
Theme name and version: GamerZ
Browser Name and Version: FireFox 84.0.2
Mods installed: TP 2.0, httpBL 2.5.1, Join Reason 1.5 and Stop Spammer 2.3.9

The shout box is up and ready,  in this dark theme I try to get the actual shout text to be #ccc. I copied the tpshout.css into theme's css folder. Any idea where to change it for dark themes?

In TP2.0.0 the shoutbox colours are set in the shoutbox settings.  Leaving them blank should take on the default colours for the theme in use.

Regarding the other text problems, does this do the same on the SMF default theme?

Got a link to that site?

Offline darkangel

  • Beta Tester
  • *
  • Posts: 361
Re: Weird text issue and text color change for dark themes/shout box
« Reply #3 on: January 13, 2021, 02:03:41 PM »
oops I had to remove some text and forgot to plop it back in...Yest it is in any theme.
http://www.thefantasiesattic.net/attic/index.php?action=forum
Fantasies Realm  | Fantasy Attic

SMF 2.0.15 | TP 1.2 | many mod addons | variety of themes

Offline tino

  • Developer
  • *
  • Posts: 2211
Re: Weird text issue and text color change for dark themes/shout box
« Reply #4 on: January 13, 2021, 02:26:16 PM »
oops I had to remove some text and forgot to plop it back in...Yest it is in any theme.
http://www.thefantasiesattic.net/attic/index.php?action=forum

If it’s slow in the shoutbox, that suggests an issue with the server itself and not being able to handle the load, turning off auto refresh will help.

Other than that it’s checking the round trip time and ensuring the routing from you to the server is decent. With a low ping and decent upload / download speeds on both ends.

Offline darkangel

  • Beta Tester
  • *
  • Posts: 361
Re: Weird text issue and text color change for dark themes/shout box
« Reply #5 on: January 13, 2021, 04:24:07 PM »
ok will test it out soon as I finally go eat sumpin. it says to set it to 0 to disable but when I do it then tells me that to set it to no less than 1
Fantasies Realm  | Fantasy Attic

SMF 2.0.15 | TP 1.2 | many mod addons | variety of themes

Offline tino

  • Developer
  • *
  • Posts: 2211
Re: Weird text issue and text color change for dark themes/shout box
« Reply #6 on: January 13, 2021, 04:54:25 PM »
ok will test it out soon as I finally go eat sumpin. it says to set it to 0 to disable but when I do it then tells me that to set it to no less than 1

I thought that bug had been fixed. Obviously not 0 is disabled though.

Offline lurkalot

  • Administrator
  • *
  • Posts: 7110
    • Camera Craniums
Re: Weird text issue and text color change for dark themes/shout box
« Reply #7 on: January 13, 2021, 04:59:44 PM »
ok will test it out soon as I finally go eat sumpin. it says to set it to 0 to disable but when I do it then tells me that to set it to no less than 1

I thought that bug had been fixed. Obviously not 0 is disabled though.

Confirmed.  Cannot disable the auto refresh in TP 2.0.0  :'(

Offline darkangel

  • Beta Tester
  • *
  • Posts: 361
Re: Weird text issue and text color change for dark themes/shout box
« Reply #8 on: January 13, 2021, 06:59:11 PM »
I can see in the code--I think -- where to set it )maybe 2 places in the text there) to 0 but it did not work for me...I tried...LOL

line 176 and 179
Code: [Select]
                    <label for="tp_shoutbox_refresh">'.$txt['tp-shout-autorefresh'].'</label>
                        </dt>
                        <dd>
                            <input type="number" name="tp_shoutbox_refresh" id="tp_shoutbox_refresh" value="' ,$context['TPortal']['shoutbox_refresh'], '" size="6" min="0" max="60" step="1" />[br /]
                        </dd>

scroll just before that section also gives the same text if setting to 0 in admin.
Fantasies Realm  | Fantasy Attic

SMF 2.0.15 | TP 1.2 | many mod addons | variety of themes

Offline tino

  • Developer
  • *
  • Posts: 2211
Re: Weird text issue and text color change for dark themes/shout box
« Reply #9 on: January 13, 2021, 07:02:32 PM »
ok will test it out soon as I finally go eat sumpin. it says to set it to 0 to disable but when I do it then tells me that to set it to no less than 1

I thought that bug had been fixed. Obviously not 0 is disabled though.

Confirmed.  Cannot disable the auto refresh in TP 2.0.0  :'(

Reopened the issue on GitHub. It’s fixed in 2.1.0 not 2.0.1