News: Welcome to the TinyPortal Support site.

Login  |  Register
HTML5 Icon HTML5 Icon
TP on Social Media
Welcome, Guest. Please login or register.
Did you miss your activation email?

September 15, 2019, 08:01:24 PM

Login with username, password and session length

Recent

Members
  • Total Members: 3752
  • Latest: Alizee
Stats
  • Total Posts: 188888
  • Total Topics: 20752
  • Online Today: 80
  • Online Ever: 629
  • (November 08, 2018, 01:36:54 PM)
Users Online
Users: 0
Guests: 54
Total: 54

Author Topic: Call to undefined function TP_loadTheme()  (Read 341 times)

0 Members and 1 Guest are viewing this topic.

Offline Dylert

  • Jr. Member
  • **
  • Posts: 40
Call to undefined function TP_loadTheme()
« on: August 12, 2019, 12:01:00 PM »
 Link to my forum: http://www.hellasforum.net/
SMF version: SMF ver. 2.0.15 here
TP version: 1.6.1
Default Forum Language: Norwegian
Theme name and version: Default
Browser Name and Version: Chrome - latest version
Mods installed:
SMF pro likes
SMF contact page
Social login
Topic starter
Users online today
WYSIWYG Quick reply
Post and PM inline attachment
Simple Audio video embedder
Advanced attachment uploader
Alternative menu
DMOT.hook.v141

Related Error messages: Call to undefined function TP_loadTheme()
PHP version: 7
« Last Edit: August 13, 2019, 02:46:01 PM by @rjen »

Offline @rjen

  • Support Team
  • *
  • Posts: 1807
    • FJR-club Nederland
Re: Call to undefined function TP_loadTheme()
« Reply #1 on: August 12, 2019, 12:04:49 PM »
Forumlink does not work?

Please Specify complete list of Mods, the Actual TP version as well as the PHP version
Running TP1.6.3 on SMF2.0 at: www.fjr-club.nl

Testing TP on SMF2.0
Testing TP on SMF2.1 RC2
Want to check what php version I am testing on? See: PHP Info

Offline Dylert

  • Jr. Member
  • **
  • Posts: 40
Re: Call to undefined function TP_loadTheme()
« Reply #2 on: August 12, 2019, 12:14:39 PM »
Forumlink does not work?

Please Specify complete list of Mods, the Actual TP version as well as the PHP version

Sorry! I have corrected th elink now:  www.hellasforum.net

Offline @rjen

  • Support Team
  • *
  • Posts: 1807
    • FJR-club Nederland
Re: Call to undefined function TP_loadTheme()
« Reply #3 on: August 12, 2019, 12:20:23 PM »
What did you do / change when this started happening? It suggests a broken / incomplete install of TinyPortal...

Did you backup before this started?
Running TP1.6.3 on SMF2.0 at: www.fjr-club.nl

Testing TP on SMF2.0
Testing TP on SMF2.1 RC2
Want to check what php version I am testing on? See: PHP Info

Offline Dylert

  • Jr. Member
  • **
  • Posts: 40
Re: Call to undefined function TP_loadTheme()
« Reply #4 on: August 12, 2019, 12:29:25 PM »
I changed from http to https and ran repair_settings.php. I clicked on "Remove all hooks", but I don't know if that is the reason.

Offline @rjen

  • Support Team
  • *
  • Posts: 1807
    • FJR-club Nederland
Re: Call to undefined function TP_loadTheme()
« Reply #5 on: August 12, 2019, 12:32:42 PM »
The remove all hooks is most likely the cause...

Do you have a backup? If so restore.

You may have more issues with your mods now.
Running TP1.6.3 on SMF2.0 at: www.fjr-club.nl

Testing TP on SMF2.0
Testing TP on SMF2.1 RC2
Want to check what php version I am testing on? See: PHP Info

Offline Dylert

  • Jr. Member
  • **
  • Posts: 40
Re: Call to undefined function TP_loadTheme()
« Reply #6 on: August 12, 2019, 12:34:07 PM »
No, I don't have a backup of everything. But I have backup of some files and database which is about 6 months old.

Offline Dylert

  • Jr. Member
  • **
  • Posts: 40
Re: Call to undefined function TP_loadTheme()
« Reply #7 on: August 12, 2019, 12:41:06 PM »
Maybe I shold make a clean install??

Offline @rjen

  • Support Team
  • *
  • Posts: 1807
    • FJR-club Nederland
Re: Call to undefined function TP_loadTheme()
« Reply #8 on: August 12, 2019, 12:54:56 PM »
A clean set of files is a sure way to fix it. More work though then a backup... you should really create a full backup of your forum before doing these things...

If you have the backup of the table smf_settings and are comfortabel with phpmyadmin you can manually put back the values you find in the table fields for the variables that start with integrate...

That should fix it, but I am not exactly sure. so no guarantees
Running TP1.6.3 on SMF2.0 at: www.fjr-club.nl

Testing TP on SMF2.0
Testing TP on SMF2.1 RC2
Want to check what php version I am testing on? See: PHP Info

Offline @rjen

  • Support Team
  • *
  • Posts: 1807
    • FJR-club Nederland
Re: Call to undefined function TP_loadTheme()
« Reply #9 on: August 12, 2019, 01:09:45 PM »
There is a file in the TinyPortal package: do_hooks.php, that can restore the hooks.

I am not sure how to run that though. Mick, a hand please ?
Running TP1.6.3 on SMF2.0 at: www.fjr-club.nl

Testing TP on SMF2.0
Testing TP on SMF2.1 RC2
Want to check what php version I am testing on? See: PHP Info

Offline lurkalot

  • Administrator
  • *
  • Posts: 6216
    • Camera Craniums
Re: Call to undefined function TP_loadTheme()
« Reply #10 on: August 12, 2019, 01:32:39 PM »
There is a file in the TinyPortal package: do_hooks.php, that can restore the hooks.

I am not sure how to run that though. Mick, a hand please ?

You  should be able to grab a copy of the do_hooks.php file from the TP package, and drop that into the directory where all your SMF files are sitting.  Then run it from  your address bar, like you would with a upgrade

Offline @rjen

  • Support Team
  • *
  • Posts: 1807
    • FJR-club Nederland
Re: Call to undefined function TP_loadTheme()
« Reply #11 on: August 12, 2019, 01:34:58 PM »
Tried that, resulting in a white screen and no updates. Saw that you used it before, hence the question
Running TP1.6.3 on SMF2.0 at: www.fjr-club.nl

Testing TP on SMF2.0
Testing TP on SMF2.1 RC2
Want to check what php version I am testing on? See: PHP Info

Offline lurkalot

  • Administrator
  • *
  • Posts: 6216
    • Camera Craniums
Re: Call to undefined function TP_loadTheme()
« Reply #12 on: August 12, 2019, 01:51:14 PM »
Tried that, resulting in a white screen and no updates. Saw that you used it before, hence the question

Strange, should run ok, or it always used to.  Haven't had to do this in a while.  Wonder if TP still shows as installed in package manager.  If not then perhaps remove all the TP files manually and reinstall it. (Backing them up first).

But as you said, removing all hooks will certainly break all the other mods that use hooks.

Offline @rjen

  • Support Team
  • *
  • Posts: 1807
    • FJR-club Nederland
Re: Call to undefined function TP_loadTheme()
« Reply #13 on: August 12, 2019, 01:55:07 PM »
It looks like the OP is setting up a fresh set of files...
Running TP1.6.3 on SMF2.0 at: www.fjr-club.nl

Testing TP on SMF2.0
Testing TP on SMF2.1 RC2
Want to check what php version I am testing on? See: PHP Info

Offline lurkalot

  • Administrator
  • *
  • Posts: 6216
    • Camera Craniums
Re: Call to undefined function TP_loadTheme()
« Reply #14 on: August 12, 2019, 02:00:52 PM »
It looks like the OP is setting up a fresh set of files...

Might be the best way to go I guess. Lets hope they are fresh files from the large upgrade package, not the install one. Otherwise it's going to get messy.  ;)

Offline lurkalot

  • Administrator
  • *
  • Posts: 6216
    • Camera Craniums
Re: Call to undefined function TP_loadTheme()
« Reply #15 on: August 12, 2019, 02:31:36 PM »
Looks like Dylert is running the installer, not just uploading a fresh set of files.  I hope there's a current backup of the database now, because it's going to be a empty forum starting from scratch.

Offline @rjen

  • Support Team
  • *
  • Posts: 1807
    • FJR-club Nederland
Re: Call to undefined function TP_loadTheme()
« Reply #16 on: August 13, 2019, 02:44:28 PM »
Guess he had a backup this time....
Running TP1.6.3 on SMF2.0 at: www.fjr-club.nl

Testing TP on SMF2.0
Testing TP on SMF2.1 RC2
Want to check what php version I am testing on? See: PHP Info

Offline lurkalot

  • Administrator
  • *
  • Posts: 6216
    • Camera Craniums
Re: Call to undefined function TP_loadTheme()
« Reply #17 on: August 13, 2019, 02:51:18 PM »
It does indeed, well that's a relief.  I was a bit worried when I saw install.php running yesterday.