News: TinyPortal Release Schedule. Please read this update for More Info.

Login  |  Register
TinyPortal on Twitter
Welcome, Guest. Please login or register.
Did you miss your activation email?
March 18, 2019, 11:51:10 AM

Login with username, password and session length

Recent

Members
  • Total Members: 3744
  • Latest: Galley
Stats
  • Total Posts: 187627
  • Total Topics: 20658
  • Online Today: 105
  • Online Ever: 629
  • (November 08, 2018, 01:36:54 PM)
Users Online
Users: 1
Guests: 17
Total: 18

Author Topic: TinyPortal 1.6.2: error with TPassimilate.php file in SMF errors log  (Read 1193 times)

0 Members and 1 Guest are viewing this topic.

Offline smartmouse

  • Jr. Member
  • **
  • Posts: 67
Re: TinyPortal 1.6.2: error with TPassimilate.php file in SMF errors log
« Reply #10 on: March 15, 2019, 05:04:50 AM »
5.4 is the version of PHP on my hosting.
« Last Edit: March 15, 2019, 08:12:45 AM by smartmouse »

Offline tino

  • Developer
  • *
  • Posts: 1493
Re: TinyPortal 1.6.2: error with TPassimilate.php file in SMF errors log
« Reply #11 on: March 15, 2019, 05:12:04 AM »
It's this mod;

Hide SMF Version

http://custom.simplemachines.org/mods/index.php?mod=1046

All our checks for SMF2.1 vs SMF2.0 would fail with this enabled.

Offline @rjen

  • Support Team
  • *
  • Posts: 1408
    • FJR-club Nederland
Re: TinyPortal 1.6.2: error with TPassimilate.php file in SMF errors log
« Reply #12 on: March 15, 2019, 05:12:44 AM »
You beat me to it, I just came to the same conclusion...
Running TP1.6.3 on SMF2.0 at: www.fjr-club.nl

Testing TP on SMF2.0
Testing TP on SMF2.1 RC1
Want to check what php version I am testing on? See: PHP Info

Offline @rjen

  • Support Team
  • *
  • Posts: 1408
    • FJR-club Nederland
Re: TinyPortal 1.6.2: error with TPassimilate.php file in SMF errors log
« Reply #13 on: March 15, 2019, 05:58:34 AM »
Confirmed. With that mod activated TP works fine for admins, but is breaks the site for all other users..

This is not something we can easily fix: $forum_version is the key that TinyPortal uses to switch between 2.0 and 2.1 logic. And it is in the TinyPortal code in many different locations, needed to make TP suitable for both 2.0 and 2.1 users.

At this time I would recommend to deactivate the Hide SMF Version mod.
TinyPortal will work fine then.

I personally doubt the usefulness of hiding the SMF version, but if you feel strongly about that, you cannot use TinyPortal...
Running TP1.6.3 on SMF2.0 at: www.fjr-club.nl

Testing TP on SMF2.0
Testing TP on SMF2.1 RC1
Want to check what php version I am testing on? See: PHP Info

Offline smartmouse

  • Jr. Member
  • **
  • Posts: 67
Re: TinyPortal 1.6.2: error with TPassimilate.php file in SMF errors log
« Reply #14 on: March 15, 2019, 08:14:21 AM »
Yes, this do the trick and solved both the problems!
Thank you very much guys for your support!

I personally doubt the usefulness of hiding the SMF version
Isn't a good practice for security reasons?

Offline @rjen

  • Support Team
  • *
  • Posts: 1408
    • FJR-club Nederland
Re: TinyPortal 1.6.2: error with TPassimilate.php file in SMF errors log
« Reply #15 on: March 15, 2019, 08:24:32 AM »
In the support thread for that MOD I find this quote from the mod author...

https://www.simplemachines.org/community/index.php?topic=214077.msg1367001#msg1367001
Quote
A lot is gone over in the "Rant" section in the readme.

You shouldn't need to hide your SMF version. In fact, it isn't really helpful at all.

A lot of people are under the impression that hiding the SMF version will protect them from hacking. It won't. Most attacks just try every possible vulnerability and see what sticks. Heck, often you will get attacks that are for software you don't even use. Of course, some people are so convinced wrongly they won't believe that and want to do it anyway.

The common method for hiding the version involves removing the version data. This also breaks the notices for SMF in the admin area. Basically, you won't get an alert if there is an important update. What this mod does is makes it so that the version is only hidden for non-admin users, which mean that update notices will still work properly.

So, do you need this mod? NO.
Is removing the version helpful in any way? Not really.
Why did I make the mod? To give those convinced they must hide the version a safe way to do so that doesn't break functionality.
Running TP1.6.3 on SMF2.0 at: www.fjr-club.nl

Testing TP on SMF2.0
Testing TP on SMF2.1 RC1
Want to check what php version I am testing on? See: PHP Info

Offline smartmouse

  • Jr. Member
  • **
  • Posts: 67
Re: TinyPortal 1.6.2: error with TPassimilate.php file in SMF errors log
« Reply #16 on: March 15, 2019, 09:07:08 AM »
Ahahah cool!

Thanks ;)