News: Welcome to the TinyPortal Support site.

Login  |  Register
* * *
TinyPortal on Twitter
Welcome, Guest. Please login or register.
Did you miss your activation email?
July 26, 2017, 12:49:10 AM

Login with username, password and session length

Recent

Members
  • Total Members: 3671
  • Latest: gordo52
Stats
  • Total Posts: 181325
  • Total Topics: 20335
  • Online Today: 37
  • Online Ever: 383
  • (January 02, 2015, 05:58:49 AM)
Users Online
Users: 1
Guests: 36
Total: 37

Skinz





Author Topic: 2.0.14/TP3  (Read 1040 times)

0 Members and 1 Guest are viewing this topic.

Offline darkangel

  • Beta Tester
  • *
  • Posts: 328
2.0.14/TP3
« on: June 24, 2017, 04:29:51 PM »
site: http://pfdlives.com/pfd/

various mods

removed old TP2 then installed TP3 and when I clicked the link to go to TP admin area I got a blank page:

this is log:
PHP Fatal error:  Cannot create references to elements of a temporary array expression in /server/pfd/Sources/TPortal.php on line 2447

I could not go anywhere cause it was a blank page everywhere. I finally had to remove all SMF files and the installed pkg list with new one to get back to forum so I could reinstall the mods and TP2 again.

Site is online again and have no idea what went wrong (course we are talking one of my sites...LOL)
Fantasies Realm  | Fantasy Attic

SMF 2.0.9 | TP 1.107 | many mod addons | variety of themes

Offline lurkalot

  • Administrator
  • *
  • Posts: 3635
    • Camera Craniums
Re: 2.0.14/TP3
« Reply #1 on: June 25, 2017, 02:06:40 AM »
Ooh, really sorry things went badly with this. I've not seen this happen in testing. 

Can I ask what version of PHP is that site running on please?
Mick aka lurkalot.  Running TP1.2 and TP1.2R

Camera Craniums Running SMF 2.0.13 / Tinyportal 1.2
Guitarist Guild Running SMF 2.0.13 / Tinyportal 1.2R Beta
The Garden Machinery Forum Running SMF 2.0.13 / Tinyportal 1.2R Beta

Offline darkangel

  • Beta Tester
  • *
  • Posts: 328
Re: 2.0.14/TP3
« Reply #2 on: June 25, 2017, 06:39:37 AM »
LOL told you my sites are naughty.

PHP Version: 5.4.45 (Zend: 2.4.0)

I was just shocked that I could not get back to a working page at all without replacing the files. Within 5 minutes I had the site back up and going again....during a time when there was just me on it --rare time too.
Fantasies Realm  | Fantasy Attic

SMF 2.0.9 | TP 1.107 | many mod addons | variety of themes

Offline lurkalot

  • Administrator
  • *
  • Posts: 3635
    • Camera Craniums
Re: 2.0.14/TP3
« Reply #3 on: June 25, 2017, 06:59:28 AM »
LOL told you my sites are naughty.

PHP Version: 5.4.45 (Zend: 2.4.0)

I was just shocked that I could not get back to a working page at all without replacing the files. Within 5 minutes I had the site back up and going again....during a time when there was just me on it --rare time too.

Thanks for that info, it will help find the problem.  I'm pretty confident, that if you had just grabbed the /Sources/TPortal.php file from TP 1.2 and replaced the TP1.3 one it would have worked for you without rebuilding your site.

I can only apologise, and will look into getting this fixed asap. 
Mick aka lurkalot.  Running TP1.2 and TP1.2R

Camera Craniums Running SMF 2.0.13 / Tinyportal 1.2
Guitarist Guild Running SMF 2.0.13 / Tinyportal 1.2R Beta
The Garden Machinery Forum Running SMF 2.0.13 / Tinyportal 1.2R Beta

Offline darkangel

  • Beta Tester
  • *
  • Posts: 328
Re: 2.0.14/TP3
« Reply #4 on: June 25, 2017, 02:48:01 PM »
No problem sweety, even the gods made mistakes so when you get it fixed is great, at least now you know in case there are other weird sites like mine. :2funny:
Fantasies Realm  | Fantasy Attic

SMF 2.0.9 | TP 1.107 | many mod addons | variety of themes

Offline Arantor

  • Jr. Member
  • **
  • Posts: 10
Re: 2.0.14/TP3
« Reply #5 on: June 27, 2017, 01:38:42 AM »
Please see the comment in http://www.tinyportal.net/index.php?topic=35895.0 where I hope I've fixed that.

It's not really that weird; it's simply that it didn't occur to me that that would break in 5.4 since it doesn't in 7+.

Offline darkangel

  • Beta Tester
  • *
  • Posts: 328
Re: 2.0.14/TP3
« Reply #6 on: June 27, 2017, 03:12:41 AM »
Thanks arantor, I will attempt the fixes soon then report back.
Fantasies Realm  | Fantasy Attic

SMF 2.0.9 | TP 1.107 | many mod addons | variety of themes

Offline darkangel

  • Beta Tester
  • *
  • Posts: 328
Re: 2.0.14/TP3
« Reply #7 on: July 03, 2017, 01:03:53 AM »
finally got to put tp3 back into the site and as far as I can see there are no problems. It installed wonderfully and did not make the forum/pages all gone.

thanks
Fantasies Realm  | Fantasy Attic

SMF 2.0.9 | TP 1.107 | many mod addons | variety of themes

Offline Arantor

  • Jr. Member
  • **
  • Posts: 10
Re: 2.0.14/TP3
« Reply #8 on: July 03, 2017, 11:46:37 AM »
Awesome, seems like that nailed the last issue that worried me for TP 1.3.

Offline darkangel

  • Beta Tester
  • *
  • Posts: 328
Re: 2.0.14/TP3
« Reply #9 on: July 03, 2017, 01:23:17 PM »
You all do awesome work, now if FF would just quit telling me sites are unsafe and make me give exceptions (sites that I know are safe that is) then I might just breathe easier.
Thanks again
Fantasies Realm  | Fantasy Attic

SMF 2.0.9 | TP 1.107 | many mod addons | variety of themes