News: When asking for support, it helps us and you, if you read the Posting Guidelines

Login  |  Register
HTML5 Icon HTML5 Icon
TP on Social Media
Welcome, Guest. Please login or register.
Did you miss your activation email?

September 16, 2019, 08:55:44 AM

Login with username, password and session length

Recent

Members
  • Total Members: 3752
  • Latest: Alizee
Stats
  • Total Posts: 188888
  • Total Topics: 20752
  • Online Today: 50
  • Online Ever: 629
  • (November 08, 2018, 01:36:54 PM)
Users Online
Users: 0
Guests: 30
Total: 30

Author Topic: Install keeps failing on tp_upgrade.php  (Read 10123 times)

0 Members and 1 Guest are viewing this topic.

Offline webby

  • Jr. Member
  • **
  • Posts: 9
    • Aston Martin Owners Club
Install keeps failing on tp_upgrade.php
« on: August 25, 2012, 03:53:31 PM »
I've tried every trick I know but install keeps failing with the following message:

Quote
Invalid default value for 'bar'
File: /Packages/temp/SMF2/tp_upgrade.php
Line: 324

Help!

Offline webby

  • Jr. Member
  • **
  • Posts: 9
    • Aston Martin Owners Club
Re: Install keeps failing on tp_upgrade.php
« Reply #1 on: August 25, 2012, 06:46:04 PM »
I solved the problem by deleting all the tp tables in MySQL.

Offline IchBin™

  • Developer
  • *
  • Posts: 16228
    • My Website
Re: Install keeps failing on tp_upgrade.php
« Reply #2 on: August 27, 2012, 09:49:16 AM »
Glad you got it sorted. I think it may have something to do with your version of MySQL or something like having it in strict mode. I'll have to do some testing and see if I can replicate the issue though.

Offline ladrius

  • Newbie
  • *
  • Posts: 1
Re: Install keeps failing on tp_upgrade.php
« Reply #3 on: October 08, 2012, 01:20:28 PM »
Same error.

Solved it the same way...thanks!

Offline IchBin™

  • Developer
  • *
  • Posts: 16228
    • My Website
Re: Install keeps failing on tp_upgrade.php
« Reply #4 on: October 08, 2012, 01:56:31 PM »
Same error.

Solved it the same way...thanks!

Two awesomes in one post.
1. Awesome you fixed it
2. Awesome you found it by searching! :D

Offline IchBin™

  • Developer
  • *
  • Posts: 16228
    • My Website
Re: Install keeps failing on tp_upgrade.php
« Reply #5 on: January 31, 2013, 10:15:24 AM »
Apparently it thinks that TP was trying to set a default value for the illustrator field in the articles table. Even though TP does not try to set any default value that I can see. Not sure what happened there for you. Maybe the table had a default value set before you dropped it somehow. That's about the only thing I can think of.

Offline Charles Parker

  • Newbie
  • *
  • Posts: 3
Re: Install keeps failing on tp_upgrade.php
« Reply #6 on: February 23, 2014, 07:21:20 PM »
I just upgraded from 1.17 smf with an old version of TP (can't remember which) however I had teh same issue.
Quote
BLOB/TEXT column 'illustration' can't have a default value
Line 324

Looking at the database columns (in the table 'smf_tp_articles') I found that there was a default value set to "0" and it was an int(11) data type

I changed it to a BLOB and removed the default value and set it to NULL

This allowed the installation to continue with no obvious problems.
However...
I would like to know what the correct data type is supposed to be, etc.
It worked - but if its supposed to be an Int(11)
I would like to change it back ASAP
Many thanks!

Offline IchBin™

  • Developer
  • *
  • Posts: 16228
    • My Website
Re: Install keeps failing on tp_upgrade.php
« Reply #7 on: February 23, 2014, 11:50:01 PM »
It's supposed to be a text field. Not an int. You just need to remove the default attribute so that it's not trying to set a default value anymore.

Offline Charles Parker

  • Newbie
  • *
  • Posts: 3
Re: Install keeps failing on tp_upgrade.php
« Reply #8 on: February 24, 2014, 06:52:13 PM »
Thanks I will change it to a text field, at one point you must have had it as an int(11) because I have never touched it prior. Its just the way I found it.
what is the default length of the text field? btw.

Thank you so much for your efforts, I am one of many who feel smf is not smf without tp
you guys (bloc, etc) are awesome

Offline IchBin™

  • Developer
  • *
  • Posts: 16228
    • My Website
Re: Install keeps failing on tp_upgrade.php
« Reply #9 on: February 24, 2014, 08:08:39 PM »
A text field is 65,535 bytes. I've noticed this with a few people. If I get a free moment, I'll have to see how that field is used, and if I need to fix the installer to update that field.