News: When asking for support, it helps us and you, if you read the Posting Guidelines

Login  |  Register
HTML5 Icon HTML5 Icon
TP on Social Media
Welcome, Guest. Please login or register.
Did you miss your activation email?

August 24, 2019, 06:27:55 PM

Login with username, password and session length

Recent

Members
  • Total Members: 3751
  • Latest: tom888
Stats
  • Total Posts: 188700
  • Total Topics: 20746
  • Online Today: 86
  • Online Ever: 629
  • (November 08, 2018, 01:36:54 PM)
Users Online
Users: 0
Guests: 42
Total: 42

Author Topic: [Upgraded to 1.0 Beta 4] A lot of errors!  (Read 7114 times)

0 Members and 1 Guest are viewing this topic.

smartmouse

  • Guest
[Upgraded to 1.0 Beta 4] A lot of errors!
« on: January 24, 2010, 05:36:37 PM »
Hello, after the upgrade of TP to the latest version i have this error in home page of my forum:

Quote
Fatal error: Call to undefined function TPortal_sidebar() in /home/myhost/public_html/mysite.com/Sources/Load.php(1758) : eval()'d code on line 456

and this is what i have at line 456 of Load.php:

Code: [Select]
if (empty($user_settings['additionalGroups']))
$user_info = array(
'groups' => array($user_settings['ID_GROUP'], $user_settings['ID_POST_GROUP'])
);
else
$user_info = array(
'groups' => array_merge(
array($user_settings['ID_GROUP'], $user_settings['ID_POST_GROUP']),
explode(',', $user_settings['additionalGroups'])
)
);
}


Besides i have all these errors in the Error log page:

Quote
8: Undefined index: tp-download
File: /home/myhost/public_html/mysite.com/Themes/default/languages/TPShout.italian.php (main_above sub template - eval?)
Linea: 710

8: Undefined index: smileys_enabled
File: /home/myhost/public_html/mysite.com/Sources/TPmodules.php
Linea: 1758

8: Undefined index: tp-forum
File: /home/myhost/public_html/mysite.com/Themes/default/languages/TPShout.italian.php (main_above sub template - eval?)
Linea: 707

8: Undefined index: TPortal_front_type
File: /home/myhost/public_html/mysite.com/Themes/default/languages/TPShout.italian.php (main_above sub template - eval?)
Linea: 705

How to find the problem and how to solve all these errors?
« Last Edit: January 31, 2010, 03:42:16 PM by ZarPrime »

Offline IchBin™

  • Developer
  • *
  • Posts: 16228
    • My Website
Re: [Upgraded to 1.0 Beta 4] A lot of errors!
« Reply #1 on: January 24, 2010, 07:01:48 PM »
smartmouse, please use the search. Every one of those errors has been reported. And most likely have a fix posted for them as well.

Offline Freddy

  • Code
  • *
  • Posts: 1615
    • AiDreams
Re: [Upgraded to 1.0 Beta 4] A lot of errors!
« Reply #2 on: January 25, 2010, 07:12:23 AM »
Don't forget that this is a BETA version Smartmouse  ;)

smartmouse

  • Guest
Re: [Upgraded to 1.0 Beta 4] A lot of errors!
« Reply #3 on: January 26, 2010, 05:35:04 AM »
I searched and searched but i can't understand what could be the problem (i'm referring to the first error).
Then i tried to install a copy of my current them (original, with no modifications) and i have the same error!

So i understand that my theme is not compatible with TP v1.0 Beta 4.

Am i right?

Offline ZarPrime

  • Friends
  • *
  • Posts: 4653
Re: [Upgraded to 1.0 Beta 4] A lot of errors!
« Reply #4 on: January 26, 2010, 06:59:32 AM »
Hmmm, maybe this will help --> http://www.tinyportal.net/index.php?topic=23547.0

ZarPrime

smartmouse

  • Guest
Re: [Upgraded to 1.0 Beta 4] A lot of errors!
« Reply #5 on: January 26, 2010, 07:34:07 AM »
I have already read that topic. The problem is the same (the same error message that disappears if i log in) but the cause is different. I disinstalled old version of Tp (v0.9.8 ) and i installed v1.0 Beta 4, throught Packages manager and without any problems or error messages.

So, what can i do to solve this problem?

In the meanwhile i contacted Crip, the creator of my theme (Black14k) to see if he can help me founding the problem in his theme.

Offline ZarPrime

  • Friends
  • *
  • Posts: 4653
Re: [Upgraded to 1.0 Beta 4] A lot of errors!
« Reply #6 on: January 26, 2010, 07:52:23 AM »
OK, so you read the topic, but did you do as Ichbiin suggested in that topic? ...
http://www.tinyportal.net/index.php?topic=23547.msg190513#msg190513

How do I manually install TinyPortal

ZarPrime

smartmouse

  • Guest
Re: [Upgraded to 1.0 Beta 4] A lot of errors!
« Reply #7 on: January 26, 2010, 08:21:13 AM »
ZarPrime, i don't understand, maybe because of my english.
I'm saying that i have not problems to install TP.
In that topic an user says that installed TP by copying files and IchBin told him how to correctly install TP.

I think i don't need to manually install TP. Am i wrong?

Offline Crip

  • Jesus Inside.
  • Themes
  • *
  • Posts: 4168
  • Theme Support
    • Cripzone
Re: [Upgraded to 1.0 Beta 4] A lot of errors!
« Reply #8 on: January 26, 2010, 08:28:49 AM »
Why not share a link to Site so we can actually see it ??
I have become comfortably numb!

Cripzone | Crip's Free 2.0.2 Themes


smartmouse

  • Guest
Re: [Upgraded to 1.0 Beta 4] A lot of errors!
« Reply #9 on: January 26, 2010, 09:32:32 AM »
www. mon*ywant*rsforum.com

* = e

Offline ZarPrime

  • Friends
  • *
  • Posts: 4653
Re: [Upgraded to 1.0 Beta 4] A lot of errors!
« Reply #10 on: January 26, 2010, 09:56:58 AM »
I don't know what you did to fix it but, for some reason, your site no longer has that error on the FP, and now looks great. O0

ZarPrime

smartmouse

  • Guest
Re: [Upgraded to 1.0 Beta 4] A lot of errors!
« Reply #11 on: January 26, 2010, 09:57:26 AM »
As i told to Crip in the last PM that i send him, i removed the maintenance mode and now the forum works like before!!

What the hell is happened??? Was the maintenance mode on SMF v1.1.11 and TP v1.0 Beta 4 not compatible with my theme?!?

Offline ZarPrime

  • Friends
  • *
  • Posts: 4653
Re: [Upgraded to 1.0 Beta 4] A lot of errors!
« Reply #12 on: January 26, 2010, 09:59:35 AM »
I leave you in the able hands of Crip, the Theme Master. :D

ZarPrime

smartmouse

  • Guest
Re: [Upgraded to 1.0 Beta 4] A lot of errors!
« Reply #13 on: January 26, 2010, 10:05:18 AM »
Eh eh eh, thank you!

Offline Crip

  • Jesus Inside.
  • Themes
  • *
  • Posts: 4168
  • Theme Support
    • Cripzone
Re: [Upgraded to 1.0 Beta 4] A lot of errors!
« Reply #14 on: January 26, 2010, 03:40:05 PM »
Why report me after i helped you?

All you had to do is ask .......
« Last Edit: January 26, 2010, 03:42:37 PM by Crip »
I have become comfortably numb!

Cripzone | Crip's Free 2.0.2 Themes


Offline IchBin™

  • Developer
  • *
  • Posts: 16228
    • My Website
Re: [Upgraded to 1.0 Beta 4] A lot of errors!
« Reply #15 on: January 26, 2010, 05:59:40 PM »
I wouldn't take offense Crip, he apparently just didn't want his link visible and thought that to be the quickest way to get it removed. No big deal.

smartmouse

  • Guest
Re: [Upgraded to 1.0 Beta 4] A lot of errors!
« Reply #16 on: January 26, 2010, 11:27:50 PM »
Why report me after i helped you?

All you had to do is ask .......

I did ask to you, but maybe you go away from pc and i had to use a quicker way as said by IchBin.
I'm sorry if you think that i reported you :(

Ehm... about my last question?

smartmouse

  • Guest
Re: [Upgraded to 1.0 Beta 4] A lot of errors!
« Reply #17 on: January 27, 2010, 05:09:01 AM »
Anyone can help me about my problem?

As i told to Crip in the last PM that i send him, i removed the maintenance mode and now the forum works like before!!

What the hell is happened??? Was the maintenance mode on SMF v1.1.11 and TP v1.0 Beta 4 not compatible with my theme?!?

Offline ZarPrime

  • Friends
  • *
  • Posts: 4653
Re: [Upgraded to 1.0 Beta 4] A lot of errors!
« Reply #18 on: January 27, 2010, 06:39:24 AM »
If it works now, I don't see the problem.  However, if it still happens when your Forum is set to Maintenance Mode, then it's possible that you have made edits that are causing this to happen.  Are we still talking about the custom theme?  Does this happen with the SMF default theme as well?

If this happens only with the custom theme, where did you download this theme from?  Please give us a link to the site from which you downloaded the theme from so that I can check it on my site to see if I can duplicate the problem.

ZarPrime

smartmouse

  • Guest
Re: [Upgraded to 1.0 Beta 4] A lot of errors!
« Reply #19 on: January 27, 2010, 08:43:34 AM »
If it works now, I don't see the problem.  However, if it still happens when your Forum is set to Maintenance Mode, then it's possible that you have made edits that are causing this to happen.  Are we still talking about the custom theme?  Does this happen with the SMF default theme as well?
Yes, it is the custom theme.
It doesn't happen with default theme.

Quote
If this happens only with the custom theme, where did you download this theme from?  Please give us a link to the site from which you downloaded the theme from so that I can check it on my site to see if I can duplicate the problem.
It's a premium theme (Black14k, it's 3 years old), how to give it to you?

Offline ZarPrime

  • Friends
  • *
  • Posts: 4653
Re: [Upgraded to 1.0 Beta 4] A lot of errors!
« Reply #20 on: January 27, 2010, 09:01:44 AM »
Is this one of Crip's theme's?  If so, I just need to know where you originally downloaded it from, if you can remember.  When you say it's a premium theme, do you mean that someone did this theme just for you?  The main reason I need to know this is because if the theme you are using was originally edited by Crip to work specifically with TP 0.98, this could very well be the problem, since you are no longer using it with TP 0.98.

ZarPrime

smartmouse

  • Guest
Re: [Upgraded to 1.0 Beta 4] A lot of errors!
« Reply #21 on: January 27, 2010, 09:20:45 AM »
Is this one of Crip's theme's?
Yes.

Quote
If so, I just need to know where you originally downloaded it from, if you can remember. When you say it's a premium theme, do you mean that someone did this theme just for you?
I downloaded it from this site almost 3 years ago, obviously the page doesn't exist anymore.

Quote
The main reason I need to know this is because if the theme you are using was originally edited by Crip to work specifically with TP 0.98, this could very well be the problem, since you are no longer using it with TP 0.98.

ZarPrime
Yes, you are right... but we were trying to make it to work with TP 1.0...

Offline ZarPrime

  • Friends
  • *
  • Posts: 4653
Re: [Upgraded to 1.0 Beta 4] A lot of errors!
« Reply #22 on: January 28, 2010, 07:09:48 AM »
smartmouse,

OK, I did some research on this theme.  This theme was originally designed by Crip for a specific purpose.  All the proceeds for the theme were to be used to help G6 to help pay for the heart surgery for her son.

I have installed the theme on my TP 1.0 beta 4 test site and, although there are some errors in the error log, it works fine with TP 1.0 beta 4.  I even went in and enabled maintenance mode and it worked fine in with that as well.  You can see it here ...
http://talesofthehavenexpanse.com/smf1test/index.php?action=forum;theme=34

It is an old theme and is not likely to be upgraded by Crip since it was designed for a specific purpose.  However, it works fine, at least on my site.

My suggestion is that you delete the copy of it that you are using on your site and upload it again and see if that solves the problem.  If it doesn't, then I would suggest that, after being in use on your site for 3 years, it's time to think about switching to another theme, despite the fact that you really like it.  Sometimes, we just have to move on.

Be aware that one of these days, after TinyPortal has been released for SMF 2.0, this theme will definitely not work on an SMF 2.0/TP 1.0 beta 5 site.  Maybe it's time to look for another theme.

ZarPrime

smartmouse

  • Guest
Re: [Upgraded to 1.0 Beta 4] A lot of errors!
« Reply #23 on: January 28, 2010, 09:38:10 AM »
smartmouse,

OK, I did some research on this theme.  This theme was originally designed by Crip for a specific purpose.  All the proceeds for the theme were to be used to help G6 to help pay for the heart surgery for her son.
I know it. At that time i was a new user and i felt to partecipate to it. I liked to do a good thing and i liked that theme!

Quote
I have installed the theme on my TP 1.0 beta 4 test site and, although there are some errors in the error log, it works fine with TP 1.0 beta 4.  I even went in and enabled maintenance mode and it worked fine in with that as well.  You can see it here ...
http://talesofthehavenexpanse.com/smf1test/index.php?action=forum;theme=34
I see, i tried to do the same but it gave me the same problems... Maybe i made mistakes with something...

Quote
It is an old theme and is not likely to be upgraded by Crip since it was designed for a specific purpose.  However, it works fine, at least on my site.

My suggestion is that you delete the copy of it that you are using on your site and upload it again and see if that solves the problem.  If it doesn't, then I would suggest that, after being in use on your site for 3 years, it's time to think about switching to another theme, despite the fact that you really like it.  Sometimes, we just have to move on.

Be aware that one of these days, after TinyPortal has been released for SMF 2.0, this theme will definitely not work on an SMF 2.0/TP 1.0 beta 5 site.  Maybe it's time to look for another theme.

ZarPrime
You are very right! Anyway i will use this theme untill SMF 2.0 is finally released.
I always thought that it's not a good idea to use Beta versions. This time i tried to install anyway TP because i was "captured" by that huge sentence at the head of the forum... then i understand that is better wait for final releases!

Thank you very much for your support, for your time, for your test!

I'm sorry only for a thing: Crip send me to the hell for that topic in which i reported his post... He doesn't understand my intentions.

Offline ZarPrime

  • Friends
  • *
  • Posts: 4653
Re: [Upgraded to 1.0 Beta 4] A lot of errors!
« Reply #24 on: January 31, 2010, 03:41:40 PM »
Actually, if everyone waited for final releases, good software would take forever to get out since the beta testers using the software is the only way that the bugs can be worked out.  So, yes, it's a good idea to use beta software, IMHO. ;)

Anyway, it seems that we are at a point where this topic can be marked solved so I will do that now.

ZarPrime