News: April 7th, 2019, The Tinyportal team is pleased to announce the release of ~~ TinyPortal 1.6.3! GET IT NOW!!!

Login  |  Register
HTML5 Icon HTML5 Icon
TP on Social Media
Welcome, Guest. Please login or register.
Did you miss your activation email?

August 24, 2019, 06:27:22 PM

Login with username, password and session length

Recent

Members
  • Total Members: 3751
  • Latest: tom888
Stats
  • Total Posts: 188700
  • Total Topics: 20746
  • Online Today: 86
  • Online Ever: 629
  • (November 08, 2018, 01:36:54 PM)
Users Online
Users: 0
Guests: 42
Total: 42

Author Topic: Upgrading TP 0.9.8 to TP 1.0.X  (Read 14182 times)

0 Members and 1 Guest are viewing this topic.

Offline Lord Anubis

  • Hero Member
  • *****
  • Posts: 679
Upgrading TP 0.9.8 to TP 1.0.X
« on: January 22, 2009, 10:49:22 PM »
This is a full step by step tutorial showing how to upgrade from TP 0.9.8 to TP 1.0.X. This is the simplest most effective way to upgrade, and makes sure there is no leftover TP codes.

I take NO RESPONSIBILITY if you do something incorrectly and something wrong happens to your forum.

I recommend reading the entire tutorial before beginning just to make sure you understand each step before you proceed.  In addition, a full backup of your DATABASE and your SMF installation would be a wise decision.  As you can't downgrade TP 1.0.X back to TP 0.9.8

WARNING: Using this method to upgrade will remove all modifications you have currently, but reinstalling your mods should leave whatever settings you previously had.

STEP 1

Download TP 1.0.X from TinyPortal

STEP 2

Download the LARGE UPGRADE from SMF.

Now you have all the necessary scripts needed to upgrade your forum.

STEP 3

What you need to do next is unzip the LARGE UPGRADE package that you previously downloaded from SMF.

Many of the files in the LARGE UPGRADE package are NOT needed so lets clean up the folders before FTPing them to your server.

DO NOT DELETE ANYTHING FROM YOUR SERVER!!! WHERE IT SAYS DELETE, THAT MEANS FROM THE UPGRADE PACKAGE YOU DOWNLOAD FROM SMF, NOT YOUR SERVER!!!


In the main directory of the SMF LARGE UPGRADE that you just unzipped you should see these files and folders



DELETE these FOLDERS
  • attachments
  • avatars
  • Packages
  • Smileys

DELETE these FILES
  • ssi_examples.shtml
  • upgrade_1-0.sql
  • upgrade_1-1.sql
  • upgrade.php

Now the main directory of the unzipped SMF Upgrade should have this left over



Now you are ready to proceed to the next step.

STEP 4

Upload all the remaining files and folders from the smf_1-1-X_upgrade folder and overwrite the files that you currently have on your server.

STEP 5

On your server in the Packages directory, delete the installed.list file.

The installed.list contains all your previous mod installations, and this will make your package manager show that your mods are installed when in actuality they are not because you overwrote all the SMF files with clean unmodified files.

STEP 6

Upload the latest TinyPortal using the package manager and install!

STEP 7

ENJOY  ;)
« Last Edit: January 22, 2009, 11:04:29 PM by Lord Anubis »

Offline G6Cad

  • Friends
  • *
  • Posts: 12643
    • FamiljeGodis
Re: Upgrading TP 0.9.8 to TP 1.0.X
« Reply #1 on: January 22, 2009, 11:03:13 PM »
Nice guide and thank you for posting Lord Anubis  :)  :up:

A small note.
Lord Anubis guide will also remove ALL your other installed mods from your forum.


If you want to keep them, you have to go this way

To upgrade TP from V098, more or less all you have to do is to uninstall TP v098 from the package manager ( if you get errors, follow this guide to manually remove TP V098 from the SMF files http://docs.tinyportal.co.uk/index.php/topic,147.html )

Then upload TP V1.0.* through your package manager and click the apply mod link. ( If you get errors, follow this guide on what code to manually add to the SMF files http://docs.tinyportal.co.uk/index.php/topic,140.html )

Offline Lord Anubis

  • Hero Member
  • *****
  • Posts: 679
Re: Upgrading TP 0.9.8 to TP 1.0.X
« Reply #2 on: January 22, 2009, 11:19:44 PM »
Thanks G6, I cleaned up a guide a bit more, so that the exact versions aren't used....Since I am sure that this wont change that dramatically for a few months at least

BTW: Lots of users using TP 0.9.8 are using old versions, and using the package manager will not show an uninstall link there are 2 ways to deal with this:

1,  add  ;emulate_version=1.1.X  to the end of the URL for the package manager.....for instance
http://www.mysite.com/index.php?action=packages;emulate_version=1.1.5

2. or upload to your site in "/packages" the latest version of TinyPortal V9.8.0 and you should see in the admin panel an uninstall link"

Often if you are using a lot of modifications, unless you want to manually delete the code from the files that have errors in the uninstall process, this is the easiest and most efficient way to upgrade

;)

Offline Zetan

  • Friends
  • *
  • Posts: 3471
Re: Upgrading TP 0.9.8 to TP 1.0.X
« Reply #3 on: January 23, 2009, 12:20:53 AM »
Nice guide Lord Anubis, I've stickied it for now, if people find it useful, it can stay. This board doesn't have many stickies, so it wont get in the way. (a poem at 07:20 by Zetan)


I like illustrative guides  :)


Offline Lord Anubis

  • Hero Member
  • *****
  • Posts: 679
Re: Upgrading TP 0.9.8 to TP 1.0.X
« Reply #4 on: January 23, 2009, 07:10:20 AM »
Thanks :)

vanityq

  • Guest
Re: Upgrading TP 0.9.8 to TP 1.0.X
« Reply #5 on: February 10, 2009, 02:50:04 AM »
i cannot uninstall the tp .9
it says

An Error Has Occurred!
This package cannot be uninstalled, because there is no uninstaller!

Please contact the mod author for more information.

can i just delete the listfiles/delete on packages and install the 1.05?..

vanityq

  • Guest
Re: Upgrading TP 0.9.8 to TP 1.0.X
« Reply #6 on: February 10, 2009, 02:51:10 AM »
ive tried this one

1,  add  ;emulate_version=1.1.X  to the end of the URL for the package manager.....for instance
http://www.mysite.com/index.php?action=packages;emulate_version=1.1.5

nothing happens
and

2. or upload to your site in "/packages" the latest version of TinyPortal V9.8.0 and you should see in the admin panel an uninstall link"
do i still need to install?
« Last Edit: February 10, 2009, 04:49:24 AM by vanykekok »

Offline IchBin™

  • Developer
  • *
  • Posts: 16228
    • My Website
Re: Upgrading TP 0.9.8 to TP 1.0.X
« Reply #7 on: February 10, 2009, 10:45:55 AM »
vanykekok, Please read the Posting Guidelines. This starts with using the search first, and then starting your own topic if you can't find the answer. This has been covered many, many times.

Muldoon

  • Guest
Re: Upgrading TP 0.9.8 to TP 1.0.X
« Reply #8 on: January 16, 2010, 08:07:35 PM »
Hi guys,

I am currently running SMF 1.1.11 and TinyPortal v0.9.8.  I see that TP v1.0 beta 4 is the latest version and that I should upgrade.  Is this correct?

I have followed the above instruction that Lord Anubis has posted and I have completed Step 3.  However, before I proceed further, I am concerned about uploading all these SMF files since my SMF installation is already at the latest 1.1.11 version. 

What will happen when I upload these files?

Then all I have left is to delete the installed.list from my packages directory, upload the latest TP v1.0 beta 4 zip file and install?   

I do not have to uninstall v0.9.8?  If I need to I'm not sure I can as I do not see any uninstall link, let alone TP v0.9.8 even showing in my packages directory. 

Any guidance/advice/moral support would be much appreciated.  Also, I had two other mods besides TP installed in SMF and have already uninstalled them...if that even matters.

Thank you.


Offline IchBin™

  • Developer
  • *
  • Posts: 16228
    • My Website
Re: Upgrading TP 0.9.8 to TP 1.0.X
« Reply #9 on: January 16, 2010, 09:15:45 PM »
This topic is a year old Muldoon! The only way you find out things is if you try it. If you have a backup of everything you have no worries in what you try. Please start your own topic following our posting guidelines in the future. Thank you.