News: September 21st, 2019, The Tinyportal team is pleased to announce the release of ~~ TinyPortal 1.6.4! GET IT NOW!!!

Login  |  Register
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media
Welcome, Guest. Please login or register.
Did you miss your activation email?

December 16, 2019, 06:43:46 AM

Login with username, password and session length

Recent

Members
Stats
  • Total Posts: 189283
  • Total Topics: 20776
  • Online Today: 65
  • Online Ever: 629
  • (November 08, 2018, 01:36:54 PM)
Users Online
Users: 0
Guests: 56
Total: 56

Author Topic: help please  (Read 1562 times)

0 Members and 1 Guest are viewing this topic.

dtaliaferro

  • Guest
help please
« on: March 22, 2007, 04:54:30 AM »
I was running SMF 1.1.1 and TP 9.8
I installed the files and ran the upgrade to SMF 1.1.2
Now, SMF forum messages are displayed but with no menu items and an error message at the bottom of the page:
Fatal error: Call to undefined function: tportal_version() in /home/u6/dtaliaferro/ldbell71.com/html/forum/Sources/Load.php(1726) : eval()'d code on line 552

With no menu, I have no access to the admin panel
Can someone help point me in the right direction?

TestMonkey

  • Guest
Re: help please
« Reply #1 on: March 22, 2007, 05:31:35 AM »
Ahh it sounds like you need to re-apply the TP installation, basically what you did was installed smf, then tp, then upgraded smf which undoes alot of the TP bits reverting back some code to SMF without TP.

Basically download the manual install for TP, upload the files to where you're forum is installed and follow the guide to install TP manually..
Quicklink to the manual install guide: http://www.tinyportal.net/index.php?topic=14195


Directly from bloc's post regarding the new version:
Quote
To manually install:
- upload the contents of TP0983_manual.zip to the forum folder.
- run the included manual_install_tp.php to install/update database tables.
- follow the mod instructions outlined in TP Docs to make the needed changes to core SMF files => http://www.tinyportal.net/index.php?topic=14195

If you can get lucky and get into you're admin panel you can try this:
Go into your admin area, and uninstall the SMF upgrade then uninstall TP, then re-install the SMF upgrade, and THEN finally re-install TP.. but this may not be possible for you and may not work correctly..

The manual install/re-install of TP should correct the problems you're having if SMF did infact get upgraded properly.

For future reference, anytime you go to upgrade SMF uninstall TP and all other mods then update SMF then re-apply you're mod's one at a time making sure they all work correctly with the new SMF version.

Hope that helps.
« Last Edit: March 22, 2007, 05:39:32 AM by TestMonkey »