News: TinyPortal Release Schedule. Please read this update for More Info.

Login  |  Register
HTML5 Icon HTML5 Icon
TP on Social Media
Welcome, Guest. Please login or register.
Did you miss your activation email?

September 19, 2019, 03:02:45 PM

Login with username, password and session length

Recent

Members
  • Total Members: 3752
  • Latest: Alizee
Stats
  • Total Posts: 188917
  • Total Topics: 20754
  • Online Today: 126
  • Online Ever: 629
  • (November 08, 2018, 01:36:54 PM)
Users Online
Users: 1
Guests: 59
Total: 60

Author Topic: Minimum Supported Browser Version in TinyPortal?  (Read 1136 times)

0 Members and 1 Guest are viewing this topic.

Offline tino

  • Developer
  • *
  • Posts: 1651
Minimum Supported Browser Version in TinyPortal?
« on: June 04, 2018, 01:10:21 PM »
Hi All,

What do you feel is the minimum version of the various browsers that TinyPortal should support?

That's of the relatively big ones;

IE/Edge, FireFox, Chrome, Safari, Opera, Pale Moon. I'm not going to include the others.

Thanks!

tino

Offline wildenborch

  • Support Team
  • *
  • Posts: 347
Re: Minimum Supported Browser Version in TinyPortal?
« Reply #1 on: June 04, 2018, 03:36:26 PM »
Tino,

Difficult question for me.
I only use firefox and always update to the latest version.
And i never experienced problems with TP in older versions.

Since i have never heard of Pale Moon i will try it tomorrow.


Offline lurkalot

  • Administrator
  • *
  • Posts: 6225
    • Camera Craniums
Re: Minimum Supported Browser Version in TinyPortal?
« Reply #2 on: June 04, 2018, 11:53:44 PM »
Not sure of this one either, I suppose everyone should be using the latest version of any browser for security purposes. That clearly isn't the case in the real world, which makes things a bit awkward in this respect.

Offline tino

  • Developer
  • *
  • Posts: 1651
Re: Minimum Supported Browser Version in TinyPortal?
« Reply #3 on: June 05, 2018, 01:43:25 PM »
There is a reason I ask, but I'd like opinions first..

Here are some stats;

http://gs.statcounter.com/browser-market-share/desktop/worldwide

Chrome 66.93%
Firefox 11.55%
IE 6.97%
Safari 5.48%
Edge 4.15%
Opera 2.36%


https://www.w3counter.com/globalstats.php

Chrome 56.6%
Safari 14.7%
Internet Explorer & Edge 7.1%
Firefox 6.5%
Opera 3.5%

https://netmarketshare.com/browser-market-share.aspx

Chrome   60.98%
Internet Explorer   12.18%
Firefox   11.47%
Edge   4.15%
Safari   3.72%
Opera   1.51%

Safari is a lot higher than I expected.

Offline lurkalot

  • Administrator
  • *
  • Posts: 6225
    • Camera Craniums
Re: Minimum Supported Browser Version in TinyPortal?
« Reply #4 on: June 07, 2018, 01:14:24 AM »
Chrome seems pretty consistent at the top of the rankings.  The other browsers move around quite a bit though.  I've no idea of the individual versions of these browsers though.

IE / Edge should always be the latest versions, providing Windows update is being used and up to date. What gets me is they all seem to have their own standards and do things differently from each other.  As we've found with some things which work fine with Firefox/IE/Edge, but don't work properly in Chrome.

Offline tino

  • Developer
  • *
  • Posts: 1651
Re: Minimum Supported Browser Version in TinyPortal?
« Reply #5 on: June 15, 2018, 01:26:40 PM »
Not really had a answer for this one. I ask as the following will work in the latest versions of Safari, Firefox, Chrome and Edge.

https://tinoest.co.uk/responsive/

It won't work in IE

It's using a new HTML5 attribute for styling a webpage and makes responsive design a lot more consistent and easier to do.

That link is just a very simple and quickly put together example of a header, right sidebar, left sidebar, center content and then footer. Each block can be split as you wish. It's pretty much fully responsive without the need to use most of the things which cause issues with responsive design.

I choose to reorder the page when in responsive mode and move the right side bar to after the main content, it can easily go before.

Offline lurkalot

  • Administrator
  • *
  • Posts: 6225
    • Camera Craniums
Re: Minimum Supported Browser Version in TinyPortal?
« Reply #6 on: June 15, 2018, 02:29:04 PM »
Not really had a answer for this one. I ask as the following will work in the latest versions of Safari, Firefox, Chrome and Edge.

https://tinoest.co.uk/responsive/

It won't work in IE

It's using a new HTML5 attribute for styling a webpage and makes responsive design a lot more consistent and easier to do.

That link is just a very simple and quickly put together example of a header, right sidebar, left sidebar, center content and then footer. Each block can be split as you wish. It's pretty much fully responsive without the need to use most of the things which cause issues with responsive design.

I choose to reorder the page when in responsive mode and move the right side bar to after the main content, it can easily go before.

Neat.  ;)  It does worry me somewhat that a lot of people still use these older browsers, but I gather a lot of sites now state that they will no longer work with IE11, or at least they soon won't. 

You probably haven't seen it as you don't use IE11, but GitHub for example is doing just this.  Anyone who visits GitHub with IE11 is presented with a message at the top of the page,

"Please note that GitHub will stop supporting Internet Explorer as of July 2018.

We recommend Microsoft Edge, which is already installed on your version of Windows 10, Google Chrome, or Firefox."

Offline tino

  • Developer
  • *
  • Posts: 1651
Re: Minimum Supported Browser Version in TinyPortal?
« Reply #7 on: June 15, 2018, 03:25:50 PM »
I’d quite happily drop IE11, but then I don’t use it. It would require ripping up most of the TinyPortal logic to implement mind. Should make it work better with regards to being responsive though.

Anyway, I found it useful and the reorder option is very cool.