TinyPortal

General => Chit chat => Topic started by: tino on April 20, 2018, 03:08:59 AM

Title: Should the next TinyPortal Release include support for SMF2.1?
Post by: tino on April 20, 2018, 03:08:59 AM
Hi All,

Simple enough poll, when should TinyPortal support SMF 2.1? I know we have a TinyPortal-2 lying around that does support it, but that's not been kept up to date with TinyPortal-1. So a decision has to be made on when to support it, and what support it is given. This is just for the community to feed back what they want, based on this we'll work out what we can do.

Thanks

tino
Title: Re: Should the next TinyPortal Release include support for SMF2.1?
Post by: @rjen on April 20, 2018, 04:52:06 AM
I have TP2.0 on a 2.1 test site for a long time. As soon as 2.1 goes RC I will consider migrating my forum.

Having TP responsive support is a prerequisite to move the site to 2.1.
Title: Re: Should the next TinyPortal Release include support for SMF2.1?
Post by: lurkalot on April 20, 2018, 02:25:03 PM
I voted "Yes - Start basic support now"

Think we should make another start on supporting 2.1  Other portals have versions which do, so not wanting to fall behind. 

That said from a personal point of view I'd probably migrate to 2.1 on a couple of my sites when it goes RC and beyond, providing there's some decent themes available, (and TP of course).

TP2 seems to work well and looks pretty nicely, though we never got around to adding the responsive stuff to this version.

I like the modern looks of TP2 to be available for SMF 2.0.15 and SMF 2.1 much like you were doing with your original TP 1.5.0   
Title: Re: Should the next TinyPortal Release include support for SMF2.1?
Post by: tino on June 04, 2018, 01:11:49 PM
Well there wasn't much feedback, 7 in total. Of which it was 5/2 in starting it.

Based on the relatively slow development on SMF 2.1 then I'll wait for a RC release and ask again as more people might be interested in it then.
Title: Re: Should the next TinyPortal Release include support for SMF2.1?
Post by: lurkalot on June 04, 2018, 01:47:18 PM
Completely forgot about this poll.  :-[ I should have perhaps posted this question over in the TP support topic at SMF, and pointed them to it.   

Also find it amazing that out of the thousands of users TP has had over the years, the complete lack of comments and feedback, until they have a problem.   ;)
Title: Re: Should the next TinyPortal Release include support for SMF2.1?
Post by: VladTepes on June 26, 2018, 07:54:34 PM
Well to be honest I don't pop in to this forum very often.  To date I've only used TP for it's basic functions - not for a lot of the fancier stuff it can do - and so I've not needed to ask too many questions.

In regard to this particular question -

I gather the existing TP version 1.x can be installed to SMF 2.1 in emulation mode.  Will this allow all the current TP functionality to work on a 2.1 forum or is that a bad idea?

I would certainly like to have an SMF 2.1 compatible TP available in time for the SMF 2.1RC, as given the general experience among people who have risked using SMF 2.1 in production, it seems as if the risk is fairly low and therefore I'd be likely to move from 2.0.x to 2.1 RC fairly early.  So whether or not it's actually available prior to the 2.1RC isn't as important as whether it will be available when (or at least very shortly after) the SMF 2.1RC is available for use.

That's just my $0.02 less tax :) 
Title: Re: Should the next TinyPortal Release include support for SMF2.1?
Post by: lurkalot on June 27, 2018, 05:44:25 AM
Well to be honest I don't pop in to this forum very often.  To date I've only used TP for it's basic functions - not for a lot of the fancier stuff it can do - and so I've not needed to ask too many questions.

In regard to this particular question -

I gather the existing TP version 1.x can be installed to SMF 2.1 in emulation mode.  Will this allow all the current TP functionality to work on a 2.1 forum or is that a bad idea?

I would certainly like to have an SMF 2.1 compatible TP available in time for the SMF 2.1RC, as given the general experience among people who have risked using SMF 2.1 in production, it seems as if the risk is fairly low and therefore I'd be likely to move from 2.0.x to 2.1 RC fairly early.  So whether or not it's actually available prior to the 2.1RC isn't as important as whether it will be available when (or at least very shortly after) the SMF 2.1RC is available for use.

That's just my $0.02 less tax :)

Unfortunately, the current TP versions won't work with SMF 2.1 at the moment.  The only one we had working with SMF 2.1 beta 3 was a version on GitHub, but it doesn't behave responsively and is probably well out of date. We'll have wait and see which way tino decides to go with this one.