TinyPortal

Development => Feedback => Bugs/Errors => Topic started by: zalias7 on January 03, 2012, 03:13:35 AM

Title: article comments 2 bugs
Post by: zalias7 on January 03, 2012, 03:13:35 AM
Link to my site:localhost
SMF version: SMF ver. 2.0.2
TP version: TP ver. 1.0 RC2
Default Forum Language: lithuanian-utf8
Theme name and version: Theme name here
Browser Name and Version: firefox 9.0.1
Mods installed: TinyPortal
Related Error messages: The database value you're trying to insert does not exist: com

a problem
When I delete the article comments and reading the article in the article, I get an error: The database value you're trying to insert does not exist: com

I see that the table tp_articles Value for the comments field does not change. Changing to a fair number of comments the problem no longer exists.

issue 2
Article comments, removed user name is displayed as 0
Title: Re: article comments 2 bugs
Post by: IchBin™ on January 03, 2012, 01:33:41 PM
Can you post the full error please? I need the file name and line number that it gives.
Title: Re: article comments 2 bugs
Post by: zalias7 on January 03, 2012, 02:01:40 PM
sorry for my English.

error:

The database value you're trying to insert does not exist: com
Function: doTPpage
File: ../www/Sources/TPortal.php
Line: 801

You need to do is: write article -> write article for comment. Delete comment from article. Read article with comment and you get the error
Title: Re: article comments 2 bugs
Post by: IchBin™ on January 03, 2012, 03:01:00 PM
Find in TPortal.php
Code: [Select]
array('com' => $count, 'artid' => $article['id'])
Replace $count as $ccount.
Code: [Select]
array('com' => $ccount, 'artid' => $article['id'])
This is fixed in the next version coming out soon. :)
Title: Re: article comments 2 bugs
Post by: zalias7 on January 04, 2012, 02:16:46 AM
sorry, but anyway Error:
Unknown column 'i' in 'where clause'
File ..\ www \ Sources \ TPortal.php
Line: 801
Title: Re: article comments 2 bugs
Post by: IchBin™ on January 04, 2012, 09:14:05 AM
Attach your file please.
Title: Re: article comments 2 bugs
Post by: zalias7 on January 04, 2012, 11:27:25 AM
Attach your file please.

Attach TPortal.php  or other ?
Title: Re: article comments 2 bugs
Post by: lurkalot on January 04, 2012, 12:22:58 PM
Attach your file please.

Attach TPortal.php  or other ?

Your TPortal.php file is the file you need to attach.
Title: Re: article comments 2 bugs
Post by: zalias7 on January 04, 2012, 12:46:26 PM
Attach your file please.

Attach TPortal.php  or other ?

Your TPortal.php file is the file you need to attach.

vakaras.lt/TPortal.p_p
Title: Re: article comments 2 bugs
Post by: ZarPrime on January 05, 2012, 11:04:52 AM
zalias7,

Your last post did not have the TPortal.php file attached but you should be able to attach it to your next post.  Could you try it again please?

ZarPrime
Title: Re: article comments 2 bugs
Post by: zalias7 on January 05, 2012, 01:46:35 PM
Yesterday, I did not attach a file, and add links. Today I can not attach files Thank you  ::)
Title: Re: article comments 2 bugs
Post by: IchBin™ on January 05, 2012, 04:41:53 PM
You removed a couple of characters when you edited the file.

This part:
WHERE i= {int:artid}',

Needs to have been this:
WHERE id = {int:artid}',

I have attached your fixed file.
Title: Re: article comments 2 bugs
Post by: zalias7 on January 06, 2012, 07:17:49 AM
I do not understand how it happened, but thanks.
As with the other problem: removed user name in article comments?
Title: Re: article comments 2 bugs
Post by: IchBin™ on January 06, 2012, 09:05:04 AM
I don't understand what you are saying about that issue, can you explain how to replicate the issue? Show a screenshot or something?
Title: Re: article comments 2 bugs
Post by: zalias7 on January 06, 2012, 10:56:49 AM
removed users seen as 0
Title: Re: article comments 2 bugs
Post by: IchBin™ on January 06, 2012, 01:32:40 PM
Yeah, it's showing 0 if the user doesn't have a name.

Try to find this code in Sources/TPortal.php about line#778
Code: (find) [Select]
'poster' => $row['realName'],
Code: (replace with) [Select]
'poster' => !empty($row['realName']) ? $row['realName'] : $txt['tp-guest'];
That was just off the top of my head, so if it doesn't work go ahead and remove the code. It should say "Guest" instead of 0, assuming that is what you want?
Title: Re: article comments 2 bugs
Post by: zalias7 on January 08, 2012, 09:57:55 AM
Thanks !

and last problem:

this footer with tiniportal logo and with default theme.

(https://www.tinyportal.net/proxy.php?request=http%3A%2F%2Fhost-photo.com%2Fthumb.php%3Ff%3Dgeras.jpg&hash=d4aa39bf9c77b20097fe609828e8b63bacebc5ae) (http://host-photo.com/photo.php?f=geras.jpg)

this footer with tiniportal logo and green_theme_rc5.zip theme http://custom.simplemachines.org/themes/index.php?lemma=2265

(https://www.tinyportal.net/proxy.php?request=http%3A%2F%2Fhost-photo.com%2Fthumb.php%3Ff%3Dzalia.jpg&hash=8a095212d49e028764b0e884135de7b5347b2c3e) (http://host-photo.com/photo.php?f=zalia.jpg)

What to do? :)
Title: Re: article comments 2 bugs
Post by: Lesmond on January 08, 2012, 10:11:27 AM
in index.css

Code: (find) [Select]
#footerarea ul li.copyright
{
display: block;
line-height: 0;
font-size: small;
padding: 1em;

Code: (Change to) [Select]
#footerarea ul li.copyright
{
display: block;
line-height: 1;
font-size: small;
padding: 1em;
Title: Re: article comments 2 bugs
Post by: zalias7 on January 08, 2012, 10:25:26 AM
prefect, big , big thanks !