TinyPortal

Development => Support => Installation => Topic started by: trentend on November 26, 2006, 09:02:39 AM

Title: 1.1 RC3 and 0.9.6 Catastrophic install failure.
Post by: trentend on November 26, 2006, 09:02:39 AM
I have a problem.

I install 1.1 RC3, apply the security patch which is available.  Then install tp 0.9.6 (it checks out okay) as a package.  After installation all I can ever see is a blank browser window with no page source code (ie and firefox).

I cannot access the board, so cannot administer it in any way.  I get nothing.

I have repeated this process enough times (three) to establish that I get the same result every time.  I have checked all of the file priviledge's (and cannot see any problems).  I have tried copying the manual install filles over the top of the package modified files.  No change.

The only way I seem to be able to restore a working smf board, is to delete the tp records from the database, delete the whole smf directory, upload smf again, sort out the file permissions, and use repair_settings.php to configure the baord.

It's a long dull process.

I'm just about to give up on tp entirely (and once I have a live board there's no way that I'm messing with it, so will probably use mambo instead even though tp's integration and feature set better matches my needs). Unless anyone here can help me out.

Thanks in advance.

Title: Re: 1.1 RC3 and 0.9.6 Catastrophic install failure.
Post by: RoarinRow on November 26, 2006, 09:25:14 AM
The last time I saw this happen one of the files did not transfer over completely via FTP.  There was a file, I can't remember which one, that was 0kb in size.  After I FTP'd the same file over again, I was o.k.  Do you have anything like that in your root directory?
Title: Re: 1.1 RC3 and 0.9.6 Catastrophic install failure.
Post by: trentend on November 26, 2006, 09:40:27 AM
No.  Certainly no files in my smf base directory.  As well as being in this state from the package install, it also remains in this state if I copy over the modifield files prepared by L3X (http://www.tinyportal.net/smf/index.php?topic=10242.30) for a manual install.  As a result of these two approaches I find it very hard to believe it's the result of an ftp error.
Title: Re: 1.1 RC3 and 0.9.6 Catastrophic install failure.
Post by: Crip on November 26, 2006, 09:42:42 AM
May I see a link?
Title: Re: 1.1 RC3 and 0.9.6 Catastrophic install failure.
Post by: trentend on November 26, 2006, 09:53:37 AM
May I see a link?

link removed.
***edit***

I've decided to do without tp.  I need to move on with installation of my SMF board.
Title: Re: 1.1 RC3 and 0.9.6 Catastrophic install failure.
Post by: Crip on November 26, 2006, 11:28:45 AM
*******C'ya soon!******  :P
Title: Re: 1.1 RC3 and 0.9.6 Catastrophic install failure.
Post by: hygron on November 28, 2006, 01:10:55 AM
wow...
Title: Re: 1.1 RC3 and 0.9.6 Catastrophic install failure.
Post by: Techdomain on November 28, 2006, 02:17:27 AM
bit hard to help someone if they quit in less then a day!
Title: Re: 1.1 RC3 and 0.9.6 Catastrophic install failure.
Post by: trentend on November 28, 2006, 03:55:59 AM
bit hard to help someone if they quit in less then a day!

I appreciate that.  I wasn't implying any fault or disappointment.  I just needed to get my board up and running, and couldn't risk breaking the live board.

If there had been a simple solution, or problem solving methodology I would have engaged in it.  As it is I just needed to move on.

Sorry for any inconvenience I've caused.  I genuinely wasn't trying to be awkward.
Title: Re: 1.1 RC3 and 0.9.6 Catastrophic install failure.
Post by: IchBin™ on November 28, 2006, 06:41:30 AM
Its your choice Trentend. No problems here. I see no reason you couldn't setup a test environment to get it to work though. Just my $.02
Title: Re: 1.1 RC3 and 0.9.6 Catastrophic install failure.
Post by: trentend on November 28, 2006, 02:13:32 PM
That's a fair point.  When I have a bit of time I'll do exactly that, and post the link here.

I will also need help migrating my current smf board to the new tp-smf setup, if I pursue this option.  Is that possible/easy?
Title: Re: 1.1 RC3 and 0.9.6 Catastrophic install failure.
Post by: Techdomain on November 28, 2006, 03:57:08 PM
yes - quite possible, and there isnt any known reason it should be difficult