HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media


Welcome to TinyPortal. Please login or sign up.

September 21, 2023, 08:13:25 PM

Login with username, password and session length
  • Total Posts: 194,530
  • Total Topics: 21,180
  • Online today: 97
  • Online ever: 3,540
  • (September 03, 2022, 01:38:54 AM)
Users Online
Users: 1
Guests: 61
Total: 62

Permissions Error After Instal

Started by xKillswitchx, February 22, 2006, 06:29:41 PM

Previous topic - Next topic

0 Members and 2 Guests are viewing this topic.


Im am currently on SMF 1.06, with the VisualWarning mod and Now Playing Mod installed.  I just installed TinyPortal after reading up on it a bit, and started in on creating and moving blocks around.  I am using the default theme at the moment.  A link to the forums can be found here, if needed.

My problem is, when I try to go to set member permissions now, I get this error message ...

Parse error: parse error, unexpected ',', expecting ')' in /home/zeldaleg/public_html/forums/Sources/ManagePermissions.php on line 996

This never happened before TP was installed.  Is there anyway to fix this without rolling backwards?  Im not even sure how this happened, even if it was caused by installing TP. 

Ive been wanting to allow members to write articles and submit downloads, but I cant get into the controls.  Also, while Im at it , I have set the download size to be no higher than 8,000 kb, so I can upload a 4 mb zip, but I keep getting an error.  Will look around forums to solve that, unless anyone can dive into that quickly.

Thanks for any help, and thanks for TinyPortal.  It is a very nice system.


You will have to manually edit the ManagePermissions.php file.
Copy the one from your server to your hard drive, and open it with a editing program. Not Wordpad. (It messes up the formating)
I think 2 mods tried to access the same area of this file and there is some fixing to do.
I recomend ConTEXT, for editing php files, but there are many other good free applications. Or you could post the code around line 996 here, and let one of us take a shot.

For download, permissions, use the admin Download link in the user block.

For article permissions, use the TP links in the admin page.


Ok, here is line 994 to 1015.  I hope this isnt too much.  Thanks for all the help you can give me.

         // Tinyportal end
         'visual_warn' => array(
            'visual_warn_any' => false,
            'visual_approve_any' => false,
      'board' => array(
         'general_board' => array(
            'moderate_board' => false,
         'topic' => array(
            'post_new' => false,
            'merge_any' => false,
            'split_any' => false,
            'send_topic' => false,
            'make_sticky' => false,
            'move' => true,
            'lock' => true,
            'delete' => true,
            'post_reply' => true,
            'modify_replies' => false,
            'remove_replies' => false,
            'announce_topic' => false,
         'post' => array(
            'remove' => true,
            'modify' => true,
            'report_any' => false,
         'poll' => array(
            'poll_view' => false,
            'poll_vote' => false,
            'poll_post' => false,
            'poll_add' => true,
            'poll_edit' => true,
            'poll_lock' => true,
            'poll_remove' => true,
         'notification' => array(
            'mark_any_notify' => false,
            'mark_notify' => false,
         'attachment' => array(
            'view_attachments' => false,
            'post_attachment' => false,

   // This is just a helpful array of permissions guests... cannot have.
   $non_guest_permissions = array(

Should it be this?? 

         // Tinyportal end
         'visual_warn' => array(
            'visual_warn_any' => false,
            'visual_approve_any' => false,
         )'  <---- add the ' after the ) ?


Oh wow, sorry but I actually figured it out.  Thanks for all the help.  There was just a " ,  " in the wrong spot.  Have no clue how that got there, but I removed it and all works now.  Thanks again for the help.


Sometimes we help, without doing a thing. Glad you got it working.