HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media


Welcome to TinyPortal. Please login or sign up.

September 21, 2023, 07:33:04 PM

Login with username, password and session length
  • Total Posts: 194,530
  • Total Topics: 21,180
  • Online today: 97
  • Online ever: 3,540
  • (September 03, 2022, 01:38:54 AM)
Users Online
Users: 1
Guests: 64
Total: 65

Permissions issue with SMF

Started by tw0sh0t, January 13, 2006, 11:27:14 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hi guys, I'm trying to install Tinyportal 0.7.5.  Once I upload it, and try to select "Apply Mod" I get an error message:

You cannot download or install new packages because the Packages directory or one of the files in it are not writable!

I go into Options and select to make all files/folders writable, I've even FTP'd in and manually CHMOD'd the Packages directory and even went as far as everything inside the Packages directory to 777.  I STILL get this error message.

I'm using SMF 1.1 RC2 (Had the same problem with SMF 1.1 RC1), my server information is:

Operating System    Linux
Kernel Version    2.4.29-grsec
Apache Version    1.3.34 (Unix)
Perl Version    5.8.1
PHP Version    4.4.2
MySQL Version    4.0.20-standard

Any ideas would be greatly appreciated.  Thanks!


Update, I've tried to install other packages and I have the same problem.  I've posted this on so hopefully some people will share their ideas there also. 

Thanks for anyone who wants to take a crack at this.


Try setting the forum directory, and if possible, the root directory to 777. Had this problem before. Even had an image causing problems because it was not writable (Some SMF images need to be overwritten by TP).


Yep, my root, public_html is CHMOD'd to 777.  My forums are in the root directory.  As all my website is at the moment is SMF forum.


Is the SMF installation new? If yes then I suspect you have a problem with your server configuration. Shared server??

QuoteYep, my root, public_html is CHMOD'd to 777.

How are you doing this?


Not just your directories have to be writeable, but also the files. I change them to 755 after that though. :)
Do you have shell access to this machine? Or just a CPanel and ftp?