News: When asking for support, it helps us and you, if you read the Posting Guidelines

Login  |  Register
* *
TinyPortal on Twitter
Welcome, Guest. Please login or register.
Did you miss your activation email?
November 17, 2017, 07:27:12 PM

Login with username, password and session length

Recent

Members
Stats
  • Total Posts: 181546
  • Total Topics: 20362
  • Online Today: 55
  • Online Ever: 383
  • (January 02, 2015, 05:58:49 AM)
Users Online
Users: 2
Guests: 26
Total: 28

Skinz





Author Topic: db_query error on 2.0.14 installation  (Read 2435 times)

0 Members and 1 Guest are viewing this topic.

Offline Arantor

  • Jr. Member
  • **
  • Posts: 11
Re: db_query error on 2.0.14 installation
« Reply #20 on: October 22, 2017, 03:57:17 AM »
Before we go any further, part of the problem is the assumption that GROUP BY has anything to do with PHP - it absolutely doesn't.

PHP 7 doesn't do anything related to GROUP BY. Neither does PHP 7.1. They don't change how the database expects to be communicated with, the only_group_by stuff is a change made by MySQL themselves and I'd assume you've upgraded from something like MySQL 5.5 to MySQL 5.7 where this is a newer ruling they added for strictness.

You will want to turn this setting off because other parts of SMF and other SMF mods still rely on it (it's something that has been tackled in SMF 2.1)

Tackling this particular code in TP is a little tricky as it involves rewriting the query in a really complicated way but I'll see if I have any ideas as the day goes on.

Offline lurkalot

  • Administrator
  • *
  • Posts: 3719
    • Camera Craniums
Re: db_query error on 2.0.14 installation
« Reply #21 on: October 22, 2017, 04:08:35 AM »
Thanks Arantor, that would be brilliant.  O0

I did wonder if it was a MySQL thing, after I googled the error. 
Mick aka lurkalot.  Running TP1.2 and TP1.2R

Camera Craniums Running SMF 2.0.13 / Tinyportal 1.2
Guitarist Guild Running SMF 2.0.13 / Tinyportal 1.2R Beta
The Garden Machinery Forum Running SMF 2.0.13 / Tinyportal 1.2R Beta

Offline coyoteboy

  • Jr. Member
  • **
  • Posts: 13
Re: db_query error on 2.0.14 installation
« Reply #22 on: October 22, 2017, 09:18:11 AM »
Yeah sorry folks, my very early morning brain screwed the two up. I need to sleep more.

You're right of course, it's not PHP at all.

I can turn off the setting, and I will, but I have other systems on this server that are expecting it (but not necessarily needing it).

Having read further into it (mysql isn't my thing) it looks like turning it off won't give any major issues and doesn't stop me doing what I need with my other systems. I'll disable it for now, but it would be nice to be up to current spec as it's not going to go away. I appreciate there may be other priorities though :)

Cheers folks