Login  |  Register
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media

Recent

Welcome, Guest. Please login or register.
Did you miss your activation email?

August 12, 2022, 06:55:50 PM

Login with username, password and session length
Members
  • Total Members: 3842
  • Latest: Kokoro
Stats
  • Total Posts: 193479
  • Total Topics: 21088
  • Online today: 50
  • Online ever: 1035
  • (November 26, 2020, 04:45:12 AM)
Users Online
Users: 0
Guests: 40
Total: 40

Author Topic: Strange error with SMF2.1  (Read 349 times)

0 Members and 1 Guest are viewing this topic.

Offline davejo

  • Jr. Member
  • **
  • Posts: 27
Strange error with SMF2.1
« on: February 12, 2022, 08:35:17 AM »
Hi,

I've upgraded my test site https://www.davejohnson.co.uk/testing/index.php to SMF2.1.1 and installed various mods one of which is TP.

On my regular site 'https://www.quizland.co.uk' using SMF2.0.19 I have a bottom panel which has some scrolling text 'Friends Of Quizland' and yes TP is there.


Now on the test site I have exactly the same panel with exactly the same code but for some reason it's very small using the default SMF2.1.1 theme

Can anyone tell me why this might be please?

Mods I have installed are:




Offline tino

  • Developer
  • *
  • Posts: 2613
Re: Strange error with SMF2.1
« Reply #1 on: February 12, 2022, 08:44:19 AM »
Something is stopping it picking up the image size and resizing it to be a smaller image. So I would guess there is a CSS element somewhere that's doing that.

Offline @rjen

  • Support Team
  • *
  • Posts: 3285
    • FJR-club Nederland
Re: Strange error with SMF2.1
« Reply #2 on: February 12, 2022, 08:56:33 AM »
I cannot sees the cause at first galnce, but I am pretty sure it is something that changed in the css for SMF 2.1

Can you post your blockcode here (in code tags) so we can see what it does for us?
Running Latest TP on SMF2.1 at: www.fjr-club.nl

Testing TP on SMF2.0
Testing TP on SMF2.1 (latest Github)
Want to check what php version I am testing on? See: PHP Info

Offline davejo

  • Jr. Member
  • **
  • Posts: 27
Re: Strange error with SMF2.1
« Reply #3 on: February 12, 2022, 10:01:49 AM »
Code: [Select]
<style style="text/css">
.marquee {
  width: 100%;
  margin: 0 auto;
  white-space: nowrap;
  overflow: hidden;
  box-sizing: border-box;
  line-height: 25px;
  font-size: 1.3em;
  color: yellow;
}

.marquee span {
  display: inline-block;
  padding-left: 100%;
  will-change: transform;
  /* show the marquee just outside the paragraph */
  animation: marquee 45s linear infinite;
}

.marquee span:hover {
  animation-play-state: paused
}

/* Move it (define the animation) */
@-moz-keyframes scroll-left {
 0%   { -moz-transform: translateX(100%); }
 100% { -moz-transform: translateX(-100%); }
}

/* Make it move */

@keyframes marquee {
  0% {
    transform: translate(0, 0);
  }
  100% {
    transform: translate(-100%, 0);
  }
}


/* Respect user preferences about animations */

@media (prefers-reduced-motion: reduce) {
  .marquee {
    white-space: normal
  }
  .marquee span {
    animation: none;
    padding-left: 0;
  }
}
</style>
<p class="marquee">
   <span>
<a href="https://www.alwayshobbies.com" target="_blank"><img src="https://www.quizland.co.uk/images/adpics/hobbies.png" border="0" alt="Always Hobbies"/></a>

<a href="https://buildzhosting.com/" target="_blank"><img src="https://www.quizland.co.uk/images/adpics/buildz.png" border="0" alt="BuildzHosting/"/></a>

<a href="https://www.gardenguru.co.uk" target="_blank"><img src="https://www.quizland.co.uk/images/adpics/gg.png" border="0" alt="Garden Guru"/></a>

<a href="https://www.davejohnson.co.uk" target="_blank"><img src="https://www.quizland.co.uk/images/adpics/hobby.png" border="0" alt="Hobby Workshop"/></a>

<a href="https://ronaldsarcade.com/" target="_blank"><img src="https://www.quizland.co.uk/images/adpics/ronald.png" border="0" alt="Ronalds Arcade"/></a>

<a href="https://www.facebook.com/Radio-Brian-Gran-Canaria-567533000427221/" target="_blank"><img src="https://www.quizland.co.uk/images/adpics/radiobrian.png" border="0" alt="Radio Brian"/></a>

<a href="https://www.shirleyjphotography.co.uk" target="_blank"><img src="https://www.quizland.co.uk/images/adpics/shirl.png" border="0" alt="Shirley J Photography"/></a>

<a href="https://www.smfhacks.com//" target="_blank"><img src="https://www.quizland.co.uk/images/adpics/smfhacks.png" border="0" alt="SMFHacks"/></a>

<a href="https://www.theadvertiseronline.co.uk/" target="_blank"><img src="https://www.quizland.co.uk/images/adpics/theadvertiser.png" border="0" alt="The Advertiser"/></a>     

<a href="https://www.tinyportal.net/" target="_blank"><img src="https://www.quizland.co.uk/images/adpics/tinyportal.png" border="0" alt="Tiny Portal"/></a>

<a href="https://web-develop.ca/" target="_blank"><img src="https://www.quizland.co.uk/images/adpics/webdev.png" border="0" alt="WebDev"/></a>

</span>
   </p>

<div style="text-align: center;"><a href="https://www.quizland.co.uk/index.php?topic=56" target="_blank"><img src="https://www.quizland.co.uk/images/disclaimer.gif" border="0" alt="External Link Disclaimer"/></a></div>

It's worth noting that I have removed all but the Quiz, Arcade and TP mods form the site now.

Offline @rjen

  • Support Team
  • *
  • Posts: 3285
    • FJR-club Nederland
Re: Strange error with SMF2.1
« Reply #4 on: February 12, 2022, 11:27:11 AM »
It does the same on my local SMF 2.1.1 testbed. Let me have a look tomorrow to see what I can find...
Running Latest TP on SMF2.1 at: www.fjr-club.nl

Testing TP on SMF2.0
Testing TP on SMF2.1 (latest Github)
Want to check what php version I am testing on? See: PHP Info

Offline davejo

  • Jr. Member
  • **
  • Posts: 27
Re: Strange error with SMF2.1
« Reply #5 on: February 12, 2022, 11:59:51 AM »
Thank you @rjen

Offline @rjen

  • Support Team
  • *
  • Posts: 3285
    • FJR-club Nederland
Re: Strange error with SMF2.1
« Reply #6 on: February 13, 2022, 02:48:44 AM »
Had a look, but I cannot find the cause.
Something to to with the marquee styling I suspect.

Pretty sure it is not related to Tinyportal. Perhaps you can get an answer at the SMF forum..
Running Latest TP on SMF2.1 at: www.fjr-club.nl

Testing TP on SMF2.0
Testing TP on SMF2.1 (latest Github)
Want to check what php version I am testing on? See: PHP Info

Offline davejo

  • Jr. Member
  • **
  • Posts: 27
Re: Strange error with SMF2.1
« Reply #7 on: February 13, 2022, 07:31:07 AM »
I think you're right. I have removed the marquee function from the block to just leave the images and they are fine.

As you say I'll ask in SMF

Thanks for lookig at it.