Login  |  Register
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media

Recent

Welcome, Guest. Please login or register.
Did you miss your activation email?

August 09, 2022, 05:20:52 AM

Login with username, password and session length
Members
  • Total Members: 3842
  • Latest: Kokoro
Stats
  • Total Posts: 193479
  • Total Topics: 21088
  • Online today: 57
  • Online ever: 1035
  • (November 26, 2020, 04:45:12 AM)
Users Online
Users: 0
Guests: 42
Total: 42

Author Topic: Theme support  (Read 7705 times)

0 Members and 1 Guest are viewing this topic.

Offline Maxx1

  • Sr. Member
  • ****
  • Posts: 352
  • Learning To Fly
    • SMF Theme & Portal Testing
Theme support
« on: April 30, 2012, 09:22:15 AM »
Sorry Guys had many personal troubles> I'm back if you let me stay? I'll help support Bloc's or anybodies themes, if possible! I don't need to be on any team or such just here to help out like I promised!

Kind regards,.
maxx
But Mama, That's Where all the fun is!

Offline IchBin

  • Friends
  • *
  • Posts: 16231
Re: Theme support
« Reply #1 on: April 30, 2012, 09:24:22 AM »
Sounds good Maxx. You are free to help out anywhere you want around here. Hope the personal troubles subside for you.

Offline Maxx1

  • Sr. Member
  • ****
  • Posts: 352
  • Learning To Fly
    • SMF Theme & Portal Testing
Re: Theme support
« Reply #2 on: April 30, 2012, 09:36:08 AM »
Thanks Brad!!!

regards,
Maxx
But Mama, That's Where all the fun is!

Offline Rus

  • Jr. Member
  • **
  • Posts: 31
    • Local Watering Hole
Re: Theme support
« Reply #3 on: March 27, 2013, 01:57:40 PM »
An old thread but it's right in line with what I'm looking for.  I'm using the Pandora theme from once upon a long time ago.  I know it was written for RC5 but I like it and it still works.

It does put an error in my error log when anyone clicks on unread posts and there are unread posts to see:

 
http://www.tallingroth.ca/index.php?action=unread
Apply Filter: Only show the errors with the same message
8: Undefined index:

File: /home/cy4410/public_html/tallingroth/Themes/pandora_smf20rc5b/Recent.template.php
Line: 209

The line in question is this one:

            $mootip = $topic[$which_post]['preview'];
 
from this area of code:

Code: [Select]
if(!empty($settings['showmootips']))
{
$which = !empty($settings['firstpreview']) ? 'first' : 'last';
$which_post = $which.'_post';
$mootip = '
<img src=' . (!empty($avvy[$topic[$which_post]['member']['id']]) ? $avvy[$topic[$which_post]['member']['id']] : $settings['images_url'].'/TPguest.png') . '  class=mooavy />
<span class=greysmalltext>' . $which .' post by <b>'.$topic[$which_post]['member']['name'].'</b><br>' . $topic[$which_post]['time'] . '</span>
<hr><div> '. $topic[$which_post]['preview'].'</div>';
}
else
$mootip = $topic[$which_post]['preview'];

I've tried declaring those variables up top in a multitude of ways but can't seem to get it right.  Any help would be great.  It's not killing the forum by any means but sometimes it does bury other errors I'm trying to find when I do tweaks.

Thanks guys.

Offline IchBin

  • Friends
  • *
  • Posts: 16231
Re: Theme support
« Reply #4 on: March 27, 2013, 03:24:15 PM »
Move these two lines above the if statement.

$which = !empty($settings['firstpreview']) ? 'first' : 'last';
$which_post = $which.'_post';

Basically what is happening is that those two variables (in the if statement) are not getting set if you hit the (else statement) part of that code.

Offline Maxx1

  • Sr. Member
  • ****
  • Posts: 352
  • Learning To Fly
    • SMF Theme & Portal Testing
Re: Theme support
« Reply #5 on: March 27, 2013, 04:21:44 PM »
Thanks Brad!

I just got done installing the Pandora rc5b on my smf 2.0.4. test site and do not have any issues at all with it so far, no errors in the log. FYI

regards,
maxx
But Mama, That's Where all the fun is!

Offline Rus

  • Jr. Member
  • **
  • Posts: 31
    • Local Watering Hole
Re: Theme support
« Reply #6 on: March 28, 2013, 09:46:48 AM »
Thanks!  That has indeed eliminated those errors.  I had tried to declare them at the top of the function in several ways but nothing seemed to completely fix it, I just kept making new errors.