TP-Docs
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media

Recent

Welcome to TinyPortal. Please login or sign up.

July 24, 2024, 10:00:39 PM

Login with username, password and session length
Members
Stats
  • Total Posts: 195,347
  • Total Topics: 21,237
  • Online today: 80
  • Online ever: 3,540 (September 03, 2022, 01:38:54 AM)
Users Online
  • Users: 0
  • Guests: 49
  • Total: 49

TinyPortal 2.1 and SMF 2.0 Support

Started by @rjen, March 17, 2019, 02:24:09 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

@rjen

Split from: https://www.tinyportal.net/index.php?topic=36266.msg296548#msg296548

I am sure it is doable (though it may have performance impact when it involves that many boards)  but atm we are not adding new features to the 1.x branch anymore. Effort is focused on 2.x branche of TP, which will be SMF 2.1 only...

Running Latest TP on SMF2.1 at: www.fjr-club.nl

jernatety

Ok, I have too many custom changes to 2.0.15 to upgrade to 2.1. Is there any way to pay one of you to modify my TP version 1 last time so that I can have this feature? I guess I'll be done with TP after that :(

tino

Quote from: @rjen on March 17, 2019, 02:24:09 PM
I am sure it is doable (though it may have performance impact when it involves that many boards)  but atm we are not adding new features to the 1.x branch anymore. Effort is focused on 2.x branche of TP, which will be SMF 2.1 only...

TP 2.x will support SMF 2.0 as much as possible. I don't intend to drop support. It will only support php 5.6 or greater and drop support for less than IE 11 ( possibly Edge ) it won't be the primary focus mind but it will work. Still does actually.

@rjen

Quote from: tino on March 17, 2019, 02:36:27 PM
Quote from: @rjen on March 17, 2019, 02:24:09 PM
I am sure it is doable (though it may have performance impact when it involves that many boards)  but atm we are not adding new features to the 1.x branch anymore. Effort is focused on 2.x branche of TP, which will be SMF 2.1 only...

TP 2.x will support SMF 2.0 as much as possible. I don't intend to drop support. It will only support php 5.6 or greater and drop support for less than IE 11 ( possibly Edge ) it won't be the primary focus mind but it will work. Still does actually.

Good you mention that! I did not intend to test with SMF 2.0. Anymore  :-X
Running Latest TP on SMF2.1 at: www.fjr-club.nl

tino

I split the topic, as we had digressed a bit.