TP-Docs
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media

Recent

Welcome to TinyPortal. Please login or sign up.

April 23, 2024, 06:35:33 PM

Login with username, password and session length
Members
  • Total Members: 3,885
  • Latest: Growner
Stats
  • Total Posts: 195,172
  • Total Topics: 21,219
  • Online today: 121
  • Online ever: 3,540 (September 03, 2022, 01:38:54 AM)
Users Online
  • Users: 1
  • Guests: 115
  • Total: 116
  • @rjen

The NEW Button

Started by Skb, March 25, 2019, 10:59:01 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Skb

I'm using SMF 2.1 RC1 / TP 1.6.2.
I have a Right Panel with the Recent Posts Block.
In this Block clicking the NEW button does not have the anticipated response.
It goes to the first post of the last page of the topic.
Whereas, clicking the NEW button in the SMF Board view takes you to your first unread post.

Anyone else experienced that ?

SMF 2.1 RC4 (default theme) / TP 2.1.0

lurkalot

Thanks for the report.  We'll have to check that out and see what's going on.

I think 2.1 has had some issues where this stuff is pointing to the wrong place, including the alerts.  Not sure if they have sorted all this yet.

@rjen

#2
It seems that you have a point...

The new link from the unread view uses another message id then the link from the recent block...

Recent block uses the message ID of the new message, SMF uses that of the last message read... not sure what is causing this and why it did not pop-up before..

Unread link SMF:
https://test2.fjr-club.nl/index.php?topic=23259.msg327172;topicseen#new

Unread link Recent block:
https://test2.fjr-club.nl/index.php?topic=23259.msg327173;topicseen#new

Will have to check it out later...

Just did some checks on 2.0 and even though the same links are used there in 2.0.15 both links bring you to the first new post. In 2.1 the recent block drops you on the first message on the page that holds the new post...
Running Latest TP on SMF2.1 at: www.fjr-club.nl

Skb

On this site if I click the NEW button in the Recent Posts block to the left, it takes me to the first unread post, which is how it should be.

SMF 2.1 RC4 (default theme) / TP 2.1.0

@rjen

True, it is only not working correctly on 2.1.

This site is on 2.0.15
Running Latest TP on SMF2.1 at: www.fjr-club.nl

@rjen

Caused by changes in SMF's SSI.php

function ssi_recentTopics

The field id_msg is populated differently in 2.1 then in 2.0...
No idea if this is something that is a bug or intentional...
Running Latest TP on SMF2.1 at: www.fjr-club.nl

tino

If it's in SSI.php please raise it with SMF. It's not a issue with TinyPortal.

@rjen

It must be: we are using the href link generated by the SSI function.

It seems to be different with 2.1 from 2.0.
Can't put my finger on the exact cause though ..,
Running Latest TP on SMF2.1 at: www.fjr-club.nl

@rjen

Running Latest TP on SMF2.1 at: www.fjr-club.nl

lurkalot

I assume this is related to this problem? https://github.com/SimpleMachines/SMF2.1/pull/5478/files

Though it's scheduled for RC3