HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media


Welcome to TinyPortal. Please login or sign up.

July 20, 2024, 04:40:22 PM

Login with username, password and session length
  • Total Posts: 195,333
  • Total Topics: 21,233
  • Online today: 133
  • Online ever: 3,540 (September 03, 2022, 01:38:54 AM)
Users Online
  • Users: 0
  • Guests: 68
  • Total: 68

Article can still be edited when it is locked for edit

Started by alan, March 02, 2012, 08:57:21 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.



Glad you got it going and thanks 4 letting us know!
gonna mark solved now!

But Mama, That's Where all the fun is!



I replaced TPsubs.template.php, TPmodules.php, TPmodules.english.php, and TPortal.php from the download listed above which successfully fixed the problem I had.

I would now like to upgrade to the TinyPortal 1.0 Final, what is the best method for me to do the upgrade.




Upload the new package, click install. Easy peasy!!! :)

I prefer to uninstall the old first (making sure to not select the option to delete the tables). Always make backups before you do any changes like this though.


I ran the uninstall and got the following message.

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 316161 bytes) in /home/a9623288/public_html/forum/Sources/Subs-Package.php on line 2072

Then if I try to access my forum I get

Warning: require_once(/home/a9623288/public_html/forum/Sources/TPortal.php) [function.require-once]: failed to open stream: No such file or directory in /home/a9623288/public_html/forum/index.php on line 55


Fatal error: require_once() [function.require]: Failed opening required '/home/a9623288/public_html/forum/Sources/TPortal.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/a9623288/public_html/forum/index.php on line 55

And can no longer access my forum.

Luckily I did a full backup before I started.


Looks like your server timed out before it was able to complete the uninstall process. You may want to try to up your memory limit on your server if you attempt it again. If it doesn't work, you may have to uninstall manually.


I did a manual uninstall, not sure if I got everything.

Installed "TinyPortal 1.0 Final" l had an error where I had removed too many lines from index.php during uninstall, fixed that and all seems to be working at the moment.

This was all on my test/development installation. I'm a bit nervous about doing it on my live forum as my test/development install was unusable for a while.

I don't think I can configure memory limit on my host.