News: June 24th, 2017, The Tinyportal team is pleased to announce the release of ~~ TinyPortal 1.3! GET IT NOW!!!

Login  |  Register
* * *
TinyPortal on Twitter
Welcome, Guest. Please login or register.
Did you miss your activation email?
December 12, 2017, 05:17:23 AM

Login with username, password and session length

Recent

Members
  • Total Members: 3697
  • Latest: Ironmad
Stats
  • Total Posts: 181642
  • Total Topics: 20371
  • Online Today: 48
  • Online Ever: 383
  • (January 02, 2015, 05:58:49 AM)
Users Online
Users: 1
Guests: 40
Total: 41

Skinz





Author Topic: Upgrading SMF 2.0.13 to 14 to 15 AND TP 1.2R to 1.3R - questions  (Read 278 times)

0 Members and 1 Guest are viewing this topic.

Offline VladTepes

  • Jr. Member
  • **
  • Posts: 51
Upgrading SMF 2.0.13 to 14 to 15 AND TP 1.2R to 1.3R - questions
« on: November 30, 2017, 06:18:23 AM »
G'day all, I just have some questions before doing anything dramatic that ends life on earth as we know it (crashed forum)

I'm currently running 2.0.13 with TP 1.2R3 and it's working lovely.

I plan to
1. Update all the installed mods to current versions.
2. Upgrade 2.0.13 to 2.0.14 via package manager.
Then assuming that's OK
3.Upgrade to 2.0.15 in the same manner.

Somewhere in this process I want to update from TP1.2R3 to TP1.3R.
At what stage would that be appropriate? (i.e. where in the order of things)

Is it just a matter of uninstalling the current TP version and then installing the new version? That won't lose any settings etc?

I assume the correct place to get the TP1.3R file from is the link in the first post here?:
https://www.tinyportal.net/index.php?topic=35891.0

Also looking at the end of that thread I'm not sure what the current state of the world is regarding SMF and TP compatability with PHP7.x ?   For now I'm running PHP 5.6 so I hope that will be OK.

Thank you all  O0
« Last Edit: November 30, 2017, 06:44:14 AM by VladTepes »

Offline lurkalot

  • Administrator
  • *
  • Posts: 3761
    • Camera Craniums
Re: Upgrading SMF 2.0.13 to 14 to 15 AND TP 1.2R to 1.3R - questions
« Reply #1 on: November 30, 2017, 10:53:58 AM »
Yep, just uninstall TP 1.2R and install TP 1.3R all should be good, and settings and blocks etc should be as before.

I would probably uninstall TP then upgrade SMF via the patches, then install TP 1.3R downloaded from the link you posted above.
 
Bare in mind that you will need TP 1.3R to work on PHP7.+

Also a good idea to check all your themes and other mods are compatible with SMF 2.0.14 / 15

Hope this helps.

Mick aka lurkalot.  Running TP1.2 and TP1.2R

Camera Craniums Running SMF 2.0.13 / Tinyportal 1.2
Guitarist Guild Running SMF 2.0.13 / Tinyportal 1.2R Beta
The Garden Machinery Forum Running SMF 2.0.13 / Tinyportal 1.2R Beta

Offline VladTepes

  • Jr. Member
  • **
  • Posts: 51
Re: Upgrading SMF 2.0.13 to 14 to 15 AND TP 1.2R to 1.3R - questions
« Reply #2 on: November 30, 2017, 11:55:55 PM »
Thanks... its seems there should be no issues re 2.0.14 compatability with the mods I have.
Not so sure re 2.0.15 though as lots of the mods don't specify it as having been tested on that platform.

Re TP and 2.0.14 - I thought that TP1.2R is NOT compatible with 2.0.14. Am I wrong? Perhps tyhats just the PHP issue - I'm running PHP 5.6 anyway.



And a more general question.

In regard to any/all 'mods' is the best way to update always to uninstall/delete the old one and install the new one? That doesn't affect settings etc?

I have done updates before but not sure if that's a universal methodology or if each mod is different in how to update it best....

Offline lurkalot

  • Administrator
  • *
  • Posts: 3761
    • Camera Craniums
Re: Upgrading SMF 2.0.13 to 14 to 15 AND TP 1.2R to 1.3R - questions
« Reply #3 on: December 01, 2017, 12:18:24 AM »

Re TP and 2.0.14 - I thought that TP1.2R is NOT compatible with 2.0.14. Am I wrong? Perhps tyhats just the PHP issue - I'm running PHP 5.6 anyway.


You are correct, although TP 1.2R will actually work with 2.0.14, it will throw the dreaded login session check error, TP 1.3R has this fixed along with support for php7


In regard to any/all 'mods' is the best way to update always to uninstall/delete the old one and install the new one? That doesn't affect settings etc?

I have done updates before but not sure if that's a universal methodology or if each mod is different in how to update it best....

There's no upgrade version of TP, so it's always a case of uninstall old and install new version. That's the best way with TP.  Other mods you would need to follow the specific instructions for those mods.
Mick aka lurkalot.  Running TP1.2 and TP1.2R

Camera Craniums Running SMF 2.0.13 / Tinyportal 1.2
Guitarist Guild Running SMF 2.0.13 / Tinyportal 1.2R Beta
The Garden Machinery Forum Running SMF 2.0.13 / Tinyportal 1.2R Beta

Offline VladTepes

  • Jr. Member
  • **
  • Posts: 51
Re: Upgrading SMF 2.0.13 to 14 to 15 AND TP 1.2R to 1.3R - questions
« Reply #4 on: December 06, 2017, 06:06:41 PM »
Thanks  :)