TP-Docs
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media

Recent

Welcome to TinyPortal. Please login or sign up.

June 15, 2024, 03:12:46 AM

Login with username, password and session length
Members
Stats
  • Total Posts: 195,242
  • Total Topics: 21,223
  • Online today: 137
  • Online ever: 3,540 (September 03, 2022, 01:38:54 AM)
Users Online
  • Users: 0
  • Guests: 133
  • Total: 133

Strange issue seems to be server related

Started by wildenborch, March 05, 2018, 10:19:51 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

wildenborch

Hi,

I just noticed that I can no longer turn off/on Toggle show article on the frontpage (and Sticky & Lock).

After some checking it looks like this is server (hosting) related.
My main site is hosted in the USA and the copy of this site is hosted in the Netherlands.
On the main site i cannot change the setting, on the copy site I can change this setting.

I tried it with Tinyportal 1.4.1, 14R and 1.2 all with the same result.
I also tried it with a total clean install of SMF & TP 1.4.1.
I tried to change it in the Article self and via the Article menu

I can change all details, social bookmark buttons etc. but not the Frontpage, Sticky, Lock
In the article menu I can not change Frontpage, Sticky and Lock but also also not make the article inactive or make it Featured article.

The only way I can change these through SQL (phpadmin) directly.

Is there something I should check in the PHP settings?
Both sites are running on PHP 5.6 (on a shared server)

You can see the behavior here: https://youtu.be/QAIJAnYVOqA

lurkalot

Strange one.  I've not seen this problem in any of my test installs, or my live sites.  All running on the same php version.  What happens if you just toggle them without saving?  Do they work as expected then?

wildenborch

Yes, the icons are changing as expected. 

I have three SMF/TP websites hosted by this company and all have the same problem.


wildenborch

I might have found the problem!
In CPanel there is an option: ModSecurity. This was enabled.
After disabling this security I can toggle the Frontpage, sticky and Lock.

So now I have to check if ModSecurity is important to have.....

lurkalot

Quote from: wildenborch on March 05, 2018, 05:57:20 PM
I might have found the problem!
In CPanel there is an option: ModSecurity. This was enabled.
After disabling this security I can toggle the Frontpage, sticky and Lock.

So now I have to check if ModSecurity is important to have.....

No keep mod security turned off if possible, it can cause havoc. Glad you found the problem, and thanks for letting us know, it'll be handy info for anyone experiencing the same problem.

wildenborch


lurkalot

Quote from: wildenborch on March 05, 2018, 06:25:13 PM
Ok, I will keep ModSecurity off!

Just in case you're worried about turning mod security off, here's a bit of info for you. https://wiki.simplemachines.org/smf/Mod_security_-_Having_problems_with_mod_security

As you can turn it off in CPanel you shouldn't need to follow those instructions to disable it.

wildenborch