Login  |  Register
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media

Recent

Welcome, Guest. Please login or register.
Did you miss your activation email?

November 26, 2022, 01:58:28 AM

Login with username, password and session length
Members
  • Total Members: 3853
  • Latest: tty456
Stats
  • Total Posts: 193602
  • Total Topics: 21103
  • Online today: 74
  • Online ever: 3540
  • (September 02, 2022, 06:38:54 PM)
Users Online
Users: 0
Guests: 64
Total: 64

Author Topic: Upgraded to 2.2.2 and am having an issue with panel display  (Read 1079 times)

0 Members and 1 Guest are viewing this topic.

Offline pulgoki

  • Jr. Member
  • **
  • Posts: 17
Judging from past experience, this has to be something I've screwed up.

I upgraded to the new version of TP today.  I have the upper panel set to display blocks in three columns and then have 3 blocks set up. Before the upgrade, the blocks displayed in a horizontal row of the 3 blocks each taking up 1/3 of the upper panel.  Now, the blocks display in a column of 3 blocks off to the left side of the upper panel. I can't get them to  display correctly. 

Any suggestions to get this resolved would be appreciated.

Offline @rjen

  • Support Team
  • *
  • Posts: 3330
    • FJR-club Nederland
Re: Upgraded to 2.2.2 and am having an issue with panel display
« Reply #1 on: May 19, 2022, 11:26:07 AM »
First refresh browser cache
Running Latest TP on SMF2.1 at: www.fjr-club.nl

Offline pulgoki

  • Jr. Member
  • **
  • Posts: 17
Re: Upgraded to 2.2.2 and am having an issue with panel display
« Reply #2 on: May 19, 2022, 11:58:39 AM »
I tried that and got no love.  I'll post back in a few minutes. I managed to get it to show the blocks in the 3 columns, but I had to change the way they were displayed to grid and set the size to 33%.

I've never had to do that before so I'm not sure why it would act that way now. 

I changed it back to 3 columns and it went right back to displaying the blocks in a 1 column row.

For now, until I can get this figured out, the grid display works? 

If I had more time I would set up a test server and try this from scratch.  I would imagine that this is more difficult to trouble shoot on an upgraded install than on a fresh. 

Offline pulgoki

  • Jr. Member
  • **
  • Posts: 17
Re: Upgraded to 2.2.2 and am having an issue with panel display
« Reply #3 on: May 19, 2022, 12:03:01 PM »
Yikes!  When I try that, it throws tons of errors. Apparently that isn't the solution. 

Code: [Select]
forum/Sources/TPortal.php (Line 2040)
Undefined variable $grid_recycle


Offline pulgoki

  • Jr. Member
  • **
  • Posts: 17
Re: Upgraded to 2.2.2 and am having an issue with panel display
« Reply #4 on: May 19, 2022, 12:22:57 PM »
The grid error was my fault. I missed checking the grid layout. It indeed works, but isn't what I'm looking for.

I've tried Horizontal, 2 colums, 3 columns, and 4 columns, and all of them display the blocks in 1 single column aligned to the left of the page.

Is it possible to downgrade back to 2.2.1? I don't wan to toast my install.

Offline pulgoki

  • Jr. Member
  • **
  • Posts: 17
Re: Upgraded to 2.2.2 and am having an issue with panel display
« Reply #5 on: May 19, 2022, 01:21:31 PM »
Ok, so I went through the trouble of removing an old version of TP from my test server. I made sure the database was completely cleaned out of any TP entries.

I upgraded the test server to the latest version of smf (2.1.2) and then installed the latest version of TP (2.2.2)

I set the upper panel up to display 3 columns like I had on my live forum. I created 3 blocks in the upper panel.

The result is the same. It doesn't display the blocks in 3 columns. It displays them in a single row off to the left side of the panel.

I haven't tried to do this in any of the other panels so I don't know if I would see the same results.


edit: to add, I reverted my test forum back to 2.2.1 and the blocks displayed in a horizontal row as expected.

Is it safe to downgrade from 2.2.2 to 2.2.1? 

Offline @rjen

  • Support Team
  • *
  • Posts: 3330
    • FJR-club Nederland
Re: Upgraded to 2.2.2 and am having an issue with panel display
« Reply #6 on: May 19, 2022, 01:53:45 PM »
There is no issue downgrading TP2.2.2 to 2.2.1: just uninstall 2.2.2, leave the data intact and install 2.2.1

Try it on your test server to be sure.

But before you do that to your production forum, can you share a link to your forum where this can be seen? There are no changes in TP2.2.2 that would explain what you are describing.
Perhaps it is related to the theme you are using, I would like to check this out...
Running Latest TP on SMF2.1 at: www.fjr-club.nl

Offline @rjen

  • Support Team
  • *
  • Posts: 3330
    • FJR-club Nederland
Re: Upgraded to 2.2.2 and am having an issue with panel display
« Reply #7 on: May 19, 2022, 02:00:13 PM »
Just setup 3 blocks in my upper panel here: https://test.fjr-club.nl/index.php and it works as it should...
Running Latest TP on SMF2.1 at: www.fjr-club.nl

Offline @rjen

  • Support Team
  • *
  • Posts: 3330
    • FJR-club Nederland
Re: Upgraded to 2.2.2 and am having an issue with panel display
« Reply #8 on: May 19, 2022, 02:17:45 PM »
Yikes!  When I try that, it throws tons of errors. Apparently that isn't the solution. 

Code: [Select]
forum/Sources/TPortal.php (Line 2040)
Undefined variable $grid_recycle

That's not very nice, and it is actually a bug. I'll fix that for the next version...
Running Latest TP on SMF2.1 at: www.fjr-club.nl

Offline pulgoki

  • Jr. Member
  • **
  • Posts: 17
Re: Upgraded to 2.2.2 and am having an issue with panel display
« Reply #9 on: May 19, 2022, 02:32:17 PM »

Perhaps it is related to the theme you are using, I would like to check this out...

I'm using the default theme on the test server. I also use the default theme to admin the live forum.

Can I private message you a link to the test forum?  You can see it happening there. I upgraded back to the current version of TP and it immediately broke the columns again.


Offline @rjen

  • Support Team
  • *
  • Posts: 3330
    • FJR-club Nederland
Re: Upgraded to 2.2.2 and am having an issue with panel display
« Reply #10 on: May 19, 2022, 02:32:48 PM »
Yes please
Running Latest TP on SMF2.1 at: www.fjr-club.nl

Offline pulgoki

  • Jr. Member
  • **
  • Posts: 17
Re: Upgraded to 2.2.2 and am having an issue with panel display
« Reply #11 on: May 19, 2022, 02:36:36 PM »
link sent

Offline @rjen

  • Support Team
  • *
  • Posts: 3330
    • FJR-club Nederland
Re: Upgraded to 2.2.2 and am having an issue with panel display
« Reply #12 on: May 19, 2022, 02:42:35 PM »
It looks perfect on my phone. What browser do you use?
Running Latest TP on SMF2.1 at: www.fjr-club.nl

Offline pulgoki

  • Jr. Member
  • **
  • Posts: 17
Re: Upgraded to 2.2.2 and am having an issue with panel display
« Reply #13 on: May 19, 2022, 02:50:08 PM »
I'm using chrome and Firefox

I typically use chrome to do the admin, moficiations, and any troubleshooting while using firefox to look at the results as a regular user.

I haven't looked at the site on a mobile device.

Offline @rjen

  • Support Team
  • *
  • Posts: 3330
    • FJR-club Nederland
Re: Upgraded to 2.2.2 and am having an issue with panel display
« Reply #14 on: May 19, 2022, 02:56:33 PM »
This is what your test site looks like on chrome..
attachment 1

and firefox...
attachment 2

I really do not see what the issue is...
Running Latest TP on SMF2.1 at: www.fjr-club.nl

Offline pulgoki

  • Jr. Member
  • **
  • Posts: 17
Re: Upgraded to 2.2.2 and am having an issue with panel display
« Reply #15 on: May 19, 2022, 02:57:26 PM »
This may have been a weird browser cache issue. I'm glad you asked about the browsers.

I closed all browsers down and re-visited the sites and now it looks fine. 

 :uglystupid2:

I'll report back after I get home and make sure that everything looks ok.

Offline @rjen

  • Support Team
  • *
  • Posts: 3330
    • FJR-club Nederland
Re: Upgraded to 2.2.2 and am having an issue with panel display
« Reply #16 on: May 19, 2022, 03:00:39 PM »
Glad that it is sorted. To understand the cause: what tp version were you using before?
Running Latest TP on SMF2.1 at: www.fjr-club.nl

Offline pulgoki

  • Jr. Member
  • **
  • Posts: 17
Re: Upgraded to 2.2.2 and am having an issue with panel display
« Reply #17 on: May 19, 2022, 03:03:51 PM »
I was on 2.2.0 I believe

Thanks for being patient.     


Offline pulgoki

  • Jr. Member
  • **
  • Posts: 17
Re: Upgraded to 2.2.2 and am having an issue with panel display
« Reply #18 on: May 19, 2022, 07:07:32 PM »
Logged in at home and everything looks good!  O0 O0

Offline tino

  • Developer
  • *
  • Posts: 2639
Re: Upgraded to 2.2.2 and am having an issue with panel display
« Reply #19 on: May 20, 2022, 12:07:32 PM »
I don’t see us updating the css tag in the last release, so we didn’t force a css refresh through. Which is probably what caused this issue.

Offline @rjen

  • Support Team
  • *
  • Posts: 3330
    • FJR-club Nederland
Re: Upgraded to 2.2.2 and am having an issue with panel display
« Reply #20 on: May 20, 2022, 12:09:33 PM »
What is the css tag you are referring to?
Running Latest TP on SMF2.1 at: www.fjr-club.nl

Offline tino

  • Developer
  • *
  • Posts: 2639
Re: Upgraded to 2.2.2 and am having an issue with panel display
« Reply #21 on: May 20, 2022, 12:11:44 PM »
TPVERSION is the define in integrate.php its still on v210

Offline @rjen

  • Support Team
  • *
  • Posts: 3330
    • FJR-club Nederland
Re: Upgraded to 2.2.2 and am having an issue with panel display
« Reply #22 on: May 20, 2022, 12:47:36 PM »
Aha, I was not aware that it needed updating
Running Latest TP on SMF2.1 at: www.fjr-club.nl

Offline tino

  • Developer
  • *
  • Posts: 2639
Re: Upgraded to 2.2.2 and am having an issue with panel display
« Reply #23 on: May 20, 2022, 01:35:25 PM »
Aha, I was not aware that it needed updating

Only if we change the css or JavaScript. No harm in doing it each release though.