TP-Docs
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media

Recent

Welcome to TinyPortal. Please login or sign up.

February 24, 2024, 03:11:08 AM

Login with username, password and session length
Members
  • Total Members: 3,881
  • Latest: fords8
Stats
  • Total Posts: 195,062
  • Total Topics: 21,208
  • Online today: 70
  • Online ever: 3,540 (September 03, 2022, 01:38:54 AM)
Users Online
  • Users: 0
  • Guests: 63
  • Total: 63

If you upgraded from SMF1 to SMF2 with TP.

Started by IchBin, June 24, 2011, 03:17:48 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

IchBin

While I'm aware there are some language issues with characters sets, this update to the database installer addresses only the issue with the columns not updating properly. Please upload this file to the root of your SMF folder. Then access the file and run it in your browser.

Example:
http:/www.yourdomain.com/smf/tp_upgrarde.php

Please report in this topic if you have any problems. Thanks.

mrph

Finally works!
U  see that u can make it work properly. :)
Thank you very very very much and sorry if i was annoying. :P

p.s. u get typo error -> they should run tp_upgrade.php

IchBin

Yeah, but right now it only works if you run it stand alone. For some reason it does not work when I use it with the package... Glad it worked for you.

mrpike

Quote from: IchBinâ,,¢ on June 24, 2011, 04:00:23 PM
Yeah, but right now it only works if you run it stand alone. For some reason it does not work when I use it with the package... Glad it worked for you.
:D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D Works  ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D

IchBin

I split out the posts not related to this database script. Please only post in this topic if you have errors with the script.

aschofield

I was also having this issue too. This update fixed those issues for me, thanks. Save regressing my board!!

WillyP

There should be a note with a link on the download page to here.

For the benefit of anyone who may use search to find this:

Unknown column 'value9' in 'smf_tp_variables'
File:  /Packages/temp/SMF2/tp_upgrade.php
Line: 347

ZarPrime

Good idea WillyP.  Added that note for you. O0

WillyP

Thank you! Should probably do same at the SMF Mod site, or make the file available there.

Kinesthesia

I just wanted to add my thanks for sorting this issue out.

Lucas3677

Thank you, this worked for me. I was getting the problem "Duplicate column name 'id_member'"

simpsonetti

#11
Hi, i ipgrade my site from smf 1 to smf2 final.
i have previously installed TP. now i want to install TP again and i get this error after i execute ...smf/tp_upgrade.php :

Quote
Database Error
Duplicate column name 'id_member'
File: /is/htdocs/27093450h_478hj67iGH2/www/xxxxxx/smf/tp_upgrade.php
Line: 316
Back
**EDIT**
Okay, after using this modified version it works !!
Thanks a lot !!

welshdog

Quote from: WillyP on July 03, 2011, 12:10:30 AM
There should be a note with a link on the download page to here.

For the benefit of anyone who may use search to find this:

Unknown column 'value9' in 'smf_tp_variables'
File:  /Packages/temp/SMF2/tp_upgrade.php
Line: 347

Got that originally... so ran tp_upgrade.php

When I went back to the forum it returned

From tinyportal.net...
XML error: syntax error at line 1

... so I uninstalled (everything) and reinstalled rc2... but SMF returned the same error message.

IchBin

That error message looks like it's from older code or something. Are you sure your files are getting replaced when you install TP over your old install?

vranx

I am trying to install TP on SMF 2.0.1. After install I get this error:
Unknown column 'globaltags' in 'field list'
File: /home/badagui/public_html/Sources/TPortal.php
Line: 2951

No matter what page I try to go to I get that error. I tried the script at the top of this thread and it still gives that error.
badaguild.com/tp_upgrade.php

IchBin

After you run the tp_upgrade.php file, if you look at your database in the tp_modules table, can you post what columns you have in that table?

mikehsg

I'm getting this error with SMF 2 and being somewhat of a coding Luddite I could use a little "For Dummies" level help:

Database Error
Duplicate column name 'id_member'
File: /home/philisti/public_html/tp_upgrade.php
Line: 316

lurkalot

Quote from: mikehsg on November 12, 2011, 03:58:16 PM
I'm getting this error with SMF 2 and being somewhat of a coding Luddite I could use a little "For Dummies" level help:

Database Error
Duplicate column name 'id_member'
File: /home/philisti/public_html/tp_upgrade.php
Line: 316

Hi, and welcome to TP support.

Did you upload and run the script that IchBin attached to the first post in this thread?

tempuser

Hi there,

I've got a serious problem after using the script from the first post:
I used webinstall.php to upgrade my SMF 1.1.15 to 2.0.1 and tried to install TP by uploading the .zip via the packet management. The TP-install-Test was fine and i hit "Install Now"; this left me with the error described in this thread. And then, after i used the attached script in the first post...

first this script doesn't work for me... leaving me with:
Quote
Notice: Undefined index: dl_wysiwyg in /srv/www/htdocs/XXXXX/smfforum/Sources/TPortal.php on line 333 Notice: Undefined index: dl_introtext in /srv/www/htdocs/XXXXX/smfforum/Sources/TPortal.php on line 334 Notice: Undefined index: dl_screenshotsizes in /srv/www/htdocs/XXXXX/smfforum/Sources/TPortal.php on line 342 Notice: Undefined index: art_imagesizes in /srv/www/htdocs/XXXXX/smfforum/Sources/TPortal.php on line 343

Database Error

Please try again. If you come back to this error screen, report the error to an administrator.
Back

But even worst: when i try to open my forum, i get:
Quote
Database Error
Please try again. If you come back to this error screen, report the error to an administrator.
and can't even log in...

Kind regards
Oliver


//edit:
Ok, running webinstall.php again solved this issue... so far i don't get a db-error and can use the forum normally... but i don't dare to try tp_upgrade.php another time...

lurkalot

Quote from: tempuser on November 13, 2011, 12:18:56 AM
Hi there,

I've got a serious problem after using the script from the first post:
I used webinstall.php to upgrade my SMF 1.1.15 to 2.0.1


Are you saying you actually upgraded SMF using webinstall?  That might be your problem.  The recommended way would be to use the large upgrade package when moving from one major version to another.  Webinstall is for installing from scratch. See here about upgrading, http://wiki.simplemachines.org/smf/Upgrading

mikehsg

Mick - I did indeed, but I'm not 100% sure I put it in the right place. What folder does this thing ideally go into and how specifically do I execute the script?

lurkalot

Mike, the file goes into the root folder of your forum.  In other words, It's the folder on your server which contains all the files for SMF. ;)

Then run it from your address bar in your browser.  http:/www.yourdomain.com/your forum folder/tp_upgrade.php


mikehsg

Mick - Did that, and got a page about upgrading tables successfully. What I still don't have is a portal. Is there an "on" switch someplace here that I'm missing?

I'm getting this at the bottom of the main page now:

Fatal error: Call to undefined function tportal_version() in /home/philisti/public_html/Sources/Load.php(2151) : eval()'d code on line 449

lurkalot

Mike, we might need IchBin to advise us on this, but I've sent you a PM, are you able to reply to it?.

mikehsg

#24
Mick -

Can't reply to your PM. I've created the account, though. Email me directly and I'll give you the login information.

lurkalot

OK, just to confirm, that was a theme issue, and not a upgrade script error.  Theme used was a old TP 0.9.8 theme.

Qayyom

tp_upgrade.php showing blank page after uploading at public_html direcotry

any solution?


IchBin

What version of SMF are you using? What version of TP are you trying to use tp_upgrade.php from? Any information you provide will help us to answer you.