HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media


Welcome to TinyPortal. Please login or sign up.

June 25, 2024, 10:35:32 PM

Login with username, password and session length
  • Total Posts: 195,280
  • Total Topics: 21,227
  • Online today: 203
  • Online ever: 3,540 (September 03, 2022, 01:38:54 AM)
Users Online

Unable to load the 'main_above' template.

Started by Freddy, September 04, 2022, 12:59:23 PM

Previous topic - Next topic

0 Members and 5 Guests are viewing this topic.


Hello! Long time since I played!

On a site I help with we were forced to upgrade to SMF 2.1.2 and so we got the 2.2.2 version of TP.

The backend in admin works, but if we try to navigate to say downloads, we get this error and I wondered if anyone had any ideas please?

URL: <site>/index.php?action=tportal;sa=download;dl

Error: Unable to load the 'main_above' template.

Been a long time since I worked with TP so thought I would ask first.

Cheers :)


Trying that url on this site works ok. So it's not something I have missed when moving thing around.

The main_above is generally when you are trying to load a page when it doesn't exist. Do you have any modifications or changes on there? Maybe in a block or something similar. There should be more details logged in the SMF Error Log if you could provide those that will help also.

Can you provide a link to the site in question so I can see what is going on?


Hi Tino :)

The error comes when accessing Downloads from the main menu and also when trying to access the Downloads section in the TP Admin Panel.

Here's the site page:;sa=download;dl

The home page is empty at the moment.

Error message:


Type of error: Template
Error messageSelect
Unable to load the 'main_above' template.



Type of error

Error message
Unable to load the 'main_above' template.

URL of page causing the error;sa=download;dl

Backtrace information
#0: loadSubTemplate()
Called from /home/datahopa/public_html/Sources/Subs.php on line 4555
#1: template_header()
Called from /home/datahopa/public_html/Sources/Subs.php on line 4162
#2: obExit()
Called from /home/datahopa/public_html/index.php on line 194

It's not blocks I don't think, this is not a custom page, it's the TP Download page.


Thanks, can you confirm what TP files you have in the themes folder? I'm wondering if somehow some weren't installed.

What was the version of TinyPortal before you did the upgrade?


Just curious, I was looking at your site and tried to access the default theme because I seem to remember that there is some dependency in the index template file.

It seems that the default SMF (Curve2) is missing?

This links should basically bring me to the default SMF theme, but it  does not?

What exactly happened there?
Running Latest TP on SMF2.1 at:


Hello chaps, I'm working with Freddy on the site datahopa, he asked me to jump in as I have access to all the sites files.

I was forced to update the site to SMF 2 as the server was no longer supporting php5, I know I should have updated a long time ago but I had made a lot of custom mods and files that wouldn't have worked with SMF2. Please don't tell me off about that  :)

The old site was running a Beta version of TP perfectly well for many years, seriously many years and I loved working with TP on the site. Again I never updated TP.

So that's the Story.

Can a new member use attachments?  I will try.

Attached is a pic of the TP files located in the default theme.

Yes the default theme is installed on the site but not being used.

Thanks for any help.


WHAT beta version of TP was being used? Version number please...
Running Latest TP on SMF2.1 at:


Question 1: does the same error appear when you are using the Default SMF theme?
(I can't test it, because the theme is apparently not selectable)

Question 2: what theme are you using now, can you share a download link?
Never mind: it is this one I guess...
Running Latest TP on SMF2.1 at:


Thanks for the reply @rjen

Ok I went digging and found the version:

TinyPortal 10rc1

I will get back to you regarding the error with the default theme ASAP


Just installed Fusion on a test forum with TinyPortal 2.2.3 on it, and it works fine...

Would you mind uninstalling TP and re-installing it? Or did you try that already?
Running Latest TP on SMF2.1 at:


Yes as you thought it's the same on the default theme.

Before I uninstall TP, no I haven't tried it yet but I remember the downloads broke a while back on the old site, I had forgotten about that when I did the update to SMF2.

These must be related in some way. 


What exactly do you mean with 'the downloads broke' ?

That makes me a bit suspicious...
Running Latest TP on SMF2.1 at:


Need to go now but what I recommend is that you make sure to create a phpmyadmin backup of all tp_ tables from your forum.

Store that safely.

I am starting to suspect that there is something off in one of the tables.

Need to think about that a bit...
Running Latest TP on SMF2.1 at:


Quote from: @rjen on September 06, 2022, 05:33:53 PM
What exactly do you mean with 'the downloads broke' ?

That makes me a bit suspicious...

When I clicked a link to goto the downloads nothing happened, not even an error message that I can remember.

I agree with you that there is something wrong in the DB.


Did you use the downloads? Any entries in the tp_downloads table?

You can try this:
1. Create a full sql backup of all tp_ tables
2. Uninstall TP
3. Remove the tp_ tables from the database
4. Install TP clean

Check if it works now...
Then you can import the tp_ tables from the backup and see if it is ok...

It is a bit trial and error, best done on a test forum...
If you have that, give it a go, otherwise I am willing to test it if you can share the .sql backup of your tp_ tables.,.
Running Latest TP on SMF2.1 at:


Thanks for all your help @rjen

I've fixed the problem - it was an old theme that the DL part of TP was looking for but the path to the theme in SMF was incorrect.


Quote from: Data on September 07, 2022, 12:05:52 AM
Thanks for all your help @rjen

I've fixed the problem - it was an old theme that the DL part of TP was looking for but the path to the theme in SMF was incorrect.

It is nice that you found the problem: I am a bit confused though, because I cannot reproduce the error in any way:
1. Tried to delete the previously assigned theme: TinyPortal falls back to the default...
2. Tried by deliberately breaking the theme paths: TinyPortal page shows up without formatting, but it does show...

Would you mind sharing how exactly you managed to break it so it would result in the Unable to load the 'main_above' template error? Perhaps we can prevent such errors in future...
Running Latest TP on SMF2.1 at:


Been busy here.

Sorry I can't shed any more light on the error, once I removed the bad path to the old theme it just came to life.

I wish I could give you some more info but ...


Never mind, I was curious because I cannot reproduce it.

Since it is an edge case it is not that important.
Running Latest TP on SMF2.1 at: