TinyPortal

Development => Support => Topic started by: Spacecake on May 18, 2022, 01:21:49 PM

Title: Bad Gateway in TP 2.2.2 -> Blocks Administration
Post by: Spacecake on May 18, 2022, 01:21:49 PM
Hi there,

I was happily installing 2.2.2 today (coming from 2.2.1) on SMF 2.1.2.

Fortunately some smaller bugs are fixed (which could be seen in SMF Log and navigating through blocks and panels) it seems, but unfortunately I cannot access blocks section from TP Admin menu.

It will return a 502 - Bad Gateway, have already cleared my browser cache, cookies etc. but to no success.

Maybe someone has an idea how to progress on this one?

Kind Regards
Christian
Title: Re: Bad Gateway in TP 2.2.2 -> Blocks Administration
Post by: tino on May 18, 2022, 02:28:38 PM
You’re going to have to provide more information about your environment I am afraid. 502 is generally when a proxy server is involved. So it’s getting a response it doesn’t like.

Can you access the individual block if you enable that functionality?
Title: Re: Bad Gateway in TP 2.2.2 -> Blocks Administration
Post by: Spacecake on May 19, 2022, 12:05:38 PM
Hi,

I have found out, that if I add an block, which actually works, I can also see the block section to administrate. Once I delete this block again, I again run into 502 error.

What exactly do you need in terms of the environment data?

PHP version: 7.4.29
NGINX
running on a quite sufficient vserver.

So I added another block which I just did not activate, hence I can access the block administration again, but of course this is not the intended state :)

Thanks in advance and Kind Regards
Christian
Title: Re: Bad Gateway in TP 2.2.2 -> Blocks Administration
Post by: tino on May 20, 2022, 12:10:10 PM
Do you have anything in your browser console log? Or NGINX logs? I can’t recreate it currently.