Login  |  Register
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media

Recent

Welcome, Guest. Please login or register.
Did you miss your activation email?

December 08, 2022, 04:38:36 PM

Login with username, password and session length
Members
  • Total Members: 3853
  • Latest: tty456
Stats
  • Total Posts: 193628
  • Total Topics: 21108
  • Online today: 84
  • Online ever: 3540
  • (September 02, 2022, 06:38:54 PM)
Users Online
Users: 0
Guests: 66
Total: 66

Author Topic: Problema con Servidor MySQL  (Read 9101 times)

0 Members and 1 Guest are viewing this topic.

anabelen

  • Guest
Problema con Servidor MySQL
« on: July 03, 2009, 04:19:35 PM »
Hola chicos/as, me sucede algo muy curioso que no se si le estará pasando a mas usuarios.

Tenemos instalada la Version SMF 1.9, con la version de TinyPortal v1.0 beta 4.

Nos sucede que cuando lo tenemos activo, funciona correctamente pero al cabo de unos dias, nos colapsa los recursos de nuestro servidor al punto de Parar el Servidor de las Bases de Datos de todo el servidor (MySQL).

Estamos usando el Theme Newton.

Quisieramos instalar esta version de TinyPortal v1.0 beta 4 para poderlo utilizar, dado que nos encaja perfectamente con el diseño del portal, si sabeis alguna solucion, comentarnosla porque estamos algo desesperados.

Otra cosa seria utilizar el Theme Newton sobre la version de TinyPortal 0.9.8, cosa que actualmente no es posible, no nos muestra los bloques laterales ni los articulos, solo el foro directamente.

Os dejamos la web en concreto: www.cordobacf-posadas.es

Gracias y Saludos,  
 
« Last Edit: July 17, 2009, 10:45:04 AM by anabelen »

Herr Inoddorell

  • Guest
Re: Problema con Servidor MySQL
« Reply #1 on: July 03, 2009, 08:07:11 PM »
Es una estupidez lo que voy a preguntar pero: se cersioraron de borrar el log de errores?

Ya que en muchas ocasiones la base de datos supera el límite de peso permitido por el hosting debido a esto.

anabelen

  • Guest
Re: Problema con Servidor MySQL
« Reply #2 on: July 04, 2009, 12:17:29 AM »
Pues precisamente ese log es el que se satura, pero rapidisimo cuando esta con la version del tiny beta 4, con la version anterior funciona correctamente, es decir, que se llena ese log de forma normal.

No tenemos contratado hosting, es un servidor dedicado al cual le hemos aumentado el limite de peso permitido.

Saludos y Gracias

Herr Inoddorell

  • Guest
Re: Problema con Servidor MySQL
« Reply #3 on: July 04, 2009, 07:46:22 PM »
Pues precisamente ese log es el que se satura, pero rapidisimo cuando esta con la version del tiny beta 4, con la version anterior funciona correctamente, es decir, que se llena ese log de forma normal.

Ok, sería util entonces si podes postear los errores que te tira. Le estas intentando instalar algun pack de traducción?

Saludos y disculpa por la tardanza de mi respuesta

anabelen

  • Guest
Re: Problema con Servidor MySQL
« Reply #4 on: July 05, 2009, 04:54:49 AM »
Code: [Select]
>>>> 090605 19:40:35 [ERROR] /usr/sbin/mysqld: Table
>>>> './wposadas/smf_log_errors' is m
>>>> arked as crashed and last (automatic?) repair failed
>>>> 090605 19:41:07 [ERROR] /usr/sbin/mysqld: Table
>>>> './wposadas/smf_log_errors' is m
>>>> arked as crashed and last (automatic?) repair failed
>>>> 090605 19:41:07 [ERROR] /usr/sbin/mysqld: Table
>>>> './wposadas/smf_log_errors' is m
>>>> arked as crashed and last (automatic?) repair failed
>>>> 090605 20:05:41 [ERROR] /usr/sbin/mysqld: Table
>>>> './wposadas/smf_log_errors' is m
>>>> arked as crashed and last (automatic?) repair failed
>>>> 090605 20:05:41 [ERROR] /usr/sbin/mysqld: Table
>>>> './wposadas/smf_log_errors' is m
>>>> arked as crashed and last (automatic?) repair failed
>>>> 090605 20:13:18 [ERROR] /usr/sbin/mysqld: Table
>>>> './wposadas/smf_log_errors' is m
>>>> arked as crashed and last (automatic?) repair failed
>>>> 090605 20:13:18 [ERROR] /usr/sbin/mysqld: Table
>>>> './wposadas/smf_log_errors' is m
>>>> arked as crashed and last (automatic?) repair failed
>>>> 090605 20:13:48 [ERROR] /usr/sbin/mysqld: Table
>>>> './wposadas/smf_log_errors' is m
>>>> arked as crashed and last (automatic?) repair failed
>>>> 090605 20:13:48 [ERROR] /usr/sbin/mysqld: Table
>>>> './wposadas/smf_log_errors' is m
>>>> arked as crashed and last (automatic?) repair failed
>>>> 090605 20:34:37 [ERROR] /usr/sbin/mysqld: Table
>>>> './wposadas/smf_log_errors' is m
>>>> arked as crashed and last (automatic?) repair failed
>>>> 090605 20:34:37 [ERROR] /usr/sbin/mysqld: Table
>>>> './wposadas/smf_log_errors' is m
>>>> arked as crashed and last (automatic?) repair failed
>>>> 090605 20:35:11 [ERROR] /usr/sbin/mysqld: Table
>>>> './wposadas/smf_log_errors' is m
>>>> arked as crashed and last (automatic?) repair failed
>>>> 090605 20:35:11 [ERROR] /usr/sbin/mysqld: Table
>>>> './wposadas/smf_log_errors' is m
>>>> arked as crashed and last (automatic?) repair failed


Estos fueron alguno de los errores.

Offline ZarPrime

  • Friends
  • *
  • Posts: 4653
Re: Problema con Servidor MySQL
« Reply #5 on: July 05, 2009, 08:36:30 AM »
Hola anabelen,

Bienvenido a TinyPortal.

La razón de que el tema de Newton no funciona en su sitio con TinyPortal versión 0.98 es que fue diseñado para TinyPortal versión 1.x a fin de usarlo en su sitio web, usted tendrá que actualizar a TP 1.0. TP 1.0 beta 4 es la última versión de TinyPortal.

Para ello, tendrá que cambiar su Foro a los temas fundamentales del DME y desinstalar TP 0,98 en el Gestor de paquetes. Después de esto, puede instalar TP 1.0 beta 4 y el tema de trabajo de Newton.

Asimismo, ¿podría revisar su Foro de registro de errores, vaya a Admin -> Mantenimiento -> Foro de registro de errores. Si hay un gran número de errores es posible que desee borrar todos los errores y empezar de nuevo para ver si se libera algunas de sus recursos.

Si intenta desinstalar TP 0,98 y encontrar que usted consigue al hacer que los errores, puede que tenga que pasar por el manual para desinstalar TP. Si ese es el caso, por favor, nos dice y nos puede dirigir a un tema que dará instrucciones sobre cómo hacerlo.

ZarPrime

In English ...

Hello anabelen,

Welcome to TinyPortal.

The reason the Newton theme does not work on your site with TinyPortal version 0.98 is that it was designed for TinyPortal version 1.x so in order to use it on your site, you will have to upgrade to TP 1.0.  TP 1.0 beta 4 is the latest release of TinyPortal.

To do this, you will need to switch your Forum to the SMD Core theme and uninstall TP 0.98 in the Package Manager.  After this, you can install TP 1.0 beta 4 and the Newton theme will work.

Also, could you check your Forum Error Log by going to Admin --> Maintenance --> Forum Error Log.  If there are very many errors you might want to delete all of your errors and start over to see if that frees up some of your resources.

If you try to uninstall TP 0.98 and find that you get errors when doing that, you might need to go through the manual uninstall for TP.  If that is the case, please tell us and we can direct you to a topic that will instruct you on how to do that.

ZarPrime

Herr Inoddorell

  • Guest
Re: Problema con Servidor MySQL
« Reply #6 on: July 05, 2009, 05:11:51 PM »
@ ZarPrime:

Her problem is that she gets tons of errors when TP v1.0 beta 4 is already installed, not when it isn't. So, that saturates the log errors, and consequently, the data base server too.

So, she doesn't got TP 0.9.8 installed.

Cheers!

Offline ZarPrime

  • Friends
  • *
  • Posts: 4653
Re: Problema con Servidor MySQL
« Reply #7 on: July 05, 2009, 05:34:29 PM »
Herr Inoddorell,

No, she definitely has TP 0.98 installed.  Take a look at this link ...
http://www.cordobacf-posadas.es/index.php?theme=1

Plus, if she already installed TP 1.0 beta 4, she can't go backwards to TP 0.98 unless she has reverted to the database that she had when she was using TP 0.98.  This is because the first upgrade to TP 1.0 causes changes in the database that will cause TP 0.98 to not function properly, giving numerous errors.

It would appear that a majority of her errors can be attributed to having other SMF Mods installed with themes that haven't been edited to use those mods.  The reason the blocks aren't showing with the Newton theme is that it was not converted to be used with TP 0.98.  I would suggest that she revert to the SMF default theme and then clear out her error log.  After that, if she wants to use another theme, any Mods that she has installed will have to have edits to work with the custom theme.

In addition, if she wants to use the Newton theme, she will have to upgrade to TP 1.0 beta 4.

ZarPrime

Herr Inoddorell

  • Guest
Re: Problema con Servidor MySQL
« Reply #8 on: July 05, 2009, 06:40:33 PM »
Oh, I didn't see it :P. First time I took a look she got installed the Newton theme on her forum. Maybe she is now trying to install TP 0.9.8 on the Default theme now, since she couldn't make TP v1.0 beta4 work on it.

Offline ZarPrime

  • Friends
  • *
  • Posts: 4653
Re: Problema con Servidor MySQL
« Reply #9 on: July 05, 2009, 07:09:31 PM »
No, I don't think she has done anything else, unless she tried to go back to TP 0.98 after installing TP 1.0, which you can't do without a backup of the database from the previous install.

She still has the Newton theme set as her forum default.  
Link Here --> http://www.cordobacf-posadas.es/index.php?theme=4

She needs to uninstall TP 0.98 and make sure it uninstalls properly, and then install TP 1.0 beta 4, all while her forum is set to the SMF core theme.

What other SMF Mods does she have installed?  She might be better off to uninstall all her Mods, including TP and then start over by installing 1 Mod at a time, TP first.  Once she has all the Mods installed that she wants to use, then she can select the custom theme she wants to use, and she will have to manually edit the custom theme to work with each of the Mods.  She can figure out what edits are required for her custom theme for each of the Mods by using the package parser on the SMF site on the Mod page for each Mod.

ZarPrime

anabelen

  • Guest
Re: Problema con Servidor MySQL
« Reply #10 on: July 05, 2009, 11:35:47 PM »
A ver chicos/as, debido a que tuvimos estos problemas, decidimos desinstalar todo, incluido el SMF y empezar de nuevo con este orden:

1º SMF
2º TinyPortal 1.0 beta 4
3º Theme Newton

Y al cabo de unos dias, se volvio a colapsar el servidor MySQL.

Posteriormente, desinstalamos el tinyportal 1.0 beta 4 sin ningun error en la desinstalación y luego pusimos la version de tinyportal 0.9.8 que es la que está ahora.

Por lo cual, el problema no viene ni de mods ni de malas instalaciones o desinstalaciones.

Habeis probado instalar lo mismo que nosotros, es decir, 1º SMF - 2º TinyPortal 1.0 beta 4 - 3º Theme Newton

Hay alguien que coincida con estas versiones y themes?

Saludos y gracias

--------------------

To see boys / as because we had these problems, we decided to uninstall everything, including SMF and start again with this command:

1º SMF
2º TinyPortal 1.0 beta 4
3º Newton Theme

And after a few days, he became the MySQL server to collapse.

Subsequently, tinyportal uninstalled the 1.0 beta 4 without any error in the uninstall and then put the 0.9.8 version of tinyportal that is now.

Therefore, the problem does not come or mods or bad install or uninstall.

You have tried to install the same as us, ie, 1 SMF - 2nd TinyPortal 1.0 beta 4-3 º Theme Newton

There is someone who matches these versions and themes?

Greetings and thanks
« Last Edit: July 17, 2009, 03:13:46 PM by ZarPrime »

anabelen

  • Guest
Re: Problema con Servidor MySQL
« Reply #11 on: July 06, 2009, 03:04:56 AM »
Gracias, dejare este tema, aunque me gusta mucho mas el otro  :-\
Esperare una nueva versión de TinyPortal v1.0 beta 4

http://www.cordobacf-posadas.es/index.php

Saludos.

Offline ZarPrime

  • Friends
  • *
  • Posts: 4653
Re: Problema con Servidor MySQL
« Reply #12 on: July 06, 2009, 06:52:58 AM »
anabelen,

Lamento que tengas tantos problemas. Miles de personas están usando TinyPortal 1.0 beta 4 con SMF 1.1.9 sin problemas. De hecho, se puede ver el tema de Newton instalado en mi foro de prueba con este tipo de configuración por aquí buscando ...
http://talesofthehavenexpanse.com/smf1test/index.php?theme=10

Sugiero que usted configure un sitio de prueba y pruébelo haciendo lo siguiente ...

1. SMF 1.1.9 Configuración de un sitio de prueba, una nueva instalación.
2. Hacer una instalación nueva de TinyPortal 1.0 beta 4, sobre la misma.
3. Instalar el tema de Newton.
4. Cambiar a la de Newton tema en el sitio de prueba para ver si funciona bien.
5. Volver a la SMF por defecto instalar el tema y otros SMF Mods, una a la vez.
6. Newton editar el tema para trabajar con el nuevo Mods.

Después de hacer esto, verifique para asegurarse de que no está recibiendo los errores que usted menciona. Parece que algo no está instalado correctamente en su sitio principal.

Tenga en mente un par de cosas ...

1. Todos los Mods, incluyendo TinyPortal debe ser instalado cuando el foro se establece en el tema predeterminado de SMF.
2. Todos los Mods sólo se instalan para trabajar con el tema por defecto. Por esta razón, si desea que el Mods para trabajar con su tema personalizado, los archivos para el tema personalizado mst ser editado para trabajar con el tema.
3. Con el fin de actualizar desde 0,98 a TP TP 1.0 beta 4, debe desinstalar primero TP 0,98.
4. Una vez que se ha actualizado, no puede volver a TP 0,98 a menos que tenga una copia de seguridad de la base de datos como lo era antes con TP 0,98

ZarPrime

In English ...

anabelen,

I am sorry you are having so many problems.  Thousands of people are using TinyPortal 1.0 beta 4 with SMF 1.1.9 with no problems.  In fact, you can see the Newton theme installed on my test forum with just such a configuration by looking here ...
http://talesofthehavenexpanse.com/smf1test/index.php?theme=10

I suggest that you setup a separate test site and try it out by doing the following ...

1.  Setup SMF 1.1.9 on a test site, a new install.
2.  Do a new install of TinyPortal 1.0 beta 4 on it.
3.  Install the Newton theme.
4.  Switch to the Newton theme on the test site to see if it works fine.
5.  Switch back to the SMF default theme and install your other SMF Mods, one at a time.
6.  Edit the Newton theme to work with the new Mods.

After doing this, check to be sure you aren't getting the errors you mention.  It seems that something is not installed correctly on your main site.

Keep in mind a couple of things ...

1.  All Mods, including TinyPortal must be installed when your forum is set to the SMF default theme.
2.  All Mods are only installed to work with the default theme.  For this reason, if you want the Mods to work with your custom theme, the files for the custom theme mst be edited to work with the theme.
3.  In order to upgrade from TP 0.98 to TP 1.0 beta 4, you must uninstall TP 0.98 first.
4.  Once you have upgraded, you can't go back to TP 0.98 unless you have a backup of the database as it was before with TP 0.98

ZarPrime

anabelen

  • Guest
Re: Problema con Servidor MySQL
« Reply #13 on: July 06, 2009, 07:17:23 AM »
Gracias, seguiré tus consejos  ;)

Saludos.

anabelen

  • Guest
Re: Problema con Servidor MySQL
« Reply #14 on: July 17, 2009, 10:47:54 AM »
Hasta hoy no me ha dado mas problemas, muchas gracias por vuestra ayuda  ;)

Saludos.

In English ...

Until today I have had no more problems, thank you very much for your help

Greetings.   ;)

Offline ZarPrime

  • Friends
  • *
  • Posts: 4653
Re: Problema con Servidor MySQL
« Reply #15 on: July 17, 2009, 03:13:11 PM »
You're quite welcome.  I will mark this topic solved.

ZarPrime