TP-Docs
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media

Recent

Welcome to TinyPortal. Please login or sign up.

April 21, 2024, 12:03:42 AM

Login with username, password and session length
Members
  • Total Members: 3,885
  • Latest: Growner
Stats
  • Total Posts: 195,165
  • Total Topics: 21,219
  • Online today: 174
  • Online ever: 3,540 (September 03, 2022, 01:38:54 AM)
Users Online
  • Users: 0
  • Guests: 60
  • Total: 60

Using some unicode symbols result in error message when saving articles...?

Started by PoML, July 26, 2023, 03:34:46 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

@rjen

Quote from: PoML on January 16, 2024, 03:38:11 PMBack to the original topic - could the mb_substr be the cause of saving Articles with unicode symbols as well?
I tried saving an article with an 📧  (email) 📱   (phone) symbols, and got the same error:
Database Error
Incorrect string value: '\xF0\x9F\x94\x90&n...' for column `c5jnzrz36_db538176`.`smf_tp_articles`.`body` at row 1
File: /customers/c/c/a/c5jnzrz36/webroots/r538174/medlemmer/forum/TinyPortal/Base.php
Line: 285

(and to reply to my own question; no those seem unrelated)

Yep complete different topic. It seems that it should work if your database collation is utf8mb4_general_ci, which it is probably not.
I read somewhere that SMF has some sort of trick to deal with it, which explains why it is not a problem in posts.

I have no clue what that trick is, so I cannot help with that...
Running Latest TP on SMF2.1 at: www.fjr-club.nl