TP-Docs
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media

Recent

Welcome to TinyPortal. Please login or sign up.

May 28, 2023, 11:20:55 PM

Login with username, password and session length
Members
  • Total Members: 3,864
  • Latest: Joonoz
Stats
  • Total Posts: 194,355
  • Total Topics: 21,157
  • Online today: 117
  • Online ever: 3,540
  • (September 03, 2022, 01:38:54 AM)
Users Online
Users: 0
Guests: 74
Total: 74

TP 2.2.2 blocks SMF 2.0.19

Started by JLavau, February 05, 2023, 04:39:26 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

JLavau

I have uploaded and installed TP vn 2.1.0 and now it works correctly.
The bug came afterwards, in ulterior versions.

Infos sur la version:
Votre version du forum: SMF 2.0.19 (plus de détails)
Version courante de SMF: SMF 2.0.19
Version de GD: bundled (2.1.0 compatible)
Serveur de base de données: Percona
Version MySQL: 5.7.23-23
PHP: 7.4.33
Version du serveur: Apache
Donne un cheval à celui qui dit la vérité : il en aura besoin pour s'enfuir.

tino

One of your blocks is likely causing the issue. Disable them all and upgrade to 2.3.0 and see if it works. If it does enable one block at a time until it breaks. Then let us know what one breaks it.

JLavau

#22
The historic site deonto-famille.info, SMF 2.0.19 and TP 2.1.0 :
33726 errors in few hours. Very near to overflow the maximum capacity of the database space (OVH)
You cannot view this attachment. .
File attached, the lastest errors : smf_log_errorsfin.sql
at address http://deonto-ethique.eu/ressources/smf_log_errorsfin.sql
A discordance exists in the version of PHP : 8.1 or 7.4.
Maybe a discordance exists also in the versions of the TP files, passed through an attempt in 2.3.0

The same kind of errors are also flowing by thousands on the mirror site : info.deonto-famille.org (SMF 2.0.19 and TP 2.1.0).

I will have to deinstall TP on both sites.
Donne un cheval à celui qui dit la vérité : il en aura besoin pour s'enfuir.

@rjen

Have you installed 2.1.0 on a database that had 2.3.0 installed?

Then you will have to manually delete all you blocks and create them again.

The database structure for blocks was updated in 2.3.0, and there is no way to go back to previous versions without manually recreating your blocks...

This is also stated in the download...

QuoteThis version contains an update of the internal block variable handling: after this upgrade there is no returning to older TinyPortal versions while keeping the existing blocks intact!
Running Latest TP on SMF2.1 at: www.fjr-club.nl

@rjen

I see you edited your post after I replied. Again: you can repair your site by deleting all blocks and create the again.

Of course, if you feel you do not need TinyPortal on your site, feel free to remove it...
Running Latest TP on SMF2.1 at: www.fjr-club.nl