TP-Docs
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media

Recent

Welcome to TinyPortal. Please login or sign up.

March 21, 2023, 02:34:28 AM

Login with username, password and session length
Members
Stats
  • Total Posts: 194,243
  • Total Topics: 21,145
  • Online today: 40
  • Online ever: 3,540
  • (September 03, 2022, 01:38:54 AM)
Users Online
Users: 0
Guests: 25
Total: 25

Unable to load the 'main_above' template.

Started by Freddy, September 04, 2022, 12:59:23 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Freddy

Hello! Long time since I played!

On a site I help with we were forced to upgrade to SMF 2.1.2 and so we got the 2.2.2 version of TP.

The backend in admin works, but if we try to navigate to say downloads, we get this error and I wondered if anyone had any ideas please?

URL: <site>/index.php?action=tportal;sa=download;dl

Error: Unable to load the 'main_above' template.

Been a long time since I worked with TP so thought I would ask first.

Cheers :)

tino

Trying that url on this site works ok. So it's not something I have missed when moving thing around.

The main_above is generally when you are trying to load a page when it doesn't exist. Do you have any modifications or changes on there? Maybe in a block or something similar. There should be more details logged in the SMF Error Log if you could provide those that will help also.

Can you provide a link to the site in question so I can see what is going on?

Freddy

#2
Hi Tino :)

The error comes when accessing Downloads from the main menu and also when trying to access the Downloads section in the TP Admin Panel.

Here's the site page: https://datahopa.co.uk/index.php?action=tportal;sa=download;dl

The home page is empty at the moment.

Error message:

Quote
Guest
90.*.*.*
5e257d61837438fcd3595ea97f59068f
https://datahopa.co.uk/index.php?action=tportal;sa=download;dl

Type of error: Template
Error messageSelect
Unable to load the 'main_above' template.

Backtrace:

Quote
Error

Type of error
Template

Error message
Unable to load the 'main_above' template.

URL of page causing the error
https://datahopa.co.uk/index.php?action=tportal;sa=download;dl

Backtrace information
#0: loadSubTemplate()
Called from /home/datahopa/public_html/Sources/Subs.php on line 4555
#1: template_header()
Called from /home/datahopa/public_html/Sources/Subs.php on line 4162
#2: obExit()
Called from /home/datahopa/public_html/index.php on line 194

It's not blocks I don't think, this is not a custom page, it's the TP Download page.

tino

Thanks, can you confirm what TP files you have in the themes folder? I'm wondering if somehow some weren't installed.

What was the version of TinyPortal before you did the upgrade?

@rjen

Just curious, I was looking at your site and tried to access the default theme because I seem to remember that there is some dependency in the index template file.

It seems that the default SMF (Curve2) is missing?

This links should basically bring me to the default SMF theme, but it  does not?
https://datahopa.co.uk/index.php?theme=1

What exactly happened there?
Running Latest TP on SMF2.1 at: www.fjr-club.nl

Data

Hello chaps, I'm working with Freddy on the site datahopa, he asked me to jump in as I have access to all the sites files.

I was forced to update the site to SMF 2 as the server was no longer supporting php5, I know I should have updated a long time ago but I had made a lot of custom mods and files that wouldn't have worked with SMF2. Please don't tell me off about that  :)

The old site was running a Beta version of TP perfectly well for many years, seriously many years and I loved working with TP on the site. Again I never updated TP.

So that's the Story.

Can a new member use attachments?  I will try.

Attached is a pic of the TP files located in the default theme.

Yes the default theme is installed on the site but not being used.

Thanks for any help.

@rjen

WHAT beta version of TP was being used? Version number please...
Running Latest TP on SMF2.1 at: www.fjr-club.nl

@rjen

Question 1: does the same error appear when you are using the Default SMF theme?
(I can't test it, because the theme is apparently not selectable)

Question 2: what theme are you using now, can you share a download link?
Never mind: it is this one I guess...

https://custom.simplemachines.org/index.php?theme=2960
Running Latest TP on SMF2.1 at: www.fjr-club.nl

Data

Thanks for the reply @rjen

Ok I went digging and found the version:

TinyPortal 10rc1


I will get back to you regarding the error with the default theme ASAP

@rjen

Just installed Fusion on a test forum with TinyPortal 2.2.3 on it, and it works fine...

Would you mind uninstalling TP and re-installing it? Or did you try that already?
Running Latest TP on SMF2.1 at: www.fjr-club.nl