TP-Docs
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media

Recent

Welcome to TinyPortal. Please login or sign up.

November 29, 2023, 10:42:23 PM

Login with username, password and session length
Members
Stats
  • Total Posts: 194,608
  • Total Topics: 21,188
  • Online today: 196
  • Online ever: 3,540
  • (September 03, 2022, 01:38:54 AM)
Users Online
Users: 0
Guests: 64
Total: 64

TinyPortal fix for upgrading in SMF2.1.3

Started by @rjen, January 31, 2023, 09:59:46 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

@rjen

This mod package provides a solution to Upgrade Tinyportal on SMF2.1.3

Due to a bug in SMF2.1.3 upgrading TinyPortal will result in below error message.
QuoteAll parts of a PRIMARY KEY must be NOT NULL; if you need NULL in a key, use UNIQUE instead

Attached MOD package can be installed on SMF2.1.3 to allow the upgrade of TinyPortal

Fix DBPackages

Current Version: 1.0
Compatibility: SMF 2.1.3                       



Notice
This patch will replace the files DbPackages-mysql.php and DbPackages-postgresql.php with the version for SMF2.1.4. This is needed to be able to upgrade the TinyPortal package while on SMF2.1.3. Uninstalling the package will retrun the files to the code as delivered in SMF2.1.3, which should allow the forum to be patched to SMF2.1.4 without issues.



Installation
Please note that this package is ONLY for SMF2.1.3 and must be uninstalled prior to upgrading to SMF 2.1.4



Support
This package is created by the TinyPortal support team.

30/01/2023 - v1.0
^ Initial release.
Download:
https://www.tinyportal.net/index.php?action=tportal;sa=download;dl=item177
Running Latest TP on SMF2.1 at: www.fjr-club.nl