Login  |  Register
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media

Recent

Welcome, Guest. Please login or register.
Did you miss your activation email?

August 16, 2022, 09:34:17 AM

Login with username, password and session length
Members
  • Total Members: 3842
  • Latest: Kokoro
Stats
  • Total Posts: 193479
  • Total Topics: 21088
  • Online today: 55
  • Online ever: 1035
  • (November 26, 2020, 04:45:12 AM)
Users Online
Users: 1
Guests: 34
Total: 35

Author Topic: Elkarte TinyPortal Testing  (Read 17829 times)

0 Members and 1 Guest are viewing this topic.

Offline tino

  • Developer
  • *
  • Posts: 2613
Re: Elkarte TinyPortal Testing
« Reply #60 on: February 08, 2021, 03:44:34 PM »
Thanks, I’ll sort those later tonight.

Same issue as last time. I haven’t moved it all across it seems.

tino, I'm guessing this error is also stopping the articles displaying on the front page, and the reason the "Toggle show on front page" button wont stay selected? If not there's another issue.

If it’s showing an error in the log when you press them then yes that’s it.

I’ll check them both out later, I thought there would be loads of issues after my last change as it was the biggest one.

Offline tino

  • Developer
  • *
  • Posts: 2613
Re: Elkarte TinyPortal Testing
« Reply #61 on: February 08, 2021, 05:57:49 PM »
Thanks, I’ll sort those later tonight.

Same issue as last time. I haven’t moved it all across it seems.

tino, I'm guessing this error is also stopping the articles displaying on the front page, and the reason the "Toggle show on front page" button wont stay selected? If not there's another issue.

Those are all fixed.

Offline lurkalot

  • Administrator
  • *
  • Posts: 7409
    • Camera Craniums
Re: Elkarte TinyPortal Testing
« Reply #62 on: February 09, 2021, 12:58:58 AM »
Thanks, I’ll sort those later tonight.

Same issue as last time. I haven’t moved it all across it seems.

tino, I'm guessing this error is also stopping the articles displaying on the front page, and the reason the "Toggle show on front page" button wont stay selected? If not there's another issue.

Those are all fixed.


Ok, seems to work, and articles now show on front page, and the "Toggle show on front page" button button sticks as it should, but it's still putting a error in the log when you toggle it,

Type of error: Template
Unable to load the 'main' template.
http://elkarte4.test/index.php?action=admin;area=tparticles;sa=ajax;artfront=1;ai9o9N4=ok704c6q80iab6lwIostvdYvfNXb91Tr
File: C:/laragon/www/elkarte4/sources/Templates.class.php
Line: 510
[/quote]

Offline tino

  • Developer
  • *
  • Posts: 2613
Re: Elkarte TinyPortal Testing
« Reply #63 on: February 09, 2021, 09:21:21 AM »
Thanks, I’ll sort those later tonight.

Same issue as last time. I haven’t moved it all across it seems.

tino, I'm guessing this error is also stopping the articles displaying on the front page, and the reason the "Toggle show on front page" button wont stay selected? If not there's another issue.

Those are all fixed.


Ok, seems to work, and articles now show on front page, and the "Toggle show on front page" button button sticks as it should, but it's still putting a error in the log when you toggle it,

Type of error: Template
Unable to load the 'main' template.
http://elkarte4.test/index.php?action=admin;area=tparticles;sa=ajax;artfront=1;ai9o9N4=ok704c6q80iab6lwIostvdYvfNXb91Tr
File: C:/laragon/www/elkarte4/sources/Templates.class.php
Line: 510
Thanks, that's now fixed. Are there any other errors?

Offline lurkalot

  • Administrator
  • *
  • Posts: 7409
    • Camera Craniums
Re: Elkarte TinyPortal Testing
« Reply #64 on: February 09, 2021, 10:38:17 AM »
Well, just found another one,

How to redirect after login > Redirect to frontpage gives a error when you logout.

This one on page,

Database Error
Please try again. If you come back to this error screen, report the error to an administrator.

And this one in log.

Type of error: Database
Database Error: Unknown column 'var.access' in 'where clause'
http://elkarte4.test/index.php?
File: C:/laragon/www/elkarte4/TinyPortal/Model/Database.php
Line: 43

Offline tino

  • Developer
  • *
  • Posts: 2613
Re: Elkarte TinyPortal Testing
« Reply #65 on: February 09, 2021, 10:42:29 AM »
Well, just found another one,

How to redirect after login > Redirect to frontpage gives a error when you logout.

This one on page,

Database Error
Please try again. If you come back to this error screen, report the error to an administrator.

And this one in log.

Type of error: Database
Database Error: Unknown column 'var.access' in 'where clause'
http://elkarte4.test/index.php?
File: C:/laragon/www/elkarte4/TinyPortal/Model/Database.php
Line: 43

I wonder if that's also a bug in TinyPortal for SMF, as I don't recall changing that.

Offline tino

  • Developer
  • *
  • Posts: 2613
Re: Elkarte TinyPortal Testing
« Reply #66 on: February 09, 2021, 10:45:25 AM »
Well, just found another one,

How to redirect after login > Redirect to frontpage gives a error when you logout.

This one on page,

Database Error
Please try again. If you come back to this error screen, report the error to an administrator.

And this one in log.

Type of error: Database
Database Error: Unknown column 'var.access' in 'where clause'
http://elkarte4.test/index.php?
File: C:/laragon/www/elkarte4/TinyPortal/Model/Database.php
Line: 43

I wonder if that's also a bug in TinyPortal for SMF, as I don't recall changing that.

I also can't replicate it. What is set to display on your frontpage?

Offline lurkalot

  • Administrator
  • *
  • Posts: 7409
    • Camera Craniums
Re: Elkarte TinyPortal Testing
« Reply #67 on: February 09, 2021, 10:55:18 AM »

I also can't replicate it. What is set to display on your frontpage?

Just one html article, and also one html block which reside in the left panel.  These are in addition to the stock blocks.

And in front page settings I have, What to display on frontpage set to "Only articles"

Offline tino

  • Developer
  • *
  • Posts: 2613
Re: Elkarte TinyPortal Testing
« Reply #68 on: February 09, 2021, 11:17:14 AM »

I also can't replicate it. What is set to display on your frontpage?

Just one html article, and also one html block which reside in the left panel.  These are in addition to the stock blocks.

And in front page settings I have, What to display on frontpage set to "Only articles"

Does that give the error as a guest user? I don’t think it’s related to that setting.

Also what is the structure of your tp_categories table?

Offline lurkalot

  • Administrator
  • *
  • Posts: 7409
    • Camera Craniums
Re: Elkarte TinyPortal Testing
« Reply #69 on: February 09, 2021, 01:14:12 PM »

Does that give the error as a guest user? I don’t think it’s related to that setting.


Well you say that but it doesn't give the error if you select "Only forum-topics" etc, so that's what made me think it's something to do with that setting.  It gives me the error on page as soon as I click logout when that setting is set.

Table structure, in screenshot below.