TP-Docs
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media

Recent

Welcome to TinyPortal. Please login or sign up.

April 15, 2024, 09:44:06 AM

Login with username, password and session length
Members
  • Total Members: 3,885
  • Latest: Growner
Stats
  • Total Posts: 195,156
  • Total Topics: 21,219
  • Online today: 65
  • Online ever: 3,540 (September 03, 2022, 01:38:54 AM)
Users Online
  • Users: 1
  • Guests: 50
  • Total: 51
  • illori

TP Admin problem

Started by Mike66, December 16, 2023, 12:53:42 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Mike66

When I try to delete a block using the red X, or move a block using the blue arrows, I get the "Are you sure you want to ....." pop up, but when I click OK - I get a "This page isn't working" error?

Just wondering if it is a common problem with an easy fix?

I'm running TP 2.1.0 and SMF 2.0.19.

Cheers
Mike

@rjen

Not a common problem.

But if you are on TP2.1.0 the first thing I recommend that you first upgrade to 2.3.1 and try again
Running Latest TP on SMF2.1 at: www.fjr-club.nl

Mike66

Thanks @rjen

I enabled error logs and got the following:

mysite/forum/index.php?action=tpadmin;fcb2e29c=af6db508b6424770ab80b90b5396adc2;blockbottom=29

4096: Argument 4 passed to TinyPortal\Base::updateSQL() must be an instance of TinyPortal\string, string given, called in mysite/forum/TinyPortal/Block.php on line 338 and defined

File: mysite/forum/TinyPortal/Base.php
Line: 275


Interesting - I was able to delete blocks and move them as normal with error logs enabled, but when I disabled error logs again the buttons stopped working.

@rjen

So are you on TinyPortal 2.3.1 now?
Running Latest TP on SMF2.1 at: www.fjr-club.nl

Mike66

Quote from: @rjen on December 16, 2023, 06:40:14 PMSo are you on TinyPortal 2.3.1 now?

No, I haven't upgraded it yet.

I tried to upgrade SMF from 2.0.17 to 2.0.19 a while ago and failed.
Detailed Version Check shows my SMF package version as 2.0.17 and current version as ??

Everything on the forum is working well apart from this little TP admin glitch @rjen, so I am not sure about upgrading anything at the moment, as I don't want to break it.

Does TP 2.3.1 work with SMF 2.0.17?

@rjen

Running Latest TP on SMF2.1 at: www.fjr-club.nl

tino

I think you are running an older version of PHP to get that error.

It's unlikely that 2.3.1 will work if that's the case.

@rjen

he says he is using 2.1.0: that required PHP 7.2 or higher...
Running Latest TP on SMF2.1 at: www.fjr-club.nl

Mike66

Yes, that's the conclusion I've come to  :(

I uninstalled 2.1.0 ready to install 2.3.1 - bad mistake.

Although I already had 2.1.0 installed, I can't install either now.

I guess my host must have lowered the php version without me realising. I can't get in to my hosting control panel tonight either so I have raised a help ticket with them.

What a pain, I had a gut feeling that I would break it if I tried - so I've lost my front page and TP blocks until I can get it fixed.

Mike66

G'morning @rjen and tino

My web hosting guys got back to me, it had been moved to another server (which was running on 5.6) and they hadn't given me the new control panel details yet.

I used the new control panel to up the php to 7.2 and then installed TP 2.1.0 again.

That is everything fixed, front page and blocks are back and the buttons in TP Admin are now working  :)

Thanks for your help, I really like all the TP features on my forum!

Cheers
Mike