News: May 7th, 2018, The Tinyportal team is pleased to announce the release of ~~ TinyPortal 1.5.0! GET IT NOW!!!

Login  |  Register
* *
TinyPortal on Twitter
Welcome, Guest. Please login or register.
Did you miss your activation email?
May 24, 2018, 10:02:33 AM

Login with username, password and session length

Recent

Members
Stats
  • Total Posts: 183788
  • Total Topics: 20461
  • Online Today: 60
  • Online Ever: 383
  • (January 02, 2015, 05:58:49 AM)
Users Online
Users: 4
Guests: 33
Total: 37

Skinz





amazon.com

Author Topic: Tiny Portal 1.3 will not show both TP articles and forum posts on front page  (Read 879 times)

0 Members and 1 Guest are viewing this topic.

Offline djkimmel

  • Newbie
  • *
  • Posts: 3
Link to my site: http://www.kentuckylakebass.com
SMF version: SMF 2.0.15
TP version: TP 1.3
Default Forum Language: English
Theme name and version: SMF Curve slightly modified
Browser Name and Version: Any I've tried the major ones
Mods installed: Bad Behavior 1.5.20, Simple Audio Video Embedder 4.2.1, Google Analytics Code 1.5.1, Stop Spammer 2.3.9
Related Error messages: No actual error message, but feature not working apparently.

When I picked TP I did so because I thought it could show BOTH TP articles and forum posts on the front page with the setting: 'Forum-posts and articles - sorted on date.' I originally posted on the SMF Tiny Portal forum thread that I spent several hours trying to figure it out without getting it to post both.

I can only show TP articles on the Front Page with the above setting no matter the combination of options I try. No forum posts will show. Depending on the options it will sometimes only show 1 article on 'page 1' and the 2nd article on 'page 2' also. I don't have a lot of content on this website.

lurkalot was kind enough to reply on the SMF forum that this appears to be a bug introduced while applying PHP 7 fixes. I wondered if and when this might be fixed? It was mentioned I might be able to 'run TP 1.2 with a slight edit to the user block login form.'

Not sure what this is about?

While I'm running PHP 5.6 right now on my server I am planning on moving to a new server later this year that will probably have me converting to PHP 7.

Offline lurkalot

  • Administrator
  • *
  • Posts: 4550
    • Camera Craniums
Unfortunatly I was wrong regarding the use of the older portal version, that won't cure the problem.

I originally thought I'd messed up somewhere when applying the fixes for php 7, because it was the only changes made to this version other than the login seesion check fix.  But it turns out that the problem started when updating to SMF 2.0.14  This version of SMF broke quite a few things and unfortunatly this is one of them. 

At this moment we don't have a fix for it. Sorry.
Mick aka lurkalot.

Camera Craniums Running SMF 2.0.13 / Tinyportal 1.3
Guitarist Guild Running SMF 2.0.15 / Tinyportal 1.4R Beta
The Garden Machinery Forum Running SMF 2.0.15 / Tinyportal 1.4R Beta

Offline matthew

  • Jr. Member
  • **
  • Posts: 5
Just adding that I have this, too. Fresh SMF 2.0.15/TP 1.3/SMF Tricks theme. Nothing else at all.

I'm not sure of the discussion elsewhere, but I see my promoted forum topic if I choose "Selected topics only" (as expected), and only my articles if I choose either "Only articles" (as expected) or "Selected topics + articles"

If it's in your bug tracker, I guess I'll have to wait. :)

Offline tino

  • Developer
  • *
  • Posts: 687
Just adding that I have this, too. Fresh SMF 2.0.15/TP 1.3/SMF Tricks theme. Nothing else at all.

I'm not sure of the discussion elsewhere, but I see my promoted forum topic if I choose "Selected topics only" (as expected), and only my articles if I choose either "Only articles" (as expected) or "Selected topics + articles"

If it's in your bug tracker, I guess I'll have to wait. :)

This is actually fixed in TP 1.4R, if you want to download the beta release, join the beta team in your profile options.

The link to all the fixes and new features, in this release is here; https://www.tinyportal.net/index.php?topic=35967.0




Offline lurkalot

  • Administrator
  • *
  • Posts: 4550
    • Camera Craniums
Edit: tino beat me to it.  :-[ Both post apply though.

Just adding that I have this, too. Fresh SMF 2.0.15/TP 1.3/SMF Tricks theme. Nothing else at all.

I'm not sure of the discussion elsewhere, but I see my promoted forum topic if I choose "Selected topics only" (as expected), and only my articles if I choose either "Only articles" (as expected) or "Selected topics + articles"

If it's in your bug tracker, I guess I'll have to wait. :)

It' definitely a Tinyportal bug. sorry.  We have fixed it in the next version which is on test atm.  You can either wait for that release, or if you're ok with editing files I can provide a fix for it, just one small edit.

As we're on the subject of testing, we need testers for Tinyportal 1.4R if you're interested and you have a test site. Just join the responsive beta testers group via your profile under group membership. Then head to the Tinyportal Responsive Beta Testing Board.
Mick aka lurkalot.

Camera Craniums Running SMF 2.0.13 / Tinyportal 1.3
Guitarist Guild Running SMF 2.0.15 / Tinyportal 1.4R Beta
The Garden Machinery Forum Running SMF 2.0.15 / Tinyportal 1.4R Beta

Offline matthew

  • Jr. Member
  • **
  • Posts: 5
Good as gold, gentlemen. 1.4R installed and problem solved. Thanks very much! :)

Offline lurkalot

  • Administrator
  • *
  • Posts: 4550
    • Camera Craniums
Good as gold, gentlemen. 1.4R installed and problem solved. Thanks very much! :)

Matthew, thanks for trying TP 1.4R, I hope it works well for you.  If you find any problems or wish to give feedback on this version please let us know in the bugs errors board, https://www.tinyportal.net/index.php?board=89.0
Mick aka lurkalot.

Camera Craniums Running SMF 2.0.13 / Tinyportal 1.3
Guitarist Guild Running SMF 2.0.15 / Tinyportal 1.4R Beta
The Garden Machinery Forum Running SMF 2.0.15 / Tinyportal 1.4R Beta