Login  |  Register
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media

Recent

Welcome, Guest. Please login or register.
Did you miss your activation email?

December 08, 2021, 06:52:03 AM

Login with username, password and session length
Members
  • Total Members: 3831
  • Latest: pulgoki
Stats
  • Total Posts: 192617
  • Total Topics: 21020
  • Online Today: 152
  • Online Ever: 1035
  • (November 26, 2020, 04:45:12 AM)
Users Online
Users: 0
Guests: 95
Total: 95

Author Topic: Issue with look of forum post upgrade to TP 2.1.0  (Read 1884 times)

0 Members and 1 Guest are viewing this topic.

Offline VladTepes

  • Jr. Member
  • **
  • Posts: 90
Issue with look of forum post upgrade to TP 2.1.0
« on: September 07, 2021, 01:34:49 AM »
I just upgraded my forum to PHP 7.4 (from 5.6) and upgraded to TinyPortal  2.1.0

While the settings still seem to have carried over, those settings aren't displayed.

What do I mean?
Well I have the right panel activated
In that panel I have the recent topics block activated.

But as you can see here https://gsx1400owners.org/forum/index.php?action=forum
and here https://gsx1400owners.org/forum/index.php?board=1.0
The right hand sidebar with recent topics does not appear.

The same applies to the bottom panel which I have activated, and the bottom panel stats block is activated but that's also not visible.

Please help :)


Offline @rjen

  • Support Team
  • *
  • Posts: 2973
    • FJR-club Nederland
Re: Issue with look of forum post upgrade to TP 2.1.0
« Reply #1 on: September 07, 2021, 01:48:51 AM »
Hmm, why are you posting both on SMF and here?

Can you see the panels and blocks as admin?

Have you checked the panel settings?
> make sure there are set to show

Can you check the 'allow panels to be collapsed' setting
> switch it on and then collapse and open the panels, it may be a cookie issue...

Have you checked the block permissions?
Running TP2.1.0 on SMF2.0 at: www.fjr-club.nl

Testing TP on SMF2.0
Testing TP on SMF2.1 (latest Github)
Want to check what php version I am testing on? See: PHP Info

Offline lurkalot

  • Administrator
  • *
  • Posts: 7334
    • Camera Craniums
Re: Issue with look of forum post upgrade to TP 2.1.0
« Reply #2 on: September 07, 2021, 11:44:45 AM »

I just upgraded my forum to PHP 7.4 (from 5.6) and upgraded to TinyPortal  2.1.0


What version of TinyPortal were you running prior to upgrading?  And how exactly did you upgrade?

Offline lurkalot

  • Administrator
  • *
  • Posts: 7334
    • Camera Craniums
Re: Issue with look of forum post upgrade to TP 2.1.0
« Reply #3 on: September 08, 2021, 01:02:48 AM »
By the look of the forum, it appears to be behaving a bit odd all round.  No info centre showing etc.  Was this disabled in some way on purpose? And did you make sure SMF was all working properly before you installed TP?

Offline VladTepes

  • Jr. Member
  • **
  • Posts: 90
Re: Issue with look of forum post upgrade to TP 2.1.0
« Reply #4 on: September 08, 2021, 01:28:08 AM »
Hmm, why are you posting both on SMF and here?

i posted there first and then figured here might be a better place.

Can you see the panels and blocks as admin?
No

Have you checked the panel settings?
> make sure there are set to show
They are

Can you check the 'allow panels to be collapsed' setting
> switch it on and then collapse and open the panels, it may be a cookie issue...

I did a forced refresh, but will try that now.

Have you checked the block permissions?

They should have been carried over surely. I'll check.

What version of TinyPortal were you running prior to upgrading?  And how exactly did you upgrade?

I was running 1.5.1
I simply uninstalled the old one and installed the new one.

By the look of the forum, it appears to be behaving a bit odd all round.  No info centre showing etc.  Was this disabled in some way on purpose?

IIRC the SMF info centre I disabled and used the TinyPortal one instead?
I may be mistaken on that, it's been a while. 

And did you make sure SMF was all working properly before you installed TP?
Not extensively but it all seemed to be working fine at the time (TP excepted).

I have since discovered that 'like posts' no longer works but I haven't changed that mod at all, so that's an unrelated issue to the TP issue.


Offline lurkalot

  • Administrator
  • *
  • Posts: 7334
    • Camera Craniums
Re: Issue with look of forum post upgrade to TP 2.1.0
« Reply #5 on: September 08, 2021, 01:37:34 AM »
Ok, so what mods do you  have installed? 

I'm wondering if there's some sort of conflict thing going on, 

Offline lurkalot

  • Administrator
  • *
  • Posts: 7334
    • Camera Craniums
Re: Issue with look of forum post upgrade to TP 2.1.0
« Reply #6 on: September 08, 2021, 11:28:26 AM »
Ok, managed to get a look under the hood.  The blocks were not sowing because the "Use language visibility option for blocks" setting was enabled.

Although this was enabled in TP settings, it wasn't enabled in the blocks themselves.  Anyway I've disabled it and your blocks are back.

Also took the liberty of unchecking the curve theme from "Select unresponsive themes" setting, as you have the Responsive curve mod installed you might as well have the portal responsive as well. You ca check it again if you don't want this for some reason.  ;)

Offline @rjen

  • Support Team
  • *
  • Posts: 2973
    • FJR-club Nederland
Re: Issue with look of forum post upgrade to TP 2.1.0
« Reply #7 on: September 08, 2021, 11:58:25 AM »
Ha, now it makes sense... he came from 1.5.1.

There was an issue with the language visibility settings that was fixed in 1.6.4. Since that is quite a while ago I did not think of that...

Quote
TINYPORTAL 1.6.4
September 21, 2019

Changelog;

This release includes the following fixes:

Relevant to 2.0 and 2.1:
- added functionality for social buttons to use 'query title' for article links
- updated menu manager to use 'query titles' for articles and 'short names' for categories
- added language visibility functionality to frontpage blocks
- added extra layout option to articles: 'Use frame style, but not title style'. This allows for removal of title bar for articles without titles
- updated source code and templates for better html5 compliance
- fixed error '8: Undefined variable: count' due to function art_recentitems
- fixed language visibility for blocks not working correctly
- fixed do_hooks.php function not running to manually add/remove hooks
....
Running TP2.1.0 on SMF2.0 at: www.fjr-club.nl

Testing TP on SMF2.0
Testing TP on SMF2.1 (latest Github)
Want to check what php version I am testing on? See: PHP Info

Offline lurkalot

  • Administrator
  • *
  • Posts: 7334
    • Camera Craniums
Re: Issue with look of forum post upgrade to TP 2.1.0
« Reply #8 on: September 08, 2021, 12:35:02 PM »
Ha, now it makes sense... he came from 1.5.1.

There was an issue with the language visibility settings that was fixed in 1.6.4. Since that is quite a while ago I did not think of that...


I'd forgotten about that too if I'm honest.. lol.  ;)

Offline VladTepes

  • Jr. Member
  • **
  • Posts: 90
Re: Issue with look of forum post upgrade to TP 2.1.0
« Reply #9 on: September 15, 2021, 05:39:49 PM »
Thanks all, I appreciate it :)