TP-Docs
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media

Recent

Welcome to TinyPortal. Please login or sign up.

July 21, 2024, 02:01:41 PM

Login with username, password and session length
Members
Stats
  • Total Posts: 195,333
  • Total Topics: 21,233
  • Online today: 103
  • Online ever: 3,540 (September 03, 2022, 01:38:54 AM)
Users Online
  • Users: 0
  • Guests: 55
  • Total: 55

Menu feedback

Started by Oldiesmann, June 06, 2019, 04:02:45 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Oldiesmann


Long story short, I recently took over a couple of websites I've been helping out with for years following the death of the owner. One of the sites is made up of dozens of static pages plus the forum (currently using EhPortal to display blocks on the forum). I'm hoping to move everything to a single combined site/forum using TP's article system in place of the static pages.


Anyway, I have some feedback regarding the menu block...
1. There doesn't seem to be a way to do a horizontal layout
2. When you add a page as a menu item, it uses the page ID for the link rather than the query title.

lurkalot

Thanks for feedback on the menu block. 

This block was and still is primarily designed for use in a side panel, it never got a makeover in later versions.  Maybe it's time to give this some consideration. 

Regarding the links to pages not using the query title, we need to check that, pretty sure it was working.

lurkalot

Confirmed.

As a workaround add the page to the menu as a link instead of choosing the article from the dropdown.

But I tested this in TP 1.6.1 and the query title works as expected, so somethin broke between 1.6.1 and 1.6.3

@rjen

Quote from: lurkalot on June 06, 2019, 07:43:49 AM
But I tested this in TP 1.6.1 and the query title works as expected, so somethin broke between 1.6.1 and 1.6.3

I just checked the code and I seriously doubt if the menu has ever linked to the query title. It is simply not captured and also not retrieved when showing the menu...

Same applies to the Category links by the way...
Running Latest TP on SMF2.1 at: www.fjr-club.nl

lurkalot

Quote from: @rjen on June 06, 2019, 05:13:00 PM
Quote from: lurkalot on June 06, 2019, 07:43:49 AM
But I tested this in TP 1.6.1 and the query title works as expected, so somethin broke between 1.6.1 and 1.6.3

I just checked the code and I seriously doubt if the menu has ever linked to the query title. It is simply not captured and also not retrieved when showing the menu...

Same applies to the Category links by the way...

Then I must have something strange goin on with my version of 1.6.1 

If you look at the Quick links menu half way down on the left, https://cameracraniums.com/forum/

Click or hover over the links page (Link) You can see it uses the query title. This is with an article selected as the menu item, not a link. I'll add some screenshots of my settings below actually, so you can see what I have set.

@rjen

I see what you mean, but I just compared 1.6.1 ad 1.6.3 code, and that does not explain it...

I just installed 1.6.1 on my test site and it still does not use the query title.
Can you please try to create a NEW menu item to an article in your test forum and check that entry?

I am suspecting it will not work with the query title...(meaning that you created the working entry in an older version of TP)

then please go to the database and check the content of tp_variables table for all items of type menubox and tell me waht the values are in column value3.

They will state 'arti'something...
Running Latest TP on SMF2.1 at: www.fjr-club.nl

lurkalot

Quote from: @rjen on June 06, 2019, 06:35:17 PM

I am suspecting it will not work with the query title...(meaning that you created the working entry in an older version of TP)


I'm thinking you're right about the older version thing.  Haven't tried to add a new item yet, but viewing the edit for that item it says Article, but shows the list of articles as if none of them are actually selected.

That said, if it was created via an older version then surely it's got broken at some point.  It should really pick up the query title where used, much like the share buttons which you kindly fixed in 1.6.4

@rjen

Agreed, that would be the correct way. Still would like to know what is in you tp_variables table... I think it will say 'arti+query title ' and not 'arti+Id'
Running Latest TP on SMF2.1 at: www.fjr-club.nl

lurkalot

Quote from: @rjen on June 06, 2019, 08:02:39 PM
Agreed, that would be the correct way. Still would like to know what is in you tp_variables table... I think it will say 'arti+query title ' and not 'arti+Id'

Just got to take a look.  At the moment without adding a new item is says, artiLinks

Will go a add a new one and report back

@rjen

Thanks, that's what I suspected
Running Latest TP on SMF2.1 at: www.fjr-club.nl