TP-Docs
HTML5 Icon HTML5 Icon HTML5 Icon
TP on Social Media

Recent

Welcome to TinyPortal. Please login or sign up.

October 04, 2023, 07:41:42 AM

Login with username, password and session length
Members
Stats
  • Total Posts: 194,550
  • Total Topics: 21,182
  • Online today: 84
  • Online ever: 3,540
  • (September 03, 2022, 01:38:54 AM)
Users Online
Users: 0
Guests: 32
Total: 32

Unable to load the 'main_above' template.

Started by Freddy, September 04, 2022, 12:59:23 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Data

Yes as you thought it's the same on the default theme.

Before I uninstall TP, no I haven't tried it yet but I remember the downloads broke a while back on the old site, I had forgotten about that when I did the update to SMF2.

These must be related in some way. 

@rjen

What exactly do you mean with 'the downloads broke' ?

That makes me a bit suspicious...
Running Latest TP on SMF2.1 at: www.fjr-club.nl

@rjen

Need to go now but what I recommend is that you make sure to create a phpmyadmin backup of all tp_ tables from your forum.

Store that safely.

I am starting to suspect that there is something off in one of the tables.

Need to think about that a bit...
Running Latest TP on SMF2.1 at: www.fjr-club.nl

Data

Quote from: @rjen on September 06, 2022, 05:33:53 PM
What exactly do you mean with 'the downloads broke' ?

That makes me a bit suspicious...

When I clicked a link to goto the downloads nothing happened, not even an error message that I can remember.

I agree with you that there is something wrong in the DB.

@rjen

Did you use the downloads? Any entries in the tp_downloads table?

You can try this:
1. Create a full sql backup of all tp_ tables
2. Uninstall TP
3. Remove the tp_ tables from the database
4. Install TP clean

Check if it works now...
Then you can import the tp_ tables from the backup and see if it is ok...

It is a bit trial and error, best done on a test forum...
If you have that, give it a go, otherwise I am willing to test it if you can share the .sql backup of your tp_ tables.,.
Running Latest TP on SMF2.1 at: www.fjr-club.nl

Data

Thanks for all your help @rjen

I've fixed the problem - it was an old theme that the DL part of TP was looking for but the path to the theme in SMF was incorrect.


@rjen

Quote from: Data on September 07, 2022, 12:05:52 AM
Thanks for all your help @rjen

I've fixed the problem - it was an old theme that the DL part of TP was looking for but the path to the theme in SMF was incorrect.

It is nice that you found the problem: I am a bit confused though, because I cannot reproduce the error in any way:
1. Tried to delete the previously assigned theme: TinyPortal falls back to the default...
2. Tried by deliberately breaking the theme paths: TinyPortal page shows up without formatting, but it does show...

Would you mind sharing how exactly you managed to break it so it would result in the Unable to load the 'main_above' template error? Perhaps we can prevent such errors in future...
Running Latest TP on SMF2.1 at: www.fjr-club.nl

Data

Been busy here.

Sorry I can't shed any more light on the error, once I removed the bad path to the old theme it just came to life.

I wish I could give you some more info but ...

@rjen

Never mind, I was curious because I cannot reproduce it.

Since it is an edge case it is not that important.
Running Latest TP on SMF2.1 at: www.fjr-club.nl